Question...

Le
Clochard
Bon dimanche

J'ai une feuilles nommée Fiches avec une colonne nommée "Noms" et une autre
"Moyenne"
Dans la feuille 1 en C4:C100 j'ai fait une liste par cellule qui me donne
les noms inscrient dans la feulle "Fiches" j'aimerais lorsque je choisi un
nom qu'en D La moyenne de ce choix s'y affiche.

Je n'y arrive pas pourriez-vous S.V.P. me conseiller
--
Clochard
Aimerais bien savoir.
Merci!
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Garette
Le #4239521
Bonsoir,

Dans l'exemple, A1:B6 contient les noms en colonne A et les moyennes en
colonne B
Dans la feuille 1, la formules suivante renvoie la moyenne en fonction du
nom :
=RECHERCHEV(C4;Feuil1!$A$1:$B$6;2;FAUX)

"Clochard"
Bon dimanche...

J'ai une feuilles nommée Fiches avec une colonne nommée "Noms" et une
autre
"Moyenne"
Dans la feuille 1 en C4:C100 j'ai fait une liste par cellule qui me donne
les noms inscrient dans la feulle "Fiches" j'aimerais lorsque je choisi un
nom qu'en D La moyenne de ce choix s'y affiche.

Je n'y arrive pas... pourriez-vous S.V.P. me conseiller
--
Clochard
Aimerais bien savoir....
Merci!


Jacky
Le #4239491
Bonsoir,

En D4:

=INDEX(moyenne;EQUIV(C4;Noms;0))

--
Salutations
JJ



"Clochard"
Bon dimanche...

J'ai une feuilles nommée Fiches avec une colonne nommée "Noms" et une
autre
"Moyenne"
Dans la feuille 1 en C4:C100 j'ai fait une liste par cellule qui me donne
les noms inscrient dans la feulle "Fiches" j'aimerais lorsque je choisi un
nom qu'en D La moyenne de ce choix s'y affiche.

Je n'y arrive pas... pourriez-vous S.V.P. me conseiller
--
Clochard
Aimerais bien savoir....
Merci!


Clochard
Le #4237401
Merci....

Ça fonctionne très bien...

En passant... que dois-je ajouter à une formule pour que, s'il n'y a rien
d'inscrit ou a inscrire... que rien ne s'affiche... genre VALEUR ou autre....
--
Clochard
Bien content de savoir....
Merci!



Bonsoir,

Dans l'exemple, A1:B6 contient les noms en colonne A et les moyennes en
colonne B
Dans la feuille 1, la formules suivante renvoie la moyenne en fonction du
nom :
=RECHERCHEV(C4;Feuil1!$A$1:$B$6;2;FAUX)

"Clochard"
Bon dimanche...

J'ai une feuilles nommée Fiches avec une colonne nommée "Noms" et une
autre
"Moyenne"
Dans la feuille 1 en C4:C100 j'ai fait une liste par cellule qui me donne
les noms inscrient dans la feulle "Fiches" j'aimerais lorsque je choisi un
nom qu'en D La moyenne de ce choix s'y affiche.

Je n'y arrive pas... pourriez-vous S.V.P. me conseiller
--
Clochard
Aimerais bien savoir....
Merci!







Clochard
Le #4237391
Salut Jacky,

Ta suggestion fonctionne aussi très bien.... mais s.v.p. dit moi, sur quoi
devrais-je me baser pour appliquer une ou l'autre?

=INDEX(moyenne;EQUIV(C4;Noms;0))
=RECHERCHEV(C4;Feuil1!$A$1:$B$6;2;FAUX)

Y a-t-il une différence marquée ou si les deux sont applicables en tout
temps...

--
Clochard
Aimerais bien savoir....
Merci!



Bonsoir,

En D4:

=INDEX(moyenne;EQUIV(C4;Noms;0))

--
Salutations
JJ



"Clochard"
Bon dimanche...

J'ai une feuilles nommée Fiches avec une colonne nommée "Noms" et une
autre
"Moyenne"
Dans la feuille 1 en C4:C100 j'ai fait une liste par cellule qui me donne
les noms inscrient dans la feulle "Fiches" j'aimerais lorsque je choisi un
nom qu'en D La moyenne de ce choix s'y affiche.

Je n'y arrive pas... pourriez-vous S.V.P. me conseiller
--
Clochard
Aimerais bien savoir....
Merci!







Jacky
Le #4237381
Re....
Y a-t-il une différence marquée ou si les deux sont applicables en tout
temps...

L'eternel débat entre "Index,equiv " et "RechercheV"

C'est AMHA un faux débat, perso ma préférence ira vers index equiv.
Une recherche sur google , et tu trouveras certainement des avis et
arguments contraire
Chacun sa méthode........les deux sont bien ;-))

--
Salutations
JJ



"Clochard"
Salut Jacky,

Ta suggestion fonctionne aussi très bien.... mais s.v.p. dit moi, sur quoi
devrais-je me baser pour appliquer une ou l'autre?

=INDEX(moyenne;EQUIV(C4;Noms;0))
=RECHERCHEV(C4;Feuil1!$A$1:$B$6;2;FAUX)

Y a-t-il une différence marquée ou si les deux sont applicables en tout
temps...

--
Clochard
Aimerais bien savoir....
Merci!



Bonsoir,

En D4:

=INDEX(moyenne;EQUIV(C4;Noms;0))

--
Salutations
JJ



"Clochard"
Bon dimanche...

J'ai une feuilles nommée Fiches avec une colonne nommée "Noms" et une
autre
"Moyenne"
Dans la feuille 1 en C4:C100 j'ai fait une liste par cellule qui me
donne
les noms inscrient dans la feulle "Fiches" j'aimerais lorsque je choisi
un
nom qu'en D La moyenne de ce choix s'y affiche.

Je n'y arrive pas... pourriez-vous S.V.P. me conseiller
--
Clochard
Aimerais bien savoir....
Merci!









isabelle
Le #4237361
bonjour Clochard,

l'avantage à utiliser "Index,Equiv" est que la "colonne de recherche" peut être situer à droite de la plage "résultat à obtenir"
ce qui n'est pas fesable avec "Recherche"

isabelle

Salut Jacky,

Ta suggestion fonctionne aussi très bien.... mais s.v.p. dit moi, sur quoi
devrais-je me baser pour appliquer une ou l'autre?

=INDEX(moyenne;EQUIV(C4;Noms;0))
=RECHERCHEV(C4;Feuil1!$A$1:$B$6;2;FAUX)

Y a-t-il une différence marquée ou si les deux sont applicables en tout
temps...



Garette
Le #4237341
Bonsoir,

Pour ne pas avoir l'affichage #NA :
=SI(ESTNA(RECHERCHEV(C4;Feuil1!$A$1:$B$6;2;FAUX));"";RECHERCHEV(C4;Feuil1!$A$1:$B$6;2;FAUX))
=SI(ESTNA(INDEX(moyenne;EQUIV(C4;Noms;0)));"";=INDEX(moyenne;EQUIV(C4;Noms;0)))
NB - Je prefere également Index Equiv ;-)
Historiquement, On utilisait Index Equiv dans les anciennes versions d'Excel
car la fonction RechercheV obligeait que les données recherchées soient
triées.
Le 4eme argument n'existait pas.
Et comme le dit Isabelle, on peut adresser des colonnes à G à D, au dessus
et en dessous de la plage de recherche ...


"Clochard"
Merci....

Ça fonctionne très bien...

En passant... que dois-je ajouter à une formule pour que, s'il n'y a rien
d'inscrit ou a inscrire... que rien ne s'affiche... genre VALEUR ou
autre....
--
Clochard
Bien content de savoir....
Merci!



Bonsoir,

Dans l'exemple, A1:B6 contient les noms en colonne A et les moyennes en
colonne B
Dans la feuille 1, la formules suivante renvoie la moyenne en fonction du
nom :
=RECHERCHEV(C4;Feuil1!$A$1:$B$6;2;FAUX)

"Clochard"
Bon dimanche...

J'ai une feuilles nommée Fiches avec une colonne nommée "Noms" et une
autre
"Moyenne"
Dans la feuille 1 en C4:C100 j'ai fait une liste par cellule qui me
donne
les noms inscrient dans la feulle "Fiches" j'aimerais lorsque je choisi
un
nom qu'en D La moyenne de ce choix s'y affiche.

Je n'y arrive pas... pourriez-vous S.V.P. me conseiller
--
Clochard
Aimerais bien savoir....
Merci!









Clochard
Le #4237331
Merci Isabelle

Pour cette précision...

--
Clochard
Merci!



bonjour Clochard,

l'avantage à utiliser "Index,Equiv" est que la "colonne de recherche" peut être situer à droite de la plage "résultat à obtenir"
ce qui n'est pas fesable avec "Recherche"

isabelle

Salut Jacky,

Ta suggestion fonctionne aussi très bien.... mais s.v.p. dit moi, sur quoi
devrais-je me baser pour appliquer une ou l'autre?

=INDEX(moyenne;EQUIV(C4;Noms;0))
=RECHERCHEV(C4;Feuil1!$A$1:$B$6;2;FAUX)

Y a-t-il une différence marquée ou si les deux sont applicables en tout
temps...






Clochard
Le #4237321
Merci Jacky,

Pour ta réponse...
--
Clochard
Merci!



Re....
Y a-t-il une différence marquée ou si les deux sont applicables en tout
temps...

L'eternel débat entre "Index,equiv " et "RechercheV"

C'est AMHA un faux débat, perso ma préférence ira vers index equiv.
Une recherche sur google , et tu trouveras certainement des avis et
arguments contraire
Chacun sa méthode........les deux sont bien ;-))

--
Salutations
JJ



"Clochard"
Salut Jacky,

Ta suggestion fonctionne aussi très bien.... mais s.v.p. dit moi, sur quoi
devrais-je me baser pour appliquer une ou l'autre?

=INDEX(moyenne;EQUIV(C4;Noms;0))
=RECHERCHEV(C4;Feuil1!$A$1:$B$6;2;FAUX)

Y a-t-il une différence marquée ou si les deux sont applicables en tout
temps...

--
Clochard
Aimerais bien savoir....
Merci!



Bonsoir,

En D4:

=INDEX(moyenne;EQUIV(C4;Noms;0))

--
Salutations
JJ



"Clochard"
Bon dimanche...

J'ai une feuilles nommée Fiches avec une colonne nommée "Noms" et une
autre
"Moyenne"
Dans la feuille 1 en C4:C100 j'ai fait une liste par cellule qui me
donne
les noms inscrient dans la feulle "Fiches" j'aimerais lorsque je choisi
un
nom qu'en D La moyenne de ce choix s'y affiche.

Je n'y arrive pas... pourriez-vous S.V.P. me conseiller
--
Clochard
Aimerais bien savoir....
Merci!














Clochard
Le #4237311
Merci à toi aussi Garette...
--
Clochard
Merci!



Bonsoir,

Pour ne pas avoir l'affichage #NA :
=SI(ESTNA(RECHERCHEV(C4;Feuil1!$A$1:$B$6;2;FAUX));"";RECHERCHEV(C4;Feuil1!$A$1:$B$6;2;FAUX))
=SI(ESTNA(INDEX(moyenne;EQUIV(C4;Noms;0)));"";=INDEX(moyenne;EQUIV(C4;Noms;0)))
NB - Je prefere également Index Equiv ;-)
Historiquement, On utilisait Index Equiv dans les anciennes versions d'Excel
car la fonction RechercheV obligeait que les données recherchées soient
triées.
Le 4eme argument n'existait pas.
Et comme le dit Isabelle, on peut adresser des colonnes à G à D, au dessus
et en dessous de la plage de recherche ...


"Clochard"
Merci....

Ça fonctionne très bien...

En passant... que dois-je ajouter à une formule pour que, s'il n'y a rien
d'inscrit ou a inscrire... que rien ne s'affiche... genre VALEUR ou
autre....
--
Clochard
Bien content de savoir....
Merci!



Bonsoir,

Dans l'exemple, A1:B6 contient les noms en colonne A et les moyennes en
colonne B
Dans la feuille 1, la formules suivante renvoie la moyenne en fonction du
nom :
=RECHERCHEV(C4;Feuil1!$A$1:$B$6;2;FAUX)

"Clochard"
Bon dimanche...

J'ai une feuilles nommée Fiches avec une colonne nommée "Noms" et une
autre
"Moyenne"
Dans la feuille 1 en C4:C100 j'ai fait une liste par cellule qui me
donne
les noms inscrient dans la feulle "Fiches" j'aimerais lorsque je choisi
un
nom qu'en D La moyenne de ce choix s'y affiche.

Je n'y arrive pas... pourriez-vous S.V.P. me conseiller
--
Clochard
Aimerais bien savoir....
Merci!














Publicité
Poster une réponse
Anonyme