Question google map

Le
Jibé
Bonjour,

j'utilise l'API Google Map pour un site en cours de développement.
J'ai demandé une clef pour http://localhost et ça roule

J'ai besoin de déplacer ce site sur un serveur de développement toujours
en local (192.168.16.1) donc j'ai demandé une clef pour l'adresse
http://192.168.16.1 et là ça ne marche pas.
J'ai une alerte javascipt m'indiquant que cette clef est déjà utilisé et
qu'il faut que j'en demande une autre

Si quelqu'un a une idée de ce qui cloche

JiBé
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
CrazyCat
Le #22093011
Jibé wrote:
J'ai besoin de déplacer ce site sur un serveur de développement toujours
en local (192.168.16.1) donc j'ai demandé une clef pour l'adresse
http://192.168.16.1 et là ça ne marche pas.
J'ai une alerte javascipt m'indiquant que cette clef est déjà utilisé et
qu'il faut que j'en demande une autre...



Je n'ai jamais vu ça, même en créant des clés pour la même url.
Vu que la génération de clé est sans contrainte, je te conseille de
tenter d'en re-générer une.

--
Discussions et débats sur l'actualité: http://www.sujets-d-actu.eu
Réseau IRC Francophone: http://www.crazy-irc.net
Jibé
Le #22092961
CrazyCat a écrit :
Jibé wrote:
J'ai besoin de déplacer ce site sur un serveur de développement
toujours en local (192.168.16.1) donc j'ai demandé une clef pour
l'adresse http://192.168.16.1 et là ça ne marche pas.
J'ai une alerte javascipt m'indiquant que cette clef est déjà utilisé
et qu'il faut que j'en demande une autre...



Je n'ai jamais vu ça, même en créant des clés pour la même url.
Vu que la génération de clé est sans contrainte, je te conseille de
tenter d'en re-générer une.




Bonjour,
merci pour cette réponse mais c'est ce que j'ai fait et pour le moment
ça ne fonctionne pas.
J'ai essayé de faire une clef pour http://192.168.16.1
pour http://192.168.16.1/ et pour http://lenomdelamachine sans résultat
pour le moment.


JiBé
heulman
Le #22092901
"Jibé" 46b43ee2$0$5065$
J'ai essayé de faire une clef pour http://192.168.16.1
pour http://192.168.16.1/



C'est une adresse sur un réseau local. Je pense qu'il faut une IP publique
pour que ça marche (à part 127.0.0.1/localhost)

heulman
Jibé
Le #22092831
heulman a écrit :
"Jibé" 46b43ee2$0$5065$
J'ai essayé de faire une clef pour http://192.168.16.1
pour http://192.168.16.1/



C'est une adresse sur un réseau local. Je pense qu'il faut une IP publique
pour que ça marche (à part 127.0.0.1/localhost)

heulman




Oui je pense que ça vient de là moi aussi dans la mesure où les
conditions d'utilisation spécifies bien que google refuse l'usage de son
API en intranet...
JiBé
CrazyCat
Le #22092791
Jibé wrote:
Oui je pense que ça vient de là moi aussi dans la mesure où les
conditions d'utilisation spécifies bien que google refuse l'usage de son
API en intranet...



La solution qui existe alors est de faker une adresse publique sur
l'intranet en modifiant le fichier host (ou avec un serveur DNS interne)
et de faire pointer un domaine quelconque sur l'IP privée.
Par exemple:
192.168.16.1 local.mon-intra.com

Et tu enregistres la clé pour local.mon-intra.com


--
Discussions et débats sur l'actualité: http://www.sujets-d-actu.eu
Réseau IRC Francophone: http://www.crazy-irc.net
Jibé
Le #22092781
CrazyCat a écrit :
Jibé wrote:
Oui je pense que ça vient de là moi aussi dans la mesure où les
conditions d'utilisation spécifies bien que google refuse l'usage de
son API en intranet...



La solution qui existe alors est de faker une adresse publique sur
l'intranet en modifiant le fichier host (ou avec un serveur DNS interne)
et de faire pointer un domaine quelconque sur l'IP privée.
Par exemple:
192.168.16.1 local.mon-intra.com

Et tu enregistres la clé pour local.mon-intra.com




pas idiot effectivement. Merci
JiBé
xavier
Le #22092581
Bonjour,
Si c'est pour faire tourner en local, pourquoi ne pas demander une clé sur
'localhost' ?
A essayer peut-être ...
Xavier

"Jibé" 46b43ee2$0$5065$
CrazyCat a écrit :
Jibé wrote:
J'ai besoin de déplacer ce site sur un serveur de développement toujours
en local (192.168.16.1) donc j'ai demandé une clef pour l'adresse
http://192.168.16.1 et là ça ne marche pas.
J'ai une alerte javascipt m'indiquant que cette clef est déjà utilisé et
qu'il faut que j'en demande une autre...



Je n'ai jamais vu ça, même en créant des clés pour la même url.
Vu que la génération de clé est sans contrainte, je te conseille de
tenter d'en re-générer une.




Bonjour,
merci pour cette réponse mais c'est ce que j'ai fait et pour le moment ça
ne fonctionne pas.
J'ai essayé de faire une clef pour http://192.168.16.1
pour http://192.168.16.1/ et pour http://lenomdelamachine sans résultat
pour le moment.


JiBé
Publicité
Poster une réponse
Anonyme