Question.... S.V.P.

Le
Clochard
Bon dimanche,

J'ai cette formule en E2:E9 qui cherche en A1:A40 afin d'obtenir
l'emplacement du sujet demandé.

Si j'ai 8 fois le même sujet ça fonctionne très bien.. mais si il n'y en
a que 7 j'ai ######## dans E9

=PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1)

Donc, que dois-je ajouter à ma formule pour que lorsqu'il n'y en a 3.4 ou 5
ne pas voir #######
--
Clochard
Aimerais bien savoir.
Merci!
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #4806521
Bonjour,
=SI(ESTERR(PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1));"";PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1))
devrait convenir.
Question à mon tour : ne s'agit il pas en fait d'une matricielle destinée à
retourner le numéro de la 1ère ligne sur laquelle on trouve l'item noté en
Cx ?
--
Avec plaisir
Philippe.R
"Clochard" news:
Bon dimanche,

J'ai cette formule en E2:E9 qui cherche en A1:A40... afin d'obtenir
l'emplacement du sujet demandé.

Si j'ai 8 fois le même sujet... ça fonctionne très bien.. mais si il n'y
en
a que 7 j'ai ######## dans E9...

=PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1)

Donc, que dois-je ajouter à ma formule pour que lorsqu'il n'y en a 3.4 ou
5
ne pas voir #######
--
Clochard
Aimerais bien savoir....
Merci!


Clochard
Le #4806511
Merci Philippe

C'est bien cela...

Mais l'ajout que tu me proposes ne donne plus des ############
mais plutôt #NOMBRE!

Il n'apparaît rien s'il n'y a aucun sujet d'inscrit demandé... mais aussitôt
que j'en ai un... il inscrit #NOMBRE! dans les 7 cellules suivantes

Je l'ai placé dans une colonne E2:E9

E2: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1)
E3: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));2)
E4: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));3)
E5: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));4)
E6: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));5)

Ainsi de suite... jusqu'à E9
--
Clochard
Aimerais bien savoir....
Merci!



Bonjour,
=SI(ESTERR(PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1));"";PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1))
devrait convenir.
Question à mon tour : ne s'agit il pas en fait d'une matricielle destinée à
retourner le numéro de la 1ère ligne sur laquelle on trouve l'item noté en
Cx ?
--
Avec plaisir
Philippe.R
"Clochard" news:
Bon dimanche,

J'ai cette formule en E2:E9 qui cherche en A1:A40... afin d'obtenir
l'emplacement du sujet demandé.

Si j'ai 8 fois le même sujet... ça fonctionne très bien.. mais si il n'y
en
a que 7 j'ai ######## dans E9...

=PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1)

Donc, que dois-je ajouter à ma formule pour que lorsqu'il n'y en a 3.4 ou
5
ne pas voir #######
--
Clochard
Aimerais bien savoir....
Merci!






Philippe.R
Le #4806491
Re,
es tu certain de valider par Ctrl+Maj+Entrée ?
pour moi, cette variante fonctionne sans problème :
=SI(ESTERR(PETITE.VALEUR(SI(plage=C$2;LIGNE(plage));LIGNE()-1));"";PETITE.VALEUR(SI(plage=C$2;LIGNE(plage));LIGNE()-1))
et renvoi bien la liste des 8 premières lignes contenant l'item saisi en c2,
les suivantes restant vierge quant il n'y en pas suffisamment.
--
Avec plaisir
Philippe.R
"Clochard" news:
Merci Philippe

C'est bien cela...

Mais l'ajout que tu me proposes ne donne plus des ############
mais plutôt #NOMBRE!

Il n'apparaît rien s'il n'y a aucun sujet d'inscrit demandé... mais
aussitôt
que j'en ai un... il inscrit #NOMBRE! dans les 7 cellules suivantes

Je l'ai placé dans une colonne E2:E9

E2: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1)
E3: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));2)
E4: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));3)
E5: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));4)
E6: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));5)

Ainsi de suite... jusqu'à E9
--
Clochard
Aimerais bien savoir....
Merci!



Bonjour,
=SI(ESTERR(PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1));"";PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1))
devrait convenir.
Question à mon tour : ne s'agit il pas en fait d'une matricielle destinée
à
retourner le numéro de la 1ère ligne sur laquelle on trouve l'item noté
en
Cx ?
--
Avec plaisir
Philippe.R
"Clochard" news:
Bon dimanche,

J'ai cette formule en E2:E9 qui cherche en A1:A40... afin d'obtenir
l'emplacement du sujet demandé.

Si j'ai 8 fois le même sujet... ça fonctionne très bien.. mais si il
n'y
en
a que 7 j'ai ######## dans E9...

=PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1)

Donc, que dois-je ajouter à ma formule pour que lorsqu'il n'y en a 3.4
ou
5
ne pas voir #######
--
Clochard
Aimerais bien savoir....
Merci!








Clochard
Le #4806451
Merci beaucoup,

Cette fois-ci ça fonctionne au poil...

Je validais par Ctrl+Maj+Entrée.... juré promis, à chaque fois....
--
Clochard
Merci!



Re,
es tu certain de valider par Ctrl+Maj+Entrée ?
pour moi, cette variante fonctionne sans problème :
=SI(ESTERR(PETITE.VALEUR(SI(plage=C$2;LIGNE(plage));LIGNE()-1));"";PETITE.VALEUR(SI(plage=C$2;LIGNE(plage));LIGNE()-1))
et renvoi bien la liste des 8 premières lignes contenant l'item saisi en c2,
les suivantes restant vierge quant il n'y en pas suffisamment.
--
Avec plaisir
Philippe.R
"Clochard" news:
Merci Philippe

C'est bien cela...

Mais l'ajout que tu me proposes ne donne plus des ############
mais plutôt #NOMBRE!

Il n'apparaît rien s'il n'y a aucun sujet d'inscrit demandé... mais
aussitôt
que j'en ai un... il inscrit #NOMBRE! dans les 7 cellules suivantes

Je l'ai placé dans une colonne E2:E9

E2: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1)
E3: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));2)
E4: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));3)
E5: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));4)
E6: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));5)

Ainsi de suite... jusqu'à E9
--
Clochard
Aimerais bien savoir....
Merci!



Bonjour,
=SI(ESTERR(PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1));"";PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1))
devrait convenir.
Question à mon tour : ne s'agit il pas en fait d'une matricielle destinée
à
retourner le numéro de la 1ère ligne sur laquelle on trouve l'item noté
en
Cx ?
--
Avec plaisir
Philippe.R
"Clochard" news:
Bon dimanche,

J'ai cette formule en E2:E9 qui cherche en A1:A40... afin d'obtenir
l'emplacement du sujet demandé.

Si j'ai 8 fois le même sujet... ça fonctionne très bien.. mais si il
n'y
en
a que 7 j'ai ######## dans E9...

=PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1)

Donc, que dois-je ajouter à ma formule pour que lorsqu'il n'y en a 3.4
ou
5
ne pas voir #######
--
Clochard
Aimerais bien savoir....
Merci!












Philippe.R
Le #4806431
Merci pour le retour, c'est apprécié
--
Avec plaisir
Philippe.R
"Clochard" news:
Merci beaucoup,

Cette fois-ci ça fonctionne au poil...

Je validais par Ctrl+Maj+Entrée.... juré promis, à chaque fois....
--
Clochard
Merci!



Re,
es tu certain de valider par Ctrl+Maj+Entrée ?
pour moi, cette variante fonctionne sans problème :
=SI(ESTERR(PETITE.VALEUR(SI(plage=C$2;LIGNE(plage));LIGNE()-1));"";PETITE.VALEUR(SI(plage=C$2;LIGNE(plage));LIGNE()-1))
et renvoi bien la liste des 8 premières lignes contenant l'item saisi en
c2,
les suivantes restant vierge quant il n'y en pas suffisamment.
--
Avec plaisir
Philippe.R
"Clochard" news:
Merci Philippe

C'est bien cela...

Mais l'ajout que tu me proposes ne donne plus des ############
mais plutôt #NOMBRE!

Il n'apparaît rien s'il n'y a aucun sujet d'inscrit demandé... mais
aussitôt
que j'en ai un... il inscrit #NOMBRE! dans les 7 cellules suivantes

Je l'ai placé dans une colonne E2:E9

E2: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1)
E3: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));2)
E4: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));3)
E5: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));4)
E6: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));5)

Ainsi de suite... jusqu'à E9
--
Clochard
Aimerais bien savoir....
Merci!



Bonjour,
=SI(ESTERR(PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1));"";PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1))
devrait convenir.
Question à mon tour : ne s'agit il pas en fait d'une matricielle
destinée
à
retourner le numéro de la 1ère ligne sur laquelle on trouve l'item
noté
en
Cx ?
--
Avec plaisir
Philippe.R
"Clochard" news:
Bon dimanche,

J'ai cette formule en E2:E9 qui cherche en A1:A40... afin d'obtenir
l'emplacement du sujet demandé.

Si j'ai 8 fois le même sujet... ça fonctionne très bien.. mais si il
n'y
en
a que 7 j'ai ######## dans E9...

=PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1)

Donc, que dois-je ajouter à ma formule pour que lorsqu'il n'y en a
3.4
ou
5
ne pas voir #######
--
Clochard
Aimerais bien savoir....
Merci!














Clochard
Le #4806011
Et à toi Philippe.R

Merci pour ton aide... c'est GRANDEMENT apréciée...

Clochard
Bien heureux de savoir
Merci!



Merci pour le retour, c'est apprécié
--
Avec plaisir
Philippe.R
"Clochard" news:
Merci beaucoup,

Cette fois-ci ça fonctionne au poil...

Je validais par Ctrl+Maj+Entrée.... juré promis, à chaque fois....
--
Clochard
Merci!



Re,
es tu certain de valider par Ctrl+Maj+Entrée ?
pour moi, cette variante fonctionne sans problème :
=SI(ESTERR(PETITE.VALEUR(SI(plage=C$2;LIGNE(plage));LIGNE()-1));"";PETITE.VALEUR(SI(plage=C$2;LIGNE(plage));LIGNE()-1))
et renvoi bien la liste des 8 premières lignes contenant l'item saisi en
c2,
les suivantes restant vierge quant il n'y en pas suffisamment.
--
Avec plaisir
Philippe.R
"Clochard" news:
Merci Philippe

C'est bien cela...

Mais l'ajout que tu me proposes ne donne plus des ############
mais plutôt #NOMBRE!

Il n'apparaît rien s'il n'y a aucun sujet d'inscrit demandé... mais
aussitôt
que j'en ai un... il inscrit #NOMBRE! dans les 7 cellules suivantes

Je l'ai placé dans une colonne E2:E9

E2: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1)
E3: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));2)
E4: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));3)
E5: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));4)
E6: =PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));5)

Ainsi de suite... jusqu'à E9
--
Clochard
Aimerais bien savoir....
Merci!



Bonjour,
=SI(ESTERR(PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1));"";PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1))
devrait convenir.
Question à mon tour : ne s'agit il pas en fait d'une matricielle
destinée
à
retourner le numéro de la 1ère ligne sur laquelle on trouve l'item
noté
en
Cx ?
--
Avec plaisir
Philippe.R
"Clochard" news:
Bon dimanche,

J'ai cette formule en E2:E9 qui cherche en A1:A40... afin d'obtenir
l'emplacement du sujet demandé.

Si j'ai 8 fois le même sujet... ça fonctionne très bien.. mais si il
n'y
en
a que 7 j'ai ######## dans E9...

=PETITE.VALEUR(SI(A1:A40Â;LIGNE(A1:A40));1)

Donc, que dois-je ajouter à ma formule pour que lorsqu'il n'y en a
3.4
ou
5
ne pas voir #######
--
Clochard
Aimerais bien savoir....
Merci!


















Publicité
Poster une réponse
Anonyme