Questions sur dnsmasq

Le
steve
Bonjour,

Je suis en train d'essayer de configurer dnsmaq sur ma passerelle.

Voici /etc/dnsmaq.conf :

domain-needed
bogus-priv
interface=ath0
interface=ath1
interface=eth0
listen-address7.0.0.1
no-dhcp-interface=eth1
expand-hosts
domain=maison.mrs

cache-sizeU0

(eth1 est l'interface qui donne sur le modem/routeur adsl, eth0 étant en
interne, je sais, , mais c'est ainsi).


Voici /etc/resolv.conf

nameserver 195.186.4.111
nameserver 195.186.4.110
search maison.mrs

Les deux DNS sont ceux de mon FAI.

Après avoir redémarré dnsmaq, je fais un test avec une nouvelle adresse :

$ dig linuxfr.org
;; Query time: 12 msec
;; SERVER: 195.186.4.111#53(195.186.4.111)


Normal.

Je relance :

$ dig linuxfr.org
;; Query time: 12 msec
;; SERVER: 195.186.4.111#53(195.186.4.111)


Bizarre, il interroge le DNS du FAI. Je vérifie avec tcpdump :

# tcpdump -n -i eth1 udp and port 53
09:58:13.157262 IP 192.168.1.34.58515 > 195.186.4.111.53: 62810+ A?
linuxfr.org. (29)
09:58:13.169737 IP 195.186.4.111.53 > 192.168.1.34.58515: 62810 1/0/0 A
88.191.250.104 (45)


Donc il interroge bien le DNS du FAI et pas le cache de dnsmasq, alors
qu'il marche :

$ dig @127.0.0.1 linufr.org
;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)



Par contre si je fais une requête depuis un des mes postes de mon réseau
local, ça marche comme prévu :

$ dig linuxfr.org
;; Query time: 0 msec
;; SERVER: 192.168.20.1#53(192.168.20.1)


[192.168.20.1 est la patte du réseau interne, la machine sur
lequel le dig est lancé étant 192.168.20.2].

J'ai essayé plusieurs combinaisons du dnsmasq.conf ainsi que du
resolv.conf mais je n'ai pas réussi à faire en sorte qu'un second dig
interroge bien le cache de dnsmasq.

Où est-ce que ça coince ?

Merci d'avance,
Steve


PS : pour info, mix stable/testing et

apt-cache policy dnsmaq
dnsmasq:
Installé : 2.45-1+lenny1
Candidat : 2.45-1+lenny1

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Michel OLTRA
Le #20620611
Bonjour,


Le mardi 24 novembre 2009, steve a écrit...


Voici /etc/dnsmaq.conf :



domain-needed
bogus-priv
interface=ath0
interface=ath1
interface=eth0
listen-address7.0.0.1
no-dhcp-interface=eth1
expand-hosts
domain=maison.mrs



cache-sizeU0



(eth1 est l'interface qui donne sur le modem/routeur adsl, eth0 étant en
interne, je sais, ..., mais c'est ainsi).




Voici /etc/resolv.conf



nameserver 195.186.4.111
nameserver 195.186.4.110
search maison.mrs



Les deux DNS sont ceux de mon FAI.



J'utilise dnsmasq, mais je mets l'option dns-nameservers (paquet
resolvconf) dans le fichier interfaces. Voir la page de manuel de
resolvconf pour cela. dns-nameservers liste d'abord le dns situé sur la
machine, puis les dns du fai.

--
jm

A.E.L. Sarl (R.C.S CASTRES 490843240)
http://www.spidboutic.fr



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Frédéric Massot
Le #20620621
steve a écrit :
Bonjour,

Je suis en train d'essayer de configurer dnsmaq sur ma passerelle.

Voici /etc/dnsmaq.conf :

domain-needed
bogus-priv
interface=ath0
interface=ath1
interface=eth0
listen-address7.0.0.1
no-dhcp-interface=eth1
expand-hosts
domain=maison.mrs

cache-sizeU0

(eth1 est l'interface qui donne sur le modem/routeur adsl, eth0 étant en
interne, je sais, ..., mais c'est ainsi).


Voici /etc/resolv.conf

nameserver 195.186.4.111
nameserver 195.186.4.110
search maison.mrs



Salut,

La résolution pour ton système doit être réalisée par DNSMasq, donc le
fichier "/etc/resolv.conf" doit seulement contenir les lignes :

search maison.mrs
nameserver 127.0.0.1

Et le fichier de configuration de DNSMsq :

server5.186.4.111
server5.186.4.110


--
============================================= | FRÉDÉRIC MASSOT |
| http://www.juliana-multimedia.com |
| mailto: |
==========================Þbian=GNU/Linux==
--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
steve
Le #20622191
Le 24-11-2009, à 11:01:40 +0100, Frédéric Massot () a écrit :

steve a écrit :
> Bonjour,
>
> Je suis en train d'essayer de configurer dnsmaq sur ma passerelle.
>
> Voici /etc/dnsmaq.conf :
>
> domain-needed
> bogus-priv
> interface=ath0
> interface=ath1
> interface=eth0
> listen-address7.0.0.1
> no-dhcp-interface=eth1
> expand-hosts
> domain=maison.mrs
>
> cache-sizeU0
>
> (eth1 est l'interface qui donne sur le modem/routeur adsl, eth0 étant en
> interne, je sais, ..., mais c'est ainsi).
>
>
> Voici /etc/resolv.conf
>
> nameserver 195.186.4.111
> nameserver 195.186.4.110
> search maison.mrs

Salut,

La résolution pour ton système doit être réalisée par DNSMasq, donc le
fichier "/etc/resolv.conf" doit seulement contenir les lignes :

search maison.mrs
nameserver 127.0.0.1

Et le fichier de configuration de DNSMsq :

server5.186.4.111
server5.186.4.110



Le contraire de ce que j'ai lu dans pas mal de doc (ou alors je les lis
à l'envers), mais à l'usage ça marche très bien.

Merci.

steve



--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme