Qui positionne ma variable DISPLAY ?

Le
olivier.marti
Bonjour,

Je n'arrive pas à avoir un démarrage correct de X11 depuis mon passage
en 10.5 (10.5.3 en fait) parce que ma variable DISPLAY est positionnée à
:0.0. En 10.5, elle devrait être positionnée par launchd à quelque chose
comme /tmp/.

C'est dans .MacOSX/environment.plist que cette variable est positionnée
comme ça. Mais j'ai effacé plusieurs fois ce fichier, et redémarrer la
machine : à chaque fois il me le recrée, et remet dedans cette
initialisation de DISPLAY

Comment faire pour avoir une variable DISPLAY correcte ?

Une idée ?

Olivier
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
laurent.pertois
Le #10853781
Olivier Marti
Comment faire pour avoir une variable DISPLAY correcte ?



En la supprimant partout où elle est ? tu ne l'aurais pas positionnée
également dans un fichier de conf de ton shell ?

--
Politically Correct Unix - UTILITIES
The "touch" command has been removed from the standard distribution due
to its inappropriate use by high-level managers.
Olivier Croquette
Le #10855331
Olivier Marti wrote, On 28/06/08 16:35:
Une idée ?



Tente un "grep DISPLAY ~/.*"
olivier.marti
Le #10855841
Laurent Pertois
Olivier Marti
> Comment faire pour avoir une variable DISPLAY correcte ?

En la supprimant partout où elle est ? tu ne l'aurais pas positionnée
également dans un fichier de conf de ton shell ?




J'ai cherché partout, et je n'ai rien trouvé, ni dans ma session, ni
dans les fichiers systèmes. Je n'ai plus de piste.

Olivier
olivier.marti
Le #10856801
Laurent Pertois
Olivier Marti
> Comment faire pour avoir une variable DISPLAY correcte ?

En la supprimant partout où elle est ? tu ne l'aurais pas positionnée
également dans un fichier de conf de ton shell ?



J'ai vérifié par ailleurs : j'ai le même problème dans une session d'un
utilisateur que je viens de créer. Donc ça n'est pas dans $HOME qu'il
faut chercher. Mais ou ?

Olivier
olivier.marti
Le #10859611
Olivier Marti
Laurent Pertois
> Olivier Marti >
> > Comment faire pour avoir une variable DISPLAY correcte ?
>
> En la supprimant partout où elle est ? tu ne l'aurais pas positionnée
> également dans un fichier de conf de ton shell ?

J'ai vérifié par ailleurs : j'ai le même problème dans une session d'un
utilisateur que je viens de créer. Donc ça n'est pas dans $HOME qu'il
faut chercher. Mais ou ?

Olivier



Il semble que c'était sshAskPass qui faisait ce merdier.

J'ai maintenant une variable DISPLAY correcte, mais X11 ne marche
toujours pas ...

Olivier
Publicité
Poster une réponse
Anonyme