RAID 1 : le système de boote pas quand un disque manque

Le
tyranorl
Salut,

J'en ai déjà parlé un peu sur le channel irc hier soir, j'ai un souci avec mes
machines de scène qui ont leur système sur une grappe RAID 1 : lorsque je boote
en enlevant un disque, j'arrive au début de grub (Welcome to grub) et là, la
machine reboote.

Grub est installé sur chacun des disques de la grappe (vérifié hier soir avec
grub-install --recheck /dev/sdx - no error reported à chaque fois).

Dans l'installation de grub2, il m'avait été demandé si je souhaitais installé
grub sur la grappe, j'avais répondu oui, mais ça avait échoué.

Je suis en (plus ou moins) wheezy, et j'ai un initrd (forcément) sur le noyau
que j'utilise.

Des idées ?

Aurélien

PS : je connais rien ou pas beaucoup plus en RAID, j'ai lu et relu pas mal de
tuto, pense avoir fait tout dans le bon sens, mais il se peut que j'ai laissé
passer un truc très con.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/1306487793.4ddf6bf1350bb@webmail.free.fr
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
daniel huhardeaux
Le #23395831
Bonjour

Le 27/05/2011 11:16, a écrit :

Salut,

J'en ai déjà parlé un peu sur le channel irc hier soir, j'ai un souci avec mes
machines de scène qui ont leur système sur une grappe RAID 1 : lorsque je boote
en enlevant un disque, j'arrive au début de grub (Welcome to grub) et là, la
machine reboote.

Grub est installé sur chacun des disques de la grappe (vérifié hier soir avec
grub-install --recheck /dev/sdx - no error reported à chaque fois).

Dans l'installation de grub2, il m'avait été demandé si je souhaitais installé
grub sur la grappe, j'avais répondu oui, mais ça avait échoué.

Je suis en (plus ou moins) wheezy, et j'ai un initrd (forcément) sur le noyau
que j'utilise.



Je ne sais si le serveur est un Dell avec Raid SAS logiciel, j'ai eu ce
probleme avec ce materiel. La solution a été de refaire l'installation
de grub sur les deux disques sans le terminal graphique. Reprends les
archives de la liste vers fin janvier.

--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
tyranorl
Le #23395931
Quoting daniel huhardeaux
Bonjour

Le 27/05/2011 11:16, a écrit :
>
> Salut,
>
> J'en ai déjà parlé un peu sur le channel irc hier soir, j'ai un souci avec
mes
> machines de scène qui ont leur système sur une grappe RAID 1 : lorsque je
boote
> en enlevant un disque, j'arrive au début de grub (Welcome to grub) et là,
la
> machine reboote.
>
> Grub est installé sur chacun des disques de la grappe (vérifié hier soir
avec
> grub-install --recheck /dev/sdx - no error reported à chaque fois).
>
> Dans l'installation de grub2, il m'avait été demandé si je souhaitais
installé
> grub sur la grappe, j'avais répondu oui, mais ça avait échoué.
>
> Je suis en (plus ou moins) wheezy, et j'ai un initrd (forcément) sur le
noyau
> que j'utilise.

Je ne sais si le serveur est un Dell avec Raid SAS logiciel, j'ai eu ce
probleme avec ce materiel. La solution a été de refaire l'installation
de grub sur les deux disques sans le terminal graphique. Reprends les
archives de la liste vers fin janvier.

--
Daniel

--



Salut,

Il s'agit de RAID logiciel (oublié de préciser, désolé), géré via mdadm, donc
sans doute pas grand-chose à voir (peux-tu me confirmer ?).
Qu'est-ce que tu appelles terminal graphique ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
daniel huhardeaux
Le #23396021
Pas besoind eme mettre en copie, je suis abonné à la liste

Le 27/05/2011 11:38, a écrit :
[...]
Je ne sais si le serveur est un Dell avec Raid SAS logiciel, j'ai eu ce
probleme avec ce materiel. La solution a été de refaire l'installation
de grub sur les deux disques sans le terminal graphique. Reprends les
archives de la liste vers fin janvier.

--
Daniel

--


Salut,

Il s'agit de RAID logiciel (oublié de préciser, désolé), géré via mdadm, donc
sans doute pas grand-chose à voir (peux-tu me confirmer ?).



Dans le cas cité, c'est aussi mdadm qui fait le raid. Cela n'empêche pas
le serveur d'avoir un raid embarqué sur la CM ;-)
Qu'est-ce que tu appelles terminal graphique ?


Mettre la variable GRUB_TERMINAL=console dans /etc/grub

Comme dit ci dessus, reprends les archives de la liste pour l'historique
--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
tyranorl
Le #23396101
Quoting daniel huhardeaux
Pas besoind eme mettre en copie, je suis abonné à la liste

Le 27/05/2011 11:38, a écrit :
> [...]
>> Je ne sais si le serveur est un Dell avec Raid SAS logiciel, j'ai eu ce
>> probleme avec ce materiel. La solution a été de refaire l'installation
>> de grub sur les deux disques sans le terminal graphique. Reprends les
>> archives de la liste vers fin janvier.
>>
>> --
>> Daniel
>>
>> --
> Salut,
>
> Il s'agit de RAID logiciel (oublié de préciser, désolé), géré via mdadm,
donc
> sans doute pas grand-chose à voir (peux-tu me confirmer ?).

Dans le cas cité, c'est aussi mdadm qui fait le raid. Cela n'empêche pas
le serveur d'avoir un raid embarqué sur la CM ;-)
> Qu'est-ce que tu appelles terminal graphique ?
Mettre la variable GRUB_TERMINAL=console dans /etc/grub

Comme dit ci dessus, reprends les archives de la liste pour l'historique



Bien reçu, mais avant de m'embarquer dans une recherche potentiellement complexe
vu que je ne connais pas très bien RAID, je préférai être sûr de faire bonne
route ! ;)




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Pascal Le Bris
Le #23396111
Le 05/27/11 11:16, a écrit :

Salut,




Bonjour
Des idées ?





La partition root étant en raid, le grub.cfg devrait citier le bon UUID
corerespondant au raid.

exemple chez moi:

grub.cfg contient:
/boot/vmlinuz-2.6.32-5-xen-686 placeholder
root=UUIDTe1fa5e-aa7c-4d34-8291-44a291a08ab1 ro single rootdelay

ls -l /dev/disk/by-uuid/54e1fa5e-aa7c-4d34-8291-44a291a08ab1
lrwxrwxrwx 1 root root 11 30 avril 16:33
/dev/disk/by-uuid/54e1fa5e-aa7c-4d34-8291-44a291a08ab1 -> ../../md127

# cat /proc/mdstat
Personalities : [raid1]

md127 : active raid1 sdd1[2] sdc1[1]
4882692 blocks super 1.2 [2/2] [UU]

Si ca peut aider....
A+

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
tyranorl
Le #23396381
Quoting daniel huhardeaux
Pas besoind eme mettre en copie, je suis abonné à la liste


Oui, désolé, réponse depuis une interface web pourrie, et donc pas de "répondre
à la liste"....


Le 27/05/2011 11:38, a écrit :
> [...]
>> Je ne sais si le serveur est un Dell avec Raid SAS logiciel, j'ai eu ce
>> probleme avec ce materiel. La solution a été de refaire l'installation
>> de grub sur les deux disques sans le terminal graphique. Reprends les
>> archives de la liste vers fin janvier.
>>
>> --
>> Daniel
>>
>> --
> Salut,
>
> Il s'agit de RAID logiciel (oublié de préciser, désolé), géré via mdadm,
donc
> sans doute pas grand-chose à voir (peux-tu me confirmer ?).

Dans le cas cité, c'est aussi mdadm qui fait le raid. Cela n'empêche pas
le serveur d'avoir un raid embarqué sur la CM ;-)
> Qu'est-ce que tu appelles terminal graphique ?
Mettre la variable GRUB_TERMINAL=console dans /etc/grub

Comme dit ci dessus, reprends les archives de la liste pour l'historique



OK, j'ai repris ton historique, en effet, ça ressemble beaucoup à mon histoire.
Sauf que sauf que, changer ce paramètre n'a pas suffi.
Pour être sûr d'avoir fait ce qu'il fallait, voici ce que j'ai fait :

- édition de /etc/default/grub pour ajouter la ligne GRUB_TERMINAL=console
- installation de grub sur mes deux disques :
grub-install --recheck /dev/sdb
grub-install --recheck /dev/sdc

Ai-je bon ?


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
daniel huhardeaux
Le #23396771
Le 27/05/2011 13:32, a écrit :
[...]
OK, j'ai repris ton historique, en effet, ça ressemble beaucoup à mon histoire.
Sauf que sauf que, changer ce paramètre n'a pas suffi.
Pour être sûr d'avoir fait ce qu'il fallait, voici ce que j'ai fait :

- édition de /etc/default/grub pour ajouter la ligne GRUB_TERMINAL=console
- installation de grub sur mes deux disques :
grub-install --recheck /dev/sdb
grub-install --recheck /dev/sdc

Ai-je bon ?



Non, le update-grub est à faire.
--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
tyranorl
Le #23396891
Quoting daniel huhardeaux
Le 27/05/2011 13:32, a écrit :
> [...]
> OK, j'ai repris ton historique, en effet, ça ressemble beaucoup à mon
histoire.
> Sauf que sauf que, changer ce paramètre n'a pas suffi.
> Pour être sûr d'avoir fait ce qu'il fallait, voici ce que j'ai fait :
>
> - édition de /etc/default/grub pour ajouter la ligne GRUB_TERMINAL=console
> - installation de grub sur mes deux disques :
> grub-install --recheck /dev/sdb
> grub-install --recheck /dev/sdc
>
> Ai-je bon ?

Non, le update-grub est à faire.



Oui, c'est ce que je me suis dit dans la voiture... Bon, y a des fois, on est
pas au mieux, hein... Bref, je recommence.

--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/






--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
tyranorl
Le #23396951
Quoting :

Quoting daniel huhardeaux
> Le 27/05/2011 13:32, a écrit :
> > [...]
> > OK, j'ai repris ton historique, en effet, ça ressemble beaucoup à mon
> histoire.
> > Sauf que sauf que, changer ce paramètre n'a pas suffi.
> > Pour être sûr d'avoir fait ce qu'il fallait, voici ce que j'ai fait :
> >
> > - édition de /etc/default/grub pour ajouter la ligne
GRUB_TERMINAL=console
> > - installation de grub sur mes deux disques :
> > grub-install --recheck /dev/sdb
> > grub-install --recheck /dev/sdc
> >
> > Ai-je bon ?
>
> Non, le update-grub est à faire.

Oui, c'est ce que je me suis dit dans la voiture... Bon, y a des fois, on est
pas au mieux, hein... Bref, je recommence.





Merci à Daniel, c'était effectivement une (la ?) solution. Des nouvelles du bug
report que tu as posté ?

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
daniel huhardeaux
Le #23397231
Le 27/05/2011 17:05, a écrit :
[...]

Merci à Daniel, c'était effectivement une (la ?) solution. Des nouvelles du bug
report que tu as posté ?



Si tu as vu le bug tu as du voir les nouvelles ;-)? Ah, tu ne les a pas
vues? C'est qu'il n'y en a pas eu :-( ...

--
Daniel

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme