Re: 1ere install /Probleme avec startx

Le
kavanier
> > Pourtant, je l'ai bel et bien, et exécuté sur mes machines
>
> Est-il possible d'avoir son chemin d'accès (qui n'est pas précisé d=
ans
> UPDATING) ?
>

j'ai pas tout compris , tu parles de script xorg-upgrade ? (si c'est
celui la il suffit de lire le man ;-) )
Ou du " # sh /usr/ports/Tools/scripts/mergebase.sh " ??

pour ma part les compils rentrent enfin en ordre mais apres avoir fini
le portupgrade
& install de modules (souris,carte graphique etc..) je refais donc ma
config de Xorg
sans trop de soucis :)


la je lance startx avec une certaine excitation de pouvoir jouer avec
les options du Xorg.conf .


*OUINK*

[]
(**) RADEON(0): Initializing DGA
(**) RADEON(0): Initializing Xv
(**) RADEON(0): RADEONScreenInit finished

Fatal server error:
could not open default font 'fixed'
(**) RADEON(0): RADEONLeaveVT
(**) RADEON(0): EngineRestore (32/32)
[]

ça c'est louche car mes fonts sont Ok !!
avec ceci dans ma config , (les paths sont bon) .
Section "Files"
RgbPath "/usr/local/share/X11/rgb"
ModulePath "/usr/local/lib/xorg/modules"
FontPath "/usr/local/lib/X11/fonts/misc/"
FontPath "/usr/local/lib/X11/fonts/TTF/"
FontPath "/usr/local/lib/X11/fonts/OTF"
FontPath "/usr/local/lib/X11/fonts/Type1/"
FontPath "/usr/local/lib/X11/fonts/100dpi/"
FontPath "/usr/local/lib/X11/fonts/75dpi/"
EndSection

pkg_info | grep xorg
xorg-apps-7.2 X.org apps meta-port
xorg-cf-files-1.0.2_2 X.org cf files for use with imake builds
xorg-docs-1.3,1 X.org documentation files
xorg-drivers-7.2 X.org drivers meta-port
xorg-fonts-100dpi-7.2 X.Org 100dpi bitmap fonts
xorg-fonts-7.2 X.org fonts meta-port
xorg-fonts-75dpi-7.2 X.Org 75dpi bitmap fonts
xorg-fonts-cyrillic-7.2 X.Org Cyrillic bitmap fonts
xorg-fonts-miscbitmaps-7.2 X.Org miscellaneous bitmap fonts
xorg-fonts-truetype-7.2 X.Org TrueType fonts
xorg-fonts-type1-7.2 X.Org Type1 fonts
xorg-libraries-7.2 X.org libraries meta-port


la je suis un peu perdu .
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Paul Gaborit
Le #891414
À (at) 23 May 2007 07:53:57 -0700,
écrivait (wrote):
Pourtant, je l'ai bel et bien, et exécuté sur mes machines...


Est-il possible d'avoir son chemin d'accès (qui n'est pas précisé dans
UPDATING) ?



j'ai pas tout compris , tu parles de script xorg-upgrade ? (si c'est
celui la il suffit de lire le man ;-) )


C'est bien de 'xorg-upgrade' que je voulais parler... Quel man faut-il
lire ?

En fait, ce que j'ai cru déduire de la lecture de UPDATING, c'est que
le script 'xorg-upgrade' n'existe pas et qu'il faut tout simplement
suivre la procédure décrite dans UPDATING. Mais je n'ai peut-être pas
tout compris...


Ou du " # sh /usr/ports/Tools/scripts/mergebase.sh " ??


Celui-là, je n'en ai pas eu besoin. J'ai tout simplement supprimé
/usr/X11R6 (je n'avais pas touché quoi que ce soit dans
'/usr/X11R6/etc') puis j'ai modifié moi-même les fichiers dans '/etc'
(là, le script aurait peut-être pu m'aider ;-)).

--
Paul Gaborit -


David Marec
Le #891221
:

Fatal server error:
could not open default font 'fixed'


D'après ce que j'ai suivi, ce défaut est le symptôme du méta-port manquant,
ou d'un de ses composants.

pkg_info | grep xorg
xorg-apps-7.2 X.org apps meta-port
xorg-cf-files-1.0.2_2 X.org cf files for use with imake builds
xorg-docs-1.3,1 X.org documentation files
xorg-drivers-7.2 X.org drivers meta-port
xorg-fonts-100dpi-7.2 X.Org 100dpi bitmap fonts
xorg-fonts-7.2 X.org fonts meta-port
xorg-fonts-75dpi-7.2 X.Org 75dpi bitmap fonts
xorg-fonts-cyrillic-7.2 X.Org Cyrillic bitmap fonts
xorg-fonts-miscbitmaps-7.2 X.Org miscellaneous bitmap fonts
xorg-fonts-truetype-7.2 X.Org TrueType fonts
xorg-fonts-type1-7.2 X.Org Type1 fonts
xorg-libraries-7.2 X.org libraries meta-port


id:
--------------
linux-xorg-libs-6.8.2_5 Xorg libraries, linux binaries
xorg-7.2 X.Org complete distribution metaport
xorg-apps-7.2 X.org apps meta-port
xorg-cf-files-1.0.2_2 X.org cf files for use with imake builds
xorg-docs-1.3,1 X.org documentation files
xorg-drivers-7.2 X.org drivers meta-port
xorg-fonts-100dpi-7.2 X.Org 100dpi bitmap fonts
xorg-fonts-7.2 X.org fonts meta-port
xorg-fonts-75dpi-7.2 X.Org 75dpi bitmap fonts
xorg-fonts-cyrillic-7.2 X.Org Cyrillic bitmap fonts
xorg-fonts-miscbitmaps-7.2 X.Org miscellaneous bitmap fonts
xorg-fonts-truetype-7.2 X.Org TrueType fonts
xorg-fonts-type1-7.2 X.Org Type1 fonts
xorg-libraries-7.2 X.org libraries meta-port
xorg-nestserver-1.2.0,1 Nesting X server from X.Org
xorg-printserver-1.2.0,1 X Print server from X.Org
xorg-protos-7.2 X.org protos meta-port
xorg-server-1.2.0_2,1 X.Org X server and related programs
xorg-vfbserver-1.2.0,1 X virtual framebuffer server from X.Org
----------------------

Ceci dit, il me reste à remettre xfs en état de marche.
Avez vous tenté de générer un nouveau fichier de
configuration, /etc/X11/xorg.conf voire de lancer X sans aucun fichier de
configuration ?


P.-S.: Même si je suis fâché avec Free Telecom, je pense que mes adresses
chez eux fonctionnent toujours.

Publicité
Poster une réponse
Anonyme