Re: Comment s'opère la mise à jour du noyau dans Stretch ? [RESOLU][Etait: Pourquoi linux-headers-`uname r` é choue sur Stretch et pas sur Jessie ?]

Le
Olivier
--001a11403cc81d194c054aedd258
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Le 17 mars 2017 à 10:34, Jean-Marc <jean-marc@6jf.be> a écrit :

> Fri, 17 Mar 2017 10:26:49 +0100
> Olivier <oza.4h07@gmail.com> écrivait :
>
> salut,
>
> > $ sudo apt-get -s dist-upgrade
> > Lecture des listes de paquets Fait
> > Construction de l'arbre des dépendances
> > Lecture des informations d'état Fait
> > Calcul de la mise à jour Fait
> > Les paquets suivants ont été installés automatiquement e=
t ne sont plus
> > nécessaires :
> > bijiben libsofia-sip-ua-glib3 libsofia-sip-ua0 telepathy-rakia
> > Veuillez utiliser « sudo apt autoremove » pour les supprimer.
> > Les NOUVEAUX paquets suivants seront installés :
> > firmware-linux-free gnome-calendar irqbalance libopenmpt0 libpgm-5.2-=

0
> > libproxy1-plugin-gsettings
> > libproxy1-plugin-networkmanager libsaxonhe-java
> > linux-image-4.9.0-2-686-pae
> > Les paquets suivants seront mis à jour :
> > gnome gnome-core gstreamer1.0-libav libavdevice57 libavfilter6
> > libavformat57 libgegl-0.3-0 libopencv-calib3d2.4v5
> > libopencv-core2.4v5 libopencv-features2d2.4v5 libopencv-flann2.4v5
> > libopencv-highgui2.4-deb0 libopencv-imgproc2.4v5
> > libopencv-objdetect2.4v5 libopencv-video2.4v5 libxmlbeans-java libzmq=
5
> > linux-image-686-pae
> > 18 mis à jour, 9 nouvellement installés, 0 à enlever et =
0 non mis à jour.
> >
> >
> > Si j'en crois ce qui précède, linux-image n'est pas mis =
jour par
> > dist-upgrade.
>
> Si tu regardes attentivement, tu verras linux-image-686-pae dans la liste
> des paquets qui seront mis à jour et linux-image-4.9.0-2-686-pae dan=
s la
> liste des nouveaux paquets.
>
> Je pensais que c'est ce que tu voulais.
>
>
> Jean-Marc <jean-marc@6jf.be>
>

En effet, je suis complètement miro !
J'arrête de boire de l'eau ;-))


Dois-je retenir qu'un dist-upgrade est nécessaire à chaque change=
ment de
version du noyau ?
Ai-je raté une alerte me signalant qu'un changement de noyau est possi=
ble
ou recommandé ?
Que risque-ton avec un dist-upgrade (si on n'a pas changé les donn=
es de
/etc/apt) ?

En tout cas, merci pour le tuyau !

--001a11403cc81d194c054aedd258
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quo=
te">Le 17 mars 2017 à 10:34, Jean-Marc <span dir="ltr">&lt;<a href=
="mailto:jean-marc@6jf.be" target="_blank">jean-marc@6jf.be</a>&gt;</sp=
an> a écrit :<br><blockquote class="gmail_quote" style="margin:0 0=
0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Fri, 17 Mar 2017 10:26=
:49 +0100<br>
Olivier &lt;<a href="mailto:oza.4h07@gmail.com">oza.4h07@gmail.com</a>&gt=
; écrivait :<br>
<br>
salut,<br>
<span class=""><br>
&gt; $ sudo apt-get -s dist-upgrade<br>
&gt; Lecture des listes de paquets Fait<br>
&gt; Construction de l&#39;arbre des dépendances<br>
&gt; Lecture des informations d&#39;état Fait<br>
&gt; Calcul de la mise à jour Fait<br>
&gt; Les paquets suivants ont été installés automatiquement =
et ne sont plus<br>
&gt; nécessaires :<br>
&gt;   bijiben libsofia-sip-ua-glib3 libsofia-sip-ua0 telepathy-r=
akia<br>
&gt; Veuillez utiliser « sudo apt autoremove » pour les supprimer=
.<br>
&gt; Les NOUVEAUX paquets suivants seront installés :<br>
&gt;   firmware-linux-free gnome-calendar irqbalance libopenmpt0 =
libpgm-5.2-0<br>
&gt; libproxy1-plugin-gsettings<br>
&gt;   libproxy1-plugin-<wbr>networkmanager libsaxonhe-java<br>
&gt; linux-image-4.9.0-2-686-pae<br>
&gt; Les paquets suivants seront mis à jour :<br>
&gt;   gnome gnome-core gstreamer1.0-libav libavdevice57 libavfil=
ter6<br>
&gt; libavformat57 libgegl-0.3-0 libopencv-calib3d2.4v5<br>
&gt;   libopencv-core2.4v5 libopencv-features2d2.4v5 libopencv-fl=
ann2.4v5<br>
&gt; libopencv-highgui2.4-deb0 libopencv-imgproc2.4v5<br>
&gt;   libopencv-objdetect2.4v5 libopencv-video2.4v5 libxmlbeans-=
java libzmq5<br>
&gt; linux-image-686-pae<br>
&gt; 18 mis à jour, 9 nouvellement installés, 0 à enlever et=
0 non mis à jour.<br>
&gt;<br>
&gt;<br>
&gt; Si j&#39;en crois ce qui précède, linux-image n&#39;est pas =
mis à jour par<br>
&gt; dist-upgrade.<br>
<br>
</span>Si tu regardes attentivement, tu verras linux-image-686-pae dans la =
liste des paquets qui seront mis à jour et linux-image-4.9.0-2-686-pae=
dans la liste des nouveaux paquets.<br>
<br>
Je pensais que c&#39;est ce que tu voulais.<br>
<br>
<br>
Jean-Marc &lt;<a href="mailto:jean-marc@6jf.be">jean-marc@6jf.be</a>&gt;<=
br>
</blockquote></div><br></div><div class="gmail_extra">En effet, je suis c=
omplètement miro !<br></div><div class="gmail_extra">J&#39;arrê=
te de boire de l&#39;eau ;-))<br><br><br></div><div class="gmail_extra">D=
ois-je retenir qu&#39;un dist-upgrade est nécessaire à chaque cha=
ngement de version du noyau ?<br></div><div class="gmail_extra">Ai-je rat=
é une alerte me signalant qu&#39;un changement de noyau est possible o=
u recommandé ?<br></div><div class="gmail_extra">Que risque-ton avec=
un dist-upgrade (si on n&#39;a pas changé les données de /etc/ap=
t) ?<br><br></div><div class="gmail_extra">En tout cas, merci pour le tuy=
au !<br></div></div>

--001a11403cc81d194c054aedd258--
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Marc
Le #26429247
--Signature=_Fri__17_Mar_2017_18_06_48_+0100_VrsUsGGPtUWXLsTd
Content-Type: text/plain; charset=UTF-8
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable
Fri, 17 Mar 2017 15:16:15 +0100
Olivier
Dois-je retenir qu'un dist-upgrade est nécessaire à chaque chan gement de
version du noyau ?
Ai-je raté une alerte me signalant qu'un changement de noyau est pos sible
ou recommandé ?
Que risque-ton avec un dist-upgrade (si on n'a pas changé les donn ées de
/etc/apt) ?


Pas d'alerte en Stretch. C'est la version de test.
Comme je l'ai dit, un (apt upgrade> n'installe pas de nouveau paquets.
Or dans ton cas, tu voulais installer un nouveau paquet avec un noyau 4.9.
Seul un <apt dist-upgrade> staisfait ta demande.
Plus généralement, je n'utilise que <apt dist-upgrade>.
Et aucun cas, un <apt -y> dans une version de test.
Ce qui me permet de vérifier ce qui sera mis à jour, enlever ou a jouter avant de le faire.
En tout cas, merci pour le tuyau !

De rien.
Et j'ai une question : pourquoi le noyau linux-image-686-pae ?
Tu as une machine particulière qui le demande ?
Jean-Marc --Signature=_Fri__17_Mar_2017_18_06_48_+0100_VrsUsGGPtUWXLsTd
Content-Type: application/pgp-signature
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCAAdFiEEEWjgcRC0dCXkfm9hQHHLXC3pxPwFAljMF6gACgkQQHHLXC3p
xPyBWg/9Fw4pUltvPnS9fVyWiUas6u2PPOmN7wT43Jw+iATPDKstB8xbPP5QujdH
ervw5Vn62DE4OPSEfAW3338mniuqCn9JnMMcBvwCT3YxK7aBPT0la2gRJf3ref0C
AKl8tY5tiPDCg/dbOijjrKpXD8Fxv6aUPSMaVTdxfhY5meCYtbl5rMwD12daeeMy
xyibX0VB5AQRU92xqIUtWabtYnCxZDNwQyG1yVCBWBNDlF7oyTOIOuIb8Sm/VfFi
Vf4GvsYQoin0sw1B88rPgm5VMeT5d7o2XOlBQ7aXYlCLzBB1MKjSDGdedEdFRlmd
BF93jXo3VobbP7aLgL6NNgq7mzA8BiRbT5hyX5pRYTXKJuHsXeP8EfEnqn4fNTsf
OT602em1DiCHygZt3xLfzeq8DVf9TNfDpLeh7kj0R9aAjAtusXT5/wCXighCaY6R
uOE/RdF0nGmTj6tf7k/w306j221EmvYZeskq9Geunr4rv8PukK5Zimcqh8UUKDx/
zoZEBtnxOKJ+gGFqhoXAZGLUGJO+/OR0OqVuKRwFBbQ+98A/ggLyHU/D56kb3L8u
/zjMDY2UjgHdJFoeyI0p/UleEjZrMIxi9c/xXAdrTCZd6dvF+4fS9JfMmFKOhdAj
LT4FfaU5jlAi9hUixwhFL3EO8XESrGdnT7u3WpxWf7cXkuSIkhY =XVrK
-----END PGP SIGNATURE-----
--Signature=_Fri__17_Mar_2017_18_06_48_+0100_VrsUsGGPtUWXLsTd--
Publicité
Poster une réponse
Anonyme