Re création Users (suite)

Le
Pat
bonjour,

j'ai éffectuer une petiti mofication au script :

## debut script###
Const ForReading = 1, ForWriting = 2, ForAppending = 8

Set objOU = GetObject("LDAP://OU=mon_OU,dc=domaine,dc=lan")


dim fso, df1
CSVFile = "c:chemintoto.csv"

Set fso = CreateObject("Scripting.FileSystemObject")
Set df1 = fso.OpenTextFile(CSVFile,ForReading,True)

Do while Not df1.AtEndOfStream
varLigne = df1.readline()

NomUser = split(varLigne,";")(0)
PrUser = split(varLigne,";")(1)
Login = split(varLigne,";")(2)
Desc = split(varLigne,";")(3)
Tel = split(varLigne,";")(4)
Mail = split(varLigne,";")(5)

Set objUser = objOU.Create("User", "cn="&Login)
objUser.Put "sAMAccountName", Login
objUser.Put "UserPrincipalName", ""& Login &"@domaine.lan"
objUser.Put "givenName", PrUser
objUser.Put "sn", NomUser
objUser.Put "displayName", PrUser & " " & NomUser
objUser.Put "description", Desc
objUser.Put "telephoneNumber", Tel
objUser.Put "mail", mail
objUser.SetInfo

objUser.AccountDisabledúlse
objUser.SetInfo
Loop
df1.close


WScript.Quit
'## fin script###

Mon problème c'est que le displaynme sur l'interface AD ne correspond pas à
celui du script, c'est le login qui s'affiche.

Merci d'avance de votre aide.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jbongran
Le #678396
Pat wrote:
bonjour,

j'ai éffectuer une petiti mofication au script :

## debut script###
Const ForReading = 1, ForWriting = 2, ForAppending = 8

Set objOU = GetObject("LDAP://OU=mon_OU,dc=domaine,dc=lan")


dim fso, df1
CSVFile = "c:chemintoto.csv"

Set fso = CreateObject("Scripting.FileSystemObject")
Set df1 = fso.OpenTextFile(CSVFile,ForReading,True)

Do while Not df1.AtEndOfStream
varLigne = df1.readline()

NomUser = split(varLigne,";")(0)
PrUser = split(varLigne,";")(1)
Login = split(varLigne,";")(2)
Desc = split(varLigne,";")(3)
Tel = split(varLigne,";")(4)
Mail = split(varLigne,";")(5)

Set objUser = objOU.Create("User", "cn="&Login)
objUser.Put "sAMAccountName", Login
objUser.Put "UserPrincipalName", ""& Login &"@domaine.lan"
objUser.Put "givenName", PrUser
objUser.Put "sn", NomUser
objUser.Put "displayName", PrUser & " " & NomUser
objUser.Put "description", Desc
objUser.Put "telephoneNumber", Tel
objUser.Put "mail", mail
objUser.SetInfo

objUser.AccountDisabledúlse
objUser.SetInfo
Loop
df1.close


WScript.Quit
'## fin script###

Mon problème c'est que le displaynme sur l'interface AD ne correspond
pas à celui du script, c'est le login qui s'affiche.

Merci d'avance de votre aide.


Petites corrections et une question:
Do while Not df1.AtEndOfStream
arrLigne = Split(df1.readline(), ";")

NomUser = arrLigne(0)
PrUser = arrLigne(1)
Login = arrLigne(2)
Desc = arrLigne(3)
Tel = arrLigne(4)
Mail = arrLigne(5)

Set objUser = objOU.Create("User", "cn="&Login)
objUser.Put "sAMAccountName", Login
'Il me sembe qu'il y avait une erreur sur la ligne suivante
objUser.Put "UserPrincipalName", Login & "@domaine.lan"

Tu est sûr que c'est bien displayName que tu regardes dans l'interface AD ?
http://www.computerperformance.co.uk/Logon/LDAP_attributes_active_directory.htm

Publicité
Poster une réponse
Anonyme