Re : Interrogations sur le ping

Le
Christophe BOURGEOIS
--0-555145348-1203089194=:73650
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable

>> Bonjour, > >Bonjour, > >> Je suis en train de =
mettre en place un serveur (appelons le srv0), a=
vec >> openvz. Je fais tourner 2 'machines virtuelle=
s' dessus, srv1 et srv2. >> >> Sur srv1, je fai=
s tourner bind qui devient le serveur DNS de tou=
t ce >> petit monde. Depuis srv1, je ping sans =
problème srv0 et srv2 (idem depuis >> srv2) =
: >> >> >> Par contre depuis srv0, les pings son=
t très lents à repondre, même si le >=
> time de chaque requête icmp est court : >>=
>> >> Est-ce que quelqu'un aurait une petite id=
ée d'où peut venir ce temps de >> latence =
? > >Un problème de résolution DNS? srv1.d=
omaine --> (192.168.1.120) Eh bien pour le DNS, je pense que c'=
est bon, puisque si je fais : ping srv1 : il répon=
d, mais lentement ping srv1.domaine : il répond, mais lentement=
ping 192.168.1.120 : il répond normalement Et le problèm=
e ne se pose que depuis srv0. Depuis une autre machine du réseau, le p=
ing sur srv1 répond normalement, avec ou sans le nom de domaine. =
>> Ou aurait une idée de la manière dont =
je peut diagnostiquer le >> problème ? > >Ping=
uer avec les IP, au lieu des noms. Effectivement =
(et en plus ca fonctionne sans lenteurs), mais l'intérêt d'un ser=
veur DNS, c'est justement de ne pas passer par les IP =
_______________________________________________________________=
______________ Ne gardez plus qu'une seule adresse mail ! Copiez vos mai=
ls vers Yahoo! Mail http://mail.yahoo.fr
--0-555145348-1203089194=:73650
Content-Type: text/html; charset=utf-8
Content-Transfer-Encoding: quoted-printable

<html><head><style type="text/css"><!-- DIV {margin:0px;} --></style></he=
ad><body><div style="font-family:verdana,helvetica,sans-serif;font-size:1=
0pt"><div style="font-family: verdana,helvetica,sans-serif; font-size: 10=
pt;">&gt;&gt; Bonjour,<br><div style="font-family: times new roman,new=
york,times,serif; font-size: 12pt;">&gt;<br>&gt;Bonjour,<br>&gt;<br>&gt;&g=
t; Je suis en train de mettre en place un ser=
veur (appelons le srv0), avec<br>&gt;&gt; openvz. Je f=
ais tourner 2 'machines virtuelles' dessus, srv1 et =
srv2.<br>&gt;&gt;<br>&gt;&gt; Sur srv1, je fais tourner =
bind qui devient le serveur DNS de tout ce<br>&g=
t;&gt; petit monde. Depuis srv1, je ping sans probl=
ème srv0 et srv2 (idem depuis<br>&gt;&gt; srv2) :=
<br>&gt;&gt;<br>&gt;&gt;<br>&gt;&gt; Par contre depuis srv0, =
les pings sont très lents à repondre, m=
ême si le<br>&gt;&gt; time de chaque requête =
icmp est court :<br>&gt;&gt;<br>&gt;&gt;<br>&gt;&gt; Est-ce =
que quelqu'un aurait une petite idée d'où =
peut venir ce temps de<br>&gt;&gt; latence ? <br>&gt;<=
br>&gt;Un problème de résolution DNS? srv1.domaine=
--&gt; (192.168.1.120) <br><br>Eh bien pour le DNS, je pense que c'e=
st bon, puisque si je fais :<br>ping srv1&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &n=
bsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; &nbsp;&nbsp;&nbsp; : il répond, ma=
is lentement<br>ping srv1.domaine&nbsp;&nbsp;&nbsp;&nbsp; : il répond,=
mais lentement<br>ping 192.168.1.120&nbsp; : il répond normalement<br=
><br>Et le problème ne se pose que depuis srv0. Depuis une autre machi=
ne du réseau, le ping sur srv1 répond normalement, avec ou sans l=
e nom de domaine.<br><br>&gt;&gt; Ou aurait une idée de=
la manière dont je peut diagnostiquer le <br>&gt=
;&gt; problème ?<br>&gt;<br>&gt;Pinguer avec les IP, =
au lieu des noms.<br><br>Effectivement (et en plus ca fonctionne s=
ans lenteurs), mais l'intérêt d'un serveur DNS, c'est justement d=
e ne pas passer par les IP<br><br><br></div></div></div><br> =
<hr size="1"> Ne gardez plus qu'une seule adresse mail ! <a href=
="http://fr.rd.yahoo.com/mail/mail_taglines/trueswitch/SIG=11gshn0bu/**=
http%3A%2F%2Fwww.trueswitch.com%2Fyahoo-fr%2F">Copiez vos mails</a> vers Ya=
hoo! Mail </body></html>
--0-555145348-1203089194=:73650--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Serge Cavailles
Le #9716281
Le vendredi 15 février 2008 16:26, Christophe BOURGEOIS a écrit :
Bonjour,

>Bonjour,

Je
suis
en
train
de
mettre



Il est bizarre votre mailer.

Eh bien pour le DNS, je pense que c'est bon, puisque si je fais :
ping srv1 : il répond, mais lentement
ping srv1.domaine : il répond, mais lentement
ping 192.168.1.120 : il répond normalement

Et le problème ne se pose que depuis srv0. Depuis une autre machine du
réseau, le ping sur srv1 répond normalement, avec ou sans le nom de
domaine.



Si la lenteur observée n'existe qu'avant le premier ping, ça ressemble fort
à un pb de résolution DNS depuis srv0.

>Pinguer avec les IPs au lieu des noms

Effectivement (et en plus ca fonctionne sans lenteurs), mais l'intérêt
d'un serveur DNS, c'est justement de ne pas passer par les IP...



Oui, quand tout fonctionne correctement.

--
Serge
Pascal Hambourg
Le #9716271
Christophe BOURGEOIS a écrit :
Bonjour,

Bonjour,




Je
suis
en
train
de
mettre
en
place



Qu'est-ce que c'est que ce bazar ?

Eh bien pour le DNS, je pense que c'est bon, puisque si je fais :
ping srv1 : il répond, mais lentement
ping srv1.domaine : il répond, mais lentement
ping 192.168.1.120 : il répond normalement

Et le problème ne se pose que depuis srv0. Depuis une autre machine du
réseau, le ping sur srv1 répond normalement, avec ou sans le nom de
domaine.



Alors il faut vérifier le contenu de /etc/resolv.conf sur srv0, et le
cas échéant le comparer avec celui des autres machines. Si c'est bon,
vérifier la connectivité IP avec les DNS listés avec host ou dig et
tcpdump ou wireshark/tshark pour visualiser le trafic.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme