Re: Migration GRUB1 -->GRUB2

Le
Courrier Debian
Bonjour,
Je reprends cet ancien Sujet déjà paru dans la liste, pour évoquer mo=
n
expérience personnelle concernant cette migration.
Je suis en Sid AMD 64, depuis plusieurs jours, j'avais les deux Grub1 et
chaînage sur le lancement de Grub2 sans problème apparent, j'ai remarqu=
é
cependant la disparition de mon accès à Windows Vista dans le menu,ce n=
'est
pas que je l'utilise fréquemment mais des applis ne peuvent tourner que s=
ous
Windows, en lisant les messages parus précédemment j'ai vu qu'il fallai=
t
installer le paquet : os-prober et non (os-proper qui n'existe pas)
Remarque: je trouve que c'est dommage que les responsables de Grub ne
l'installent pas automatiquement.
Confiant je lance la migration totale par un : upgrade-from-grub-legacy
tout ce passe bien , je vois alors la prise en compte outre linux de Vista.
Je reboote et alors patatras au moment du boot dans Grub j'obtiens une
magnifique ERREUR 15 !!! Blocage total !!!.
Heureusement j'ai un autre PC sous la main et je peux rechercher la
signification de cette erreur, je tombe sur un message donnant un mode
opératoire :
Redémarrer avec le CD de "supergrubdisk".
Je télécharge et grave ce CD, puis je le met au démarrage et choisis =
dans le
menu du CD:
"LINUX!(1) AUTO"
et miracle la debian SID est bien lancée.
Après ouverture d'une session je lance dans une console sous root :
grub-install "(hd0)"
( j'ai plutôt lancé grub-install /dev/sda le message indiquait de fair=
e grub-
install hd0 ce qui ne marche pas.).
Je reboote et retire le CD et enfin Grub2 semble content et redémarre
correctement.
En espérant que ce message puisse être utile à quelqu'un.
Remarque , pour l'instant Grub2 semble intéressant mais pas encore aussi =
fiable
que GRUB , à mon point de vue il ne peux encore être mis dans Squeeze
(testing)
A+
Philippe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sylvain Sauvage
Le #20120781
Courrier Debian, vendredi 11 septembre 2009, 18:03:05 CEST

Bonjour,



’jour,

[…]
installer le paquet : os-prober et non (os-proper qui n'existe pas)
Remarque: je trouve que c'est dommage que les responsables de Grub ne
l'installent pas automatiquement.



Il est « suggéré ». Clairement, il n†™a pas à être en
« dépend ». Peut-être devrait-il être en « recommandé ».
Tu peux ouvrir un bogue « wishlist » pour cela…

[…]
Je reboote et alors patatras au moment du boot dans Grub j'obtiens une
magnifique ERREUR 15 !!! Blocage total !!!. […]



« Shit happens. » (Cette doc. Gentoo est plutôt bien faite :
http://www.gentoo.org/doc/fr/grub-error-guide.xml )

grub-install "(hd0)"
( j'ai plutôt lancé grub-install /dev/sda le message indiquait de faire grub-
install hd0 ce qui ne marche pas.).



grub-install peut prendre "(hd#)" ou /dev/xx
Si "(hd#)" n’a pas fonctionné, c’est que /boot/grub/ device.map
n’est pas bon. Il devrait contenir quelque chose comme :

(hd0) /dev/sda

Il faudrait savoir pourquoi le device.map n’est pas correct et
pourquoi upgrade-from-grub-legacy semble avoir réussi alors
qu’il a raté…

[…]
Remarque , pour l'instant Grub2 semble intéressant mais pas encore a ussi fiable
que GRUB , à mon point de vue il ne peux encore être mis dans S queeze
(testing)



Raison de plus de faire des rapports de bogue.

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Courrier Debian
Le #20120921
Le vendredi 11 septembre 2009 19:08:48, Sylvain Sauvage a écrit :

> grub-install "(hd0)"
> ( j'ai plutôt lancé grub-install /dev/sda le message indiqua it de faire
> grub- install hd0 ce qui ne marche pas.).

grub-install peut prendre "(hd#)" ou /dev/xx


(hd0) /dev/sda



Tu as tout à fait raison , mais le message contenait une erreur de syn taxe :
grub-install hd0 et non "(hd0)".
Merci pour le lien Gentoo il semble très intéressant.
A+
Philippe

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
thveillon.debian
Le #20121621
Courrier Debian a écrit :
Bonjour,
Je reprends cet ancien Sujet déjà paru dans la liste, pour évoquer mon
expérience personnelle concernant cette migration.
Je suis en Sid AMD 64, depuis plusieurs jours, j'avais les deux Grub1 et
chaînage sur le lancement de Grub2 sans problème apparent, j'ai remarqué
cependant la disparition de mon accès à Windows Vista dans le menu,ce n'est
pas que je l'utilise fréquemment mais des applis ne peuvent tourner que sous
Windows, en lisant les messages parus précédemment j'ai vu qu'il fallait
installer le paquet : os-prober et non (os-proper qui n'existe pas)
Remarque: je trouve que c'est dommage que les responsables de Grub ne
l'installent pas automatiquement.
Confiant je lance la migration totale par un : upgrade-from-grub-legacy
tout ce passe bien , je vois alors la prise en compte outre linux de Vista.
Je reboote et alors patatras au moment du boot dans Grub j'obtiens une
magnifique ERREUR 15 !!! Blocage total !!!.
Heureusement j'ai un autre PC sous la main et je peux rechercher la
signification de cette erreur, je tombe sur un message donnant un mode
opératoire :
Redémarrer avec le CD de "supergrubdisk".
Je télécharge et grave ce CD, puis je le met au démarrage et choisis dans le
menu du CD:
"LINUX!(1) AUTO"
et miracle la debian SID est bien lancée.
Après ouverture d'une session je lance dans une console sous root :
grub-install "(hd0)"
( j'ai plutôt lancé grub-install /dev/sda le message indiquait de faire grub-
install hd0 ce qui ne marche pas.).


Bizarre, ici "(hd0)" marche bien (Squeeze amd64).

Je reboote et retire le CD et enfin Grub2 semble content et redémarre
correctement.
En espérant que ce message puisse être utile à quelqu'un.
Remarque , pour l'instant Grub2 semble intéressant mais pas encore aussi fiable
que GRUB , à mon point de vue il ne peux encore être mis dans Squeeze
(testing)
A+
Philippe




J'utilise grub2 depuis Lenny-testing (et aujourd'hui Squeeze, raid et
ext4), et Ubuntu "hardy" (aujourd'hui Karmic) sans problème, à par un
lecteur de disquette identifié comme partition "/" une fois (réglé dans
le shell de grub2. Donc ça dépend des installations et des cartes mères,
j'ai vu des galères avec des cartes mères en mixte (p)ata et sata.
Comme c'est vendredi, je peux dire que les deux intégrations les plus
bancales que j'ai croisé sont Ubuntu Hardy et Fedora 10/11, Debian a
fait du bon boulot. Et puis "Testing", c'est marqué sur l'étiquette ! ;-)

Tom, fan de grub2

http://www.linuxpedia.fr/doku.php/expert/grub2

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Sil
Le #20125661
Le vendredi 11 septembre 2009 à 23:28 +0200, Mahashakti89 a écrit :
Je fonctionne avec Grub2 depuis un certain temps. Cela marche bien.



Bonjour,
Je profite de la discution car j'ai un doute depuis mon passage à
Grub2 :
J'ai une option dans le bios de mon portable pour étendre les images d e
plus faibles résolutions sur la totalité de l'écran. Cette o ption se
coupe aléatoirement lorsque je redémarre sous Debian ou XP
Je ne peux pas incriminer Grub2 avec certitude mais je n'ai pas d'autres
modifications sur mon install depuis.

Dell Latitude D520
Debian squeeze/sid
grub-common 1.96+20090808-1
grub-pc 1.96+20090808-1
grub2-splashimages 1.0.0
os-prober 1.28

Sinon, je n'ai eu aucun problème de migration, Debian, Memtest et XP
détecté directement avec os-prober.

@+
Sil


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme