Re: probleme de config de noyau (supposrt SATA)

Le
alex5027
Je répond donc aux questions qu'on me pose : Effctivement le=
noyau installer au moment de l'instalation fonctionne. L=
e chipset, c'est du intel. Voici le retour de lsmod | grep ata, sous=
mon linux qui tourne: ata_piix 13348 5 ata_gene=
ric 7556 0 libata 115664 2 ata_piix,ata=
_generic scsi_mod 136620 3 usb_storage,sd_mod,libata =
Je veux compiler un nouveau noyau, d'une part pour le plais=
ir, et aussi pour faire fonctionner une clé bluetooth, une webcam,=
une carte son pci, et eventuellement une carte wifi Q=
uand au dernier point, je ne sais pas quoi répondre si ce n'est qu=
'en executant le make menuconfig pour configurer le nouveau noyau je=
ne trouve pas le truc sensé s'appeler "SATA support" =
- Initial Header -- From : Sylvain S=
auvage <Sylvain.Sauvage@metanoesis.net> To : debian-user-fr=
ench@lists.debian.org Cc : Date : Thu, 15 Nov 20=
07 14:06:14 +0100 Subject : Re: probleme de config de noyau (supposr=
t SATA) ´jour, alex5027@tiscali.fr, mercredi 14 n=
ovembre 2007, 18:30:37 CET > > en configurant mon noyau je n'a=
i pas acces à support SATA > sensé etre dans Device charater>SCS=
I>SCSI low-level driver, > et évidement le noyau désiré est su=
r une partition d'un > disque SATA ce qui abouti a un joli kernel pa=
nic (il trouve > pas la sda7, en l'occurence) Tu veux d=
ire que tu as compilé un noyau et que celui-ci ne fonctionne pas (=
parce qu´il ne trouve pas la partition root) MAIS que le noyau de =
base de Debian fonctionne ? ou pas ? Plusieurs réactions :=
- ne nous donne surtout pas d´information sur ton matériel, =
on devinera tout seuls ton chipset et les modules qui s´en occ=
upent - si un noyau fonctionne, pourquoi compiler un nouveau noya=
u ? - si un noyau fonctionne, as-tu vérifié les différences de=
configuration, notamment concernant le chipset SATA ? =
-- Sylvain Sauvage ALICE=
C'EST ENCORE MIEUX AVEC CANAL+ LE BOUQUET ! Découvre=
z vite l'offre exclusive ALICEBOX et CANAL+ LE BOUQUET, en cliquant ici h=
ttp://alicebox.fr Soumis à conditions.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sylvain Sauvage
Le #9625751
, jeudi 15 novembre 2007, 16:24:18 CET

Je répond donc aux questions qu'on me pose :



C’est bien. (Au fait, ici, on répond dessous/dedans, en
coupant ce qui ne sert pas…)

Effctivement le noyau installer au moment de l'instalation
fonctionne.



Ok. Ça va aider.

Le chipset, c'est du intel. Voici le retour de lsmod | grep
ata, sous mon linux qui tourne:
ata_piix 13348 5
ata_generic 7556 0
libata 115664 2 ata_piix,ata_generic
scsi_mod 136620 3 usb_storage,sd_mod,libata



C’est pas super précis. Que dit lspci ?

Je veux compiler un nouveau noyau, d'une part pour le
plaisir,



Ok…

et aussi pour faire fonctionner une clé bluetooth,
une webcam, une carte son pci, et eventuellement une carte
wifi...



… pas ok : on peut très bien faire sans. Mais là n⠀™est pas
vraiment la question : je voulais surtout savoir si tu avais
un problème particulier que tu aurais espéré régler de cette
façon et que l’on aurait peut-être pu régler d†™une façon plus
simple.

Quand au dernier point, je ne sais pas quoi répondre si ce
n'est qu'en executant le make menuconfig pour configurer le
nouveau noyau je ne trouve pas le truc sensé s'appeler "SATA
support"



Quand on part d’un noyau qui fonctionne, le make menuconfig
reprend normalement la configuration de celui-ci et donc tous
les modules y sont configurés de la même façon (à moins qu’il
n’y ait beaucoup de différences entre la version qui tourne et
celle que l’on veut compiler, dans ce cas, un make oldconfig
avant peut être très utile).

Sinon, ça se trouve dans :
Devices Drivers


> ATA/ATAPI/MFM/RLL support > Intel PIIXn chipsets support
et
> Serial ATA (prod) and Parallel ATA (experimental) drivers
(deux lignes en dessous, les modules sont dedans)

Mais ton problème ne vient peut-être pas de là. Quel est
exactement le message d’erreur ? Il se produit quand ? Au
pivot-root de l’initrd ou avant ? Tu as fait un diff du
.config de ton noyau-à-toi-que-tu-compiles et de celui qui
fonctionne (/boot/config-<n°de version>) ?

--
Sylvain Sauvage
Publicité
Poster une réponse
Anonyme