Re: Wifi iwl4965 ne fonctionne pas avec acpi activé

Le
Mathieu JANIN
Le vendredi 05 décembre 2008, vous avez écrit :
> > Le vendredi 05 décembre 2008, Thomas GOBET a écrit :
> >> Bonjour à tous.
> >>
> >> J'ai un ASUS G1S avec un carte wifi Intel Corporation PRO/Wireless 496=
5.
> >>
> >> J'ai activé le module existant dans les dépôts avec le =
firmware
> >> correspondant.
> >> Lors de l'installation j'avais un problème au niveau de l'activat=
ion de
> >> l'interface.
> >> En effet dans /dmesg /j'avais un message qui m'indiquait que l'acpi
> >> désactivait systématiquement l'interface dès que je l'a=
ctivais
> >> J'ai donc essayé de désactivé l'acpi dans le grub et ma=
intenant tout
> >> fonctionne bien.
> >>
> >> Malheureusement ce que j'espérais temporaire, est toujours d'actu=
alité
> >> faute d'avoir trouvé une solution.
> >>
> >> Si je réactive l'ACPI une fois ma debian démarrée, je n=
'ai plus de wifi.
> >>
> >> J'espère que quelqu'un pourra me donner la solution pour faire co=
habiter
> >> acpi et le wifi.
> >>
> >> Merci d'avance.
> >
> > Le message étant précisément quoi ?
>
> Voici la suite de messages, qui suivait l'activation de l'interface :
>
> /iwl4965: Intel Wireless Wifi link
> ACPI: PCI interrupt 0000:03:00.0[A] -> GSI 17 (level low) ->IRQ 17
> iwl4965: Detected intel wireless wifi link 4965AGN
> firmware: requesting iwlwifi-4965-1.ucode
> input:4965AGN as /class/input/input9
> iwl4965: Radio disabled by HW RF Kill switch
>
> /
>
> > ++, MATT

Yo.

Ce n'est pas à moi personnellement que tu devrais répondre, mais =
plutot à la
liste.

Sinon, ton message dit juste que ton wifi est désactivé par un sw=
itch hardware
(un bouton). Ce switch peut n'être hardware que sur le papier, si tu l=
ui
apporte une couche d'acpi (comme le bouton power qui peut délègue=
r son effet
au software ACPI). Quand la machine démarre, ce HW kill switch est off=
, et
son "toggling" est conditionné à l'ACPI que tu as installé. =
Si le bouton qui
permet d'activer/désactiver ce switch n'est pas bien configuré da=
ns l'ACPI,
alors, tu ne peux jamais activer ton wifi.
Donc, première question, avec l'ACPI installé:
- ton bouton activant/desactivant le wifi ne fonctionnerait il pas, par
hasard, si tu tentes d'activer ton wifi avec ?
- si tu n'as pas de bouton, que dit
cat /sys/bus/pci/drivers/iwl4965/*/rf_kill ?
- est ce que ton wifi fonctionne si tu fais (en root) echo
1> /sys/bus/pci/drivers/iwl4965/*/rf_kill ?

++, MATT

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
GiGGz
Le #18055301
Mathieu JANIN a écrit :
Le vendredi 05 décembre 2008, vous avez écrit :
Le vendredi 05 décembre 2008, Thomas GOBET a écrit :
Bonjour à tous.

J'ai un ASUS G1S avec un carte wifi Intel Corporation PRO/Wireless 4965.

J'ai activé le module existant dans les dépôts avec le firmware
correspondant.
Lors de l'installation j'avais un problème au niveau de l'activation de
l'interface.
En effet dans /dmesg /j'avais un message qui m'indiquait que l'acpi
désactivait systématiquement l'interface dès que je l'activais...
J'ai donc essayé de désactivé l'acpi dans le grub et maintenant tout
fonctionne bien.

Malheureusement ce que j'espérais temporaire, est toujours d'actualité
faute d'avoir trouvé une solution.

Si je réactive l'ACPI une fois ma debian démarrée, je n'ai plus de wifi.

J'espère que quelqu'un pourra me donner la solution pour faire cohabiter
acpi et le wifi.

Merci d'avance.


Le message étant précisément quoi ?


Voici la suite de messages, qui suivait l'activation de l'interface :

/iwl4965: Intel Wireless Wifi link
ACPI: PCI interrupt 0000:03:00.0[A] -> GSI 17 (level low) ->IRQ 17
iwl4965: Detected intel wireless wifi link 4965AGN
firmware: requesting iwlwifi-4965-1.ucode
input:4965AGN as /class/input/input9
iwl4965: Radio disabled by HW RF Kill switch

/

++, MATT





Yo.

Ce n'est pas à moi personnellement que tu devrais répondre, mais plutot à la
liste.

Sinon, ton message dit juste que ton wifi est désactivé par un switch hardware
(un bouton). Ce switch peut n'être hardware que sur le papier, si tu lui
apporte une couche d'acpi (comme le bouton power qui peut délèguer son effet
au software ACPI). Quand la machine démarre, ce HW kill switch est off, et
son "toggling" est conditionné à l'ACPI que tu as installé. Si le bouton qui
permet d'activer/désactiver ce switch n'est pas bien configuré dans l'ACPI,
alors, tu ne peux jamais activer ton wifi.
Donc, première question, avec l'ACPI installé:
- ton bouton activant/desactivant le wifi ne fonctionnerait il pas, par
hasard, si tu tentes d'activer ton wifi avec ?
- si tu n'as pas de bouton, que dit
cat /sys/bus/pci/drivers/iwl4965/*/rf_kill ?
- est ce que ton wifi fonctionne si tu fais (en root) echo
1> /sys/bus/pci/drivers/iwl4965/*/rf_kill ?

++, MATT




D'ailleurs il y a un module du noyau rfkill. Est il chargé ? apporte t
il qqch ?

Bye

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Thomas GOBET
Le #18056811
>
Le vendredi 05 décembre 2008, vous avez écrit :
Le vendredi 05 décembre 2008, Thomas GOBET a écrit :
Bonjour à tous.

J'ai un ASUS G1S avec un carte wifi Intel Corporation PRO/Wireless
4965.

J'ai activé le module existant dans les dépôts avec le firmware
correspondant.
Lors de l'installation j'avais un problème au niveau de
l'activation de
l'interface.
En effet dans /dmesg /j'avais un message qui m'indiquait que l'acpi
désactivait systématiquement l'interface dès que je l'activais...
J'ai donc essayé de désactivé l'acpi dans le grub et maintenant tout
fonctionne bien.

Malheureusement ce que j'espérais temporaire, est toujours
d'actualité
faute d'avoir trouvé une solution.

Si je réactive l'ACPI une fois ma debian démarrée, je n'ai plus de
wifi.

J'espère que quelqu'un pourra me donner la solution pour faire
cohabiter
acpi et le wifi.

Merci d'avance.


Le message étant précisément quoi ?


Voici la suite de messages, qui suivait l'activation de l'interface :

/iwl4965: Intel Wireless Wifi link
ACPI: PCI interrupt 0000:03:00.0[A] -> GSI 17 (level low) ->IRQ 17
iwl4965: Detected intel wireless wifi link 4965AGN
firmware: requesting iwlwifi-4965-1.ucode
input:4965AGN as /class/input/input9
iwl4965: Radio disabled by HW RF Kill switch

/

++, MATT





Yo.

Ce n'est pas à moi personnellement que tu devrais répondre, mais
plutot à la liste.

Sinon, ton message dit juste que ton wifi est désactivé par un switch
hardware (un bouton). Ce switch peut n'être hardware que sur le
papier, si tu lui apporte une couche d'acpi (comme le bouton power
qui peut délèguer son effet au software ACPI). Quand la machine
démarre, ce HW kill switch est off, et son "toggling" est conditionné
à l'ACPI que tu as installé. Si le bouton qui permet
d'activer/désactiver ce switch n'est pas bien configuré dans l'ACPI,
alors, tu ne peux jamais activer ton wifi.
Donc, première question, avec l'ACPI installé:
- ton bouton activant/desactivant le wifi ne fonctionnerait il pas,
par hasard, si tu tentes d'activer ton wifi avec ?
- si tu n'as pas de bouton, que dit cat
/sys/bus/pci/drivers/iwl4965/*/rf_kill ?
- est ce que ton wifi fonctionne si tu fais (en root) echo 1>
/sys/bus/pci/drivers/iwl4965/*/rf_kill ?

++, MATT




D'ailleurs il y a un module du noyau rfkill. Est il chargé ? apporte t
il qqch ?


Ce module est bien chargé mais je ne sais pas si il apporte quelque chose...
Pour ce qui est du fichier pour rf_kill je ne le trouve nulle part.

Ce ne sont que des liens symboliques, et je reviens toujours au même
endroit.

Donc je ne peux pas vous dire pour le résultat avec rf_kill.

Bye

Bye




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Mathieu JANIN
Le #18058711
Le vendredi 05 décembre 2008, Thomas GOBET a écrit :
>> Le vendredi 05 décembre 2008, vous avez écrit :
>>>> Le vendredi 05 décembre 2008, Thomas GOBET a écrit :
>>>>> Bonjour à tous.
>>>>>
>>>>> J'ai un ASUS G1S avec un carte wifi Intel Corporation PRO/Wireless
>>>>> 4965.
>>>>>
>>>>> J'ai activé le module existant dans les dépôts avec le firmware
>>>>> correspondant.
>>>>> Lors de l'installation j'avais un problème au niveau de
>>>>> l'activation de
>>>>> l'interface.
>>>>> En effet dans /dmesg /j'avais un message qui m'indiquait que l'acpi
>>>>> désactivait systématiquement l'interface dès que je l'activais...
>>>>> J'ai donc essayé de désactivé l'acpi dans le grub et maintenant tout
>>>>> fonctionne bien.
>>>>>
>>>>> Malheureusement ce que j'espérais temporaire, est toujours
>>>>> d'actualité
>>>>> faute d'avoir trouvé une solution.
>>>>>
>>>>> Si je réactive l'ACPI une fois ma debian démarrée, j e n'ai plus de
>>>>> wifi.
>>>>>
>>>>> J'espère que quelqu'un pourra me donner la solution pour faire
>>>>> cohabiter
>>>>> acpi et le wifi.
>>>>>
>>>>> Merci d'avance.
>>>>
>>>> Le message étant précisément quoi ?
>>>
>>> Voici la suite de messages, qui suivait l'activation de l'interface :
>>>
>>> /iwl4965: Intel Wireless Wifi link
>>> ACPI: PCI interrupt 0000:03:00.0[A] -> GSI 17 (level low) ->IRQ 17
>>> iwl4965: Detected intel wireless wifi link 4965AGN
>>> firmware: requesting iwlwifi-4965-1.ucode
>>> input:4965AGN as /class/input/input9
>>> iwl4965: Radio disabled by HW RF Kill switch
>>>
>>> /
>>>
>>>> ++, MATT
>>
>> Yo.
>>
>> Ce n'est pas à moi personnellement que tu devrais répondre, mais
>> plutot à la liste.
>>
>> Sinon, ton message dit juste que ton wifi est désactivé par un switch
>> hardware (un bouton). Ce switch peut n'être hardware que sur le
>> papier, si tu lui apporte une couche d'acpi (comme le bouton power
>> qui peut délèguer son effet au software ACPI). Quand la mach ine
>> démarre, ce HW kill switch est off, et son "toggling" est conditi onné
>> à l'ACPI que tu as installé. Si le bouton qui permet
>> d'activer/désactiver ce switch n'est pas bien configuré dans l'ACPI,
>> alors, tu ne peux jamais activer ton wifi.
>> Donc, première question, avec l'ACPI installé:
>> - ton bouton activant/desactivant le wifi ne fonctionnerait il pas,
>> par hasard, si tu tentes d'activer ton wifi avec ?
>> - si tu n'as pas de bouton, que dit cat
>> /sys/bus/pci/drivers/iwl4965/*/rf_kill ?
>> - est ce que ton wifi fonctionne si tu fais (en root) echo 1>
>> /sys/bus/pci/drivers/iwl4965/*/rf_kill ?
>>
>> ++, MATT
>
> D'ailleurs il y a un module du noyau rfkill. Est il chargé ? appor te t
> il qqch ?

Ce module est bien chargé mais je ne sais pas si il apporte quelque
chose... Pour ce qui est du fichier pour rf_kill je ne le trouve nulle
part.

Ce ne sont que des liens symboliques, et je reviens toujours au même
endroit.

Donc je ne peux pas vous dire pour le résultat avec rf_kill.

Bye

> Bye



Quand je met une * dans le chemin, c'est à remplacer par un réper toire ayant
un id composé de chiffre, de points et de deux points.
Par exemple, sur ma 3945 chez moi:

:~$ cat /sys/bus/pci/drivers/iwl3945/0000:05:00.0/rf_kill

0

(d'ailleurs, je m'apercois que pour activer le wifi, c'est 0 qu'il faut met tre
dans le fichier, et pas un comme je le pensais).

Tu es certain que tu n'as pas un fichier rf_kill quelquepart dans un sous
répertoire de /sys/bus/pci/drivers ?
C'est bien du wifi embarqué ? A priori, c'est bien sur le bus pci ?

++, MATT

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Sauvage
Le #18059691
’soir,

Mathieu JANIN, vendredi 5 décembre 2008, 22:47:07 CET
[…]



Pour info, le démon dont il a été sujet dans ce fil n⠀™est plus
utile sur les nouveaux pilotes parce que Intel a fini par
comprendre que ça ne servait pas (c’était un morceau de c ode
fermé pour limiter les fréquences).
Maintenant, Intel collabore bien et le pilote s’améliore.

:~$
cat /sys/bus/pci/drivers/iwl3945/0000:05:00.0/rf_kill 0

(d'ailleurs, je m'apercois que pour activer le wifi, c'est 0
qu'il faut mettre dans le fichier, et pas un comme je le
pensais).



En fait, c’est logique :
0 = désactiver le rf_kill, 1 = activer le rf_kill,
soit 0 = activer le wifi, 1 = désactiver le wifi.

Tu es certain que tu n'as pas un fichier rf_kill quelquepart
dans un sous répertoire de /sys/bus/pci/drivers ?
C'est bien du wifi embarqué ? A priori, c'est bien sur le bus
pci ?



Hmm, le 4965 peut être en pci-express, donc répertoire
/sys/bus/pci_express/drivers/…

--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Thomas Gobet
Le #18069851
------=_Part_34054_16725186.1228650255986
Content-Type: text/plain; charset=WINDOWS-1252
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Le 5 décembre 2008 23:33, Sylvain Sauvage écrit :

'soir,

Mathieu JANIN, vendredi 5 décembre 2008, 22:47:07 CET
>[…]

Pour info, le démon dont il a été sujet dans ce fil n'est plus
utile sur les nouveaux pilotes parce que Intel a fini par
comprendre que ça ne servait pas (c'était un morceau de code
fermé pour limiter les fréquences).
Maintenant, Intel collabore bien et le pilote s'améliore.

> :~$
> cat /sys/bus/pci/drivers/iwl3945/0000:05:00.0/rf_kill 0
>
> (d'ailleurs, je m'apercois que pour activer le wifi, c'est 0
> qu'il faut mettre dans le fichier, et pas un comme je le
> pensais).

En fait, c'est logique :
0 = désactiver le rf_kill, 1 = activer le rf_kill,
soit 0 = activer le wifi, 1 = désactiver le wifi.

> Tu es certain que tu n'as pas un fichier rf_kill quelquepart
> dans un sous répertoire de /sys/bus/pci/drivers ?




Oui j'ai fait tout les répertoires ainsi que sous-répertoires et je n'a i
rien trouvé du nom de rf_kill.

Je savais pour le remplacement de l'étoile par un nom avec des chiffres.. .
En même temps ça fonctionne avec une étoile quand on fait : ls
/sys/bus/pci/drivers/iwl3945/* | grep rf_kill
Malheureusement je n'ai rien en retour de cette commande.




> C'est bien du wifi embarqué ? A priori, c'est bien sur le bus
> pci ?

Hmm, le 4965 peut être en pci-express, donc répertoire
/sys/bus/pci_express/drivers/…




Je n'ai pas regardé dans pci_express mais l'inconvénient c'est que j'ai
recherché avec locate (ayant fait un updatedb avant) et il ne m'a rien
trouvé non plus du nom de rf_kill...
Je regarderais ce soir, et je vous tiens au courant.

Merci à tous de votre aide




--
Sylvain Sauvage

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact






------=_Part_34054_16725186.1228650255986
Content-Type: text/html; charset=WINDOWS-1252
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

<br><br>
utile sur les nouveaux pilotes parce que Intel a fini par
&gt; pensais). <div class="Ih2E3d"><br>&gt; Tu es certain que tu n&#39;as pas un fichier rf_kill quelquepart<br>&gt; dans un sous répertoire de /sys/bus/pci/driv ers ?</div></blockquote>
<div>&nbsp;</div>
<div>&nbsp;</div>
<div>En même temps ça fonctionne avec une étoile quand on fait : ls / sys/bus/pci/drivers/iwl3945/* | grep rf_kill</div>
<div>&nbsp;</div>
<div>&nbsp;</div>
<div class="Ih2E3d"><span id=""></span><br>&gt; C&#39;est bien du wifi embarqué ? A priori, c&#39;est bien sur le bus<br>&gt; pci ?<br><br></div >&nbsp;Hmm, le 4965 peut être en pci-express, donc répertoire<br>/sys/b us/pci_express/drivers/…</blockquote>

<div>&nbsp;</div>
<div>&nbsp;</div>
<div>Merci à tous de votre aide</div>
<div>&nbsp;</div>
<div>
<div></div>
&quot;Reply-To:&quot; <br></div></div></blockquote></div><br>

------=_Part_34054_16725186.1228650255986--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Mathieu JANIN
Le #18072431
Le dimanche 07 décembre 2008, Thomas Gobet a écrit :
Le 5 décembre 2008 23:33, Sylvain Sauvage a

écrit :
> 'soir,
>
> Mathieu JANIN, vendredi 5 décembre 2008, 22:47:07 CET
>
> >[…]
>
> Pour info, le démon dont il a été sujet dans ce fil n'e st plus
> utile sur les nouveaux pilotes parce que Intel a fini par
> comprendre que ça ne servait pas (c'était un morceau de code
> fermé pour limiter les fréquences).
> Maintenant, Intel collabore bien et le pilote s'améliore.
>
> > :~$
> > cat /sys/bus/pci/drivers/iwl3945/0000:05:00.0/rf_kill 0
> >
> > (d'ailleurs, je m'apercois que pour activer le wifi, c'est 0
> > qu'il faut mettre dans le fichier, et pas un comme je le
> > pensais).
>
> En fait, c'est logique :
> 0 = désactiver le rf_kill, 1 = activer le rf_kill,
> soit 0 = activer le wifi, 1 = désactiver le wifi.
>
> > Tu es certain que tu n'as pas un fichier rf_kill quelquepart
> > dans un sous répertoire de /sys/bus/pci/drivers ?

Oui j'ai fait tout les répertoires ainsi que sous-répertoires e t je n'ai
rien trouvé du nom de rf_kill.

Je savais pour le remplacement de l'étoile par un nom avec des chiff res...
En même temps ça fonctionne avec une étoile quand on fait : ls
/sys/bus/pci/drivers/iwl3945/* | grep rf_kill
Malheureusement je n'ai rien en retour de cette commande.

> > C'est bien du wifi embarqué ? A priori, c'est bien sur le bus
> > pci ?
>
> Hmm, le 4965 peut être en pci-express, donc répertoire
> /sys/bus/pci_express/drivers/…

Je n'ai pas regardé dans pci_express mais l'inconvénient c'est que j'ai
recherché avec locate (ayant fait un updatedb avant) et il ne m'a ri en
trouvé non plus du nom de rf_kill...
Je regarderais ce soir, et je vous tiens au courant.

Merci à tous de votre aide

> --
> Sylvain Sauvage
>
> --
> Lisez la FAQ de la liste avant de poser une question :
> http://wiki.debian.org/DebFrFrenchLists
> Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
> "Reply-To:"
>
> To UNSUBSCRIBE, email to
> with a subject of "unsubscribe". Trouble? Contact
>



même
find /sys/bus -name "rf_kill" -print
ne te signale rien ?
Ben désolé, pas d'autre idée.

++, MATT

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme