Re: WiFi ThinkPad 600 sous Sarge avec pcmcia D-Link et la Fonera (routeur FON2200)

Le
Bernard
Le Fri, 24 Oct 2008 14:10:09 +0200, steve a écrit :

> Le 2008-10-24, à 13:37:36 +0200, Bernard (bdebreil@teaser.fr) a écrit :
>
> Salut Bernard,
>

>> Windows a donc détecté
>> ma Fonera, puisqu'apparaissait, avec l'icône 'réseaux', la mention de
>> 'dd-wrt', ce qui, ai-je appris, est l'un des noms de cet outil ou de son
>> driver interne. J'ai alors essayé "d'entrer dans la boîte" avec une
>> adresse IP trouvée via Google : 169.254.255.1.
>
> Tu ne vas certainement pas atteindre ta fonera avec cette adresse.
>
>> Cette adresse ne menait à
>> rien avec mon portable sous debian, elle ne donne rien non plus sur mon
>> Desktop sous le même Debian, mais, sous MSWIN çà fonctionne.
>
> Etrange !
>
> Bon je crois que tu mélanges pas mal de trucs.

C'est bien possible :) Cependant, il n'est pas douteux que çà
fonctionne sous MSWIN sur mon Desktop équipé d'une carte wifi, et que
cela fonctionnait également sur mon portable sous Win 98 SANS carte WiFi
(seulement une carte Ethernet)

>
> Sur ta Debian, tapes (en root) :
>
> ifconfig

Bien évidemment, j'ai déjà essayé ifconfig et iwconfig. Je
refais l'essai à l'instant sur mon portable, le câble en provenance du
routeur Fonera étant connecté dans la carte Ethernet pcmcia. Pas de
copié collé, car ce n'est pas sur le même ordi :

#ifconfig

eth0 lien encap:Ethernet HWaddr etc
UP BROADCAST RUNNING MULTICAST .
RX packets:0 errors: 0 .
etc. (je ne recopie pas tout)

lo Lien encap: Boucle locale
inet adr:127.0.0.1 Masque: 255.0.0.0
UP LOOPBACK RUNNING .
etc..

C'est tout. Sur mon Desktop, j'ai, en plus ra0 grâce à la carte WiFi
Ralink, et tiens, comme c'est ici facile grâce au copié collé, je vous
donne celui de ce desktop qui, comme vous le voyez en face de ra0, est
connecté en wifi sur ma Livebox


debreil:/home/bd# ifconfig
eth0 Lien encap:Ethernet HWaddr 00:04:76:A3:3C:A1
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interruption:19 Adresse de base:0xcc00

eth1 Lien encap:Ethernet HWaddr 00:18:F3:69:D8:A5
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interruption:17 Adresse de base:0xe000

lo Lien encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:13 errors:0 dropped:0 overruns:0 frame:0
TX packets:13 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:1120 (1.0 KiB) TX bytes:1120 (1.0 KiB)

ra0 Lien encap:Ethernet HWaddr 00:13:D3:84:2E:C7
inet adr:192.168.1.10 Bcast:192.168.1.255 Masque:255.255.255.0
adr inet6: fe80::213:d3ff:fe84:2ec7/64 Scope:Lien
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:123220 errors:0 dropped:0 overruns:0 frame:0
TX packets:11106 errors:10 dropped:10 overruns:0 carrier:0
collisions:358 lg file transmission:1000
RX bytes:23421481 (22.3 MiB) TX bytes:2748645 (2.6 MiB)
Interruption:21

mais cela c'est seulement pour mémoire, car ce n'est pas sur ce PC là
que se pose un problème.


>
> ça va te sortir la liste de tes interfaces réseaux, wifi et ethernet
> (notées eth0, eth1 etc selon le nombre de cartes que tu as dans
> Debian). Si
> tu as une carte wifi sur ta Debian (je n'ai pas lu tes précédents
> messages désolé), tu devrais avoir un bloc qui s'appelle ath0 ou wlan0
> ou En tapant ensuite
>
> iwconfig
>
> il va y avoir ces mêmes blocs mais pour tous il sera noté
>
> "no wireless extentions."

tout juste :

#iwconfig, sur
le portable qui nous intéresse : rien d'autre que eth0 et lo, avec les
mentions "non wireless extensions". J'ai installé les 'wireless-tools',
sinon je n'aurais même pas accès à 'iwconfig'. Peut-être y-a-t-il
quelque chose que j'ai oublié d'installer ?

>
> sauf pour un et ce sera donc ta carte wifi.
>
> Mettons que ce soit wlan0.

Non, il n'y a rien du tout, rien d'autre que eth0 et lo

>
>
>> J'ai alors
>> pu accéder à tout un tas d'informations et de possibilités de
>> configuration :
>>
>> router name : DD-WRT
>> router Model : FONERA 2100/2200
>> LAN MAC:
>> WIRELESS MAC
>> WAN IP: disabled
>> LAN IP: 192.168.1.1
>
> ça c'est l'adresse de la fonera. Pour y accéder une de tes cartes
> *doit* être sur le réseau 192.168.1.0/24 (par ex. 192.168.1.78), que
> ce soit l'ethernet (ce que je crois vu que sous window$ ça marche (et
> c'est toujours le cas tout le monde le sait bien)) ou le wifi.

Mais comment "mettre ma carte" sur l'une de ces adresses, par exemple
192.168.1.78 ?
>
>> etc., etc..
>>
>> SSID: dd-wrt
>
> ça c'est le "nom" de la fonera pour les clients wifi. De ta Debian, si
> tu tapes :
>
> iwlist wlan0 scan (ou ath0, selon ce qu'on a vu au-dessus)

le test tant sur wlan0 que sur ath0 me répond: "Interface doesn't support
scanning". En fait ces interfaces n'apparaissent nulle part sur ce
portable. Si je me souviens bien de la doc que j'aie vue sur dd-wrt,
l'interface devrait être ath0.

> tu devrais voir apparaître une liste de point d'accès dont celui de ta
> fonera (dd-wrt)
>
>> Mais je ne sais pas comment faire reconnaître ce routeur sous Debian
>> avec mon portable. Peut-être devrais-je installer le pilote dd-wrt ?
>
> Si le 'iwconfig' donne quelque chose, le module (driver ou pilote) de ta
> carte wifi est *déjà* chargé et le système reconnaît parfaitement
> ta carte. Si c'est le cas il ne te reste "plus" qu'à configurer ta
> carte pour que
>
> 1) elle s'associe à ta fonera et
> 2) elle obtienne une IP
>
>
>> Je ne
>> trouve rien de semblable par apt-cache search, même en activant les
>> "backports" sur mon source-lists.
>
> Totalement inutile et hors sujet ici.
>
>> Merci de me dire où je puis espérer trouver ce debian package s'il
>> existe, ou alors quelle version compilable je pourrais essayer (j'en ai
>> vu plusieurs via Google)
>
> Tapes les commandes que je t'ai indiquées plus haut et mets le
> résultat ici (copie-colle).

Voilà, c'est fait. Merci d'avance pour la suite..

Bernard

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Frédéric BOITEUX
Le #17632331
Le ven 24 oct 2008 16:08:51 CEST, Bernard

Bien évidemment, j'ai déjà essayé ifconfig et iwconfig. Je
refais l'essai à l'instant sur mon portable, le câble en provenance du
routeur Fonera étant connecté dans la carte Ethernet pcmcia. Pas de
copié collé, car ce n'est pas sur le même ordi :

#ifconfig

eth0 lien encap:Ethernet HWaddr etc...
UP BROADCAST RUNNING MULTICAST ....
RX packets:0 errors: 0 ....
etc. (je ne recopie pas tout)

lo Lien encap: Boucle locale
inet adr:127.0.0.1 Masque: 255.0.0.0
UP LOOPBACK RUNNING ....
etc..



Dans le paragraphe sur eth0, tu n'as pas de
« inet adr:<une adresse-IP> » : ta carte Ethernet n'a donc pas une
adresse, c'est normal que tu ne puisse aller nulle part... Il faut donc
que tu vérifies :
1/ que ton ordi demandes bien une adresse IP à ton routeur Fonera par
dhcp

2/ que ta Fonera est bien capable de t'en donner une... je ne connais
pas la config exacte de cette bestiole, mais si elle est censée router,
ce devrait être le cas. Si comme quelqu'un l'a dit elle est censée
partager sa connexion filaire par le Wifi, alors sans doute
cherche-t-elle *elle aussi* une adresse par DHCP sur sa connexion
filaire (Ethernet), si bien que vous ne pouvez discuter.

Une solution est d'utiliser le système d'adresses IP « locales » (en
169.254.XXX.XXX justement) : je crois que c'est le paquet « avahi » qui fait cela sous Linux, mais je ne m'en suis jamais servi...

Il te faudra sans doute reconfigurer ta Fonera pour la mettre dans le
bon mode (client Wifi et non AP) .

Bon courage,
Fred.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/DebFrFrenchLists
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme