recalcul formule

Le
benou
bonjour,

Alors voila mon problème..
2 feuilles, dans l'une une tripoté de formules du style :
=SI(ESTERREUR(RECHERCHEV("Moyenne
"&$A11;Vendeurs!$A$2:$P$1000;13;FAUX));0;RECHERCHEV("Moyenne
"&$A11;Vendeurs!$A$2:$P$1000;13;FAUX))/100
Bref faisant référence à une plage d'une autre feuille
Jusque là ça va !!

Mais quand je fais des suppression de lignes ou de colonne dans la feuille
'vendeur' la formule change pour devenir par exemple
=SI(ESTERREUR(RECHERCHEV("Moyenne "&$A11;Vendeurs!$A$2:$P$999
;13;FAUX));0;RECHERCHEV("Moyenne&$A11;Vendeurs!$A$2:$P$999;13;FAUX))/100

Et forcément à un moment les formules ont à côté de la plaque..

Il y a t'il une solution pour que cette formule soit définitivement "fixée"
quel que soient les modification sur la feuille 'cible'.. ?

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #17842241
Bonjour.
Je ne comprends pas pourquoi ça te gêne... Mais si tu veux une plage
fixe, définis un nom (Insertion, Nom, Définir) en lui mettant dans
"rèfère à"
ÞCALER(Vendeurs!$A$2;;;999;1)
Et tu mets le nom à la place de la plage de cellules.
Cordialement.
Daniel

bonjour,

Alors voila mon problème..
2 feuilles, dans l'une une tripoté de formules du style :
=SI(ESTERREUR(RECHERCHEV("Moyenne
"&$A11;Vendeurs!$A$2:$P$1000;13;FAUX));0;RECHERCHEV("Moyenne
"&$A11;Vendeurs!$A$2:$P$1000;13;FAUX))/100
Bref faisant référence à une plage d'une autre feuille...
Jusque là ça va !!

Mais quand je fais des suppression de lignes ou de colonne dans la feuille
'vendeur' la formule change pour devenir par exemple
=SI(ESTERREUR(RECHERCHEV("Moyenne "&$A11;Vendeurs!$A$2:$P$999
;13;FAUX));0;RECHERCHEV("Moyenne&$A11;Vendeurs!$A$2:$P$999;13;FAUX))/100

Et forcément à un moment les formules ont à côté de la plaque..

Il y a t'il une solution pour que cette formule soit définitivement "fixée"
quel que soient les modification sur la feuille 'cible'.. ?

Merci


Sam
Le #17844521
Bonjour,
si tu supprime des colonnes, la recherche 13 colonnes plus loin risque de
tomber dans les choux
La solution serait de nommer ta colonne donnant le résultat et d'utiliser
une formule du type
index (nom de la colonne; equiv("Moyenne"&A11;Vendeurs!$A$2:$A$1000;0))
Cordialement
Michel dit "Sam"

"benou"
bonjour,

Alors voila mon problème..
2 feuilles, dans l'une une tripoté de formules du style :
=SI(ESTERREUR(RECHERCHEV("Moyenne
"&$A11;Vendeurs!$A$2:$P$1000;13;FAUX));0;RECHERCHEV("Moyenne
"&$A11;Vendeurs!$A$2:$P$1000;13;FAUX))/100
Bref faisant référence à une plage d'une autre feuille...
Jusque là ça va !!

Mais quand je fais des suppression de lignes ou de colonne dans la feuille
'vendeur' la formule change pour devenir par exemple
=SI(ESTERREUR(RECHERCHEV("Moyenne "&$A11;Vendeurs!$A$2:$P$999
;13;FAUX));0;RECHERCHEV("Moyenne&$A11;Vendeurs!$A$2:$P$999;13;FAUX))/100

Et forcément à un moment les formules ont à côté de la plaque..

Il y a t'il une solution pour que cette formule soit définitivement
"fixée"
quel que soient les modification sur la feuille 'cible'.. ?

Merci


Publicité
Poster une réponse
Anonyme