RecehrcheV cherche par ordre alphabétique :-(

Le
Perceval
Bonjour à tous,

J'utilise la fonction RechercheV pour introduire dans une cellule la valeur
adjacente d'une cellule de référence, mais la recherche s'arrete dès qu'elle
trouve un nom qui s'approche. Je suis obligé de ranger mes nom par ordre
alphabétique pour que cela fonctionne.
N'y a-t-il pas d'alternative ?

Exemple :

Matrice F1:G5

MachineA Temps1
MachineB Temps2
MachineC Temps3
MachineD Temps4
MachineE Temps5

Formules dans les cellules F9 "=RECHERCHEV(F9;$F$1:$G$5;2)" jusqu'a à F40
"=RECHERCHEV(F40;$F$1:$G$5;2)"

Exemple :

MachineA Temps1
MachineD Temps4
MachineC Temps3
MachineE Temps5
MachineB Temps2

Si F10 contien "MachineB" la formule devrait renvoyer la valeur "Temps2"

Mais "RECHERCHEV(F10;$F$1:$G$5;2)" renvoie la valeur "Temps4" qui est la
première valeur trouvée après "MachineA"

J'espère que j'ai été clair :-S

Pourriez-vous m'aider ?
Merci d'avance
Perceval
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #19392891
Bonjour,
Utilises plutôt la combinaison index(equiv))
Extrait de l'aide :
INDEX(tableau;no_lig;no_col) renvoie la valeur d'une cellule ou d'une
matrice de cellules déterminée de l'argument tableau.

Renvoie la position relative d'un élément d'une matrice qui équivaut à une
valeur spécifiée dans un ordre donné. Utilisez la fonction EQUIV plutôt
qu'une des fonctions RECHERCHE lorsque vous avez besoin de la position d'un
élément dans une plage et non de l'élément en tant que tel.

Syntaxe

EQUIV(valeur_cherchée;matrice_recherche;type)

valeur_cherchée est la valeur utilisée pour trouver la valeur souhaitée
dans une matrice.

L'argument valeur_cherchée est la valeur dont vous voulez l'équivalent dans
l'argument matrice_recherche. Par exemple, lorsque vous cherchez le numéro
de téléphone d'une personne dans un annuaire, vous utilisez le nom de la
personne comme valeur de recherche alors que la valeur que vous voulez
obtenir est son numéro de téléphone.

L'argument valeur_cherchée peut être une valeur (nombre, texte ou valeur
logique) ou une référence de cellule à un nombre, à du texte ou à une valeur
logique.

matrice_recherche est une plage de cellules adjacentes contenant les
valeurs d'équivalence possibles. L'argument matrice_recherche peut être une
matrice ou une référence matricielle.

type est le nombre -1, 0 ou 1 qui indique comment Microsoft Excel doit
procéder pour comparer l'argument valeur_cherchée aux valeurs de l'argument
matrice_recherche.

Si la valeur de l'argument type est 1, la fonction EQUIV trouve la valeur la
plus élevée qui est inférieure ou égale à celle de l'argument
valeur_cherchée. Les valeurs de l'argument matrice_recherche doivent être
placées en ordre croissant : ...-2, -1, 0, 1, 2, ..., A-Z, FAUX, VRAI.

Si la valeur de l'argument type est 0, la fonction EQUIV trouve la première
valeur exactement équivalente à celle de l'argument valeur_cherchée. Les
valeurs de l'argument matrice_recherche peuvent être placées dans un ordre
quelconque.

Si la valeur de l'argument type est -1, la fonction EQUIV trouve la plus
petite valeur qui est supérieure ou égale à celle de l'argument
valeur_cherchée. Les valeurs de l'argument matrice_recherche doivent être
placées en ordre décroissant : VRAI, FAUX, Z-A, ..., 2, 1, 0, -1, -2, ...,
et ainsi de suite.

Si l'argument type est omis, la valeur par défaut est 1.



--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"Perceval" de news:I5MRl.35840$
Bonjour à tous,

J'utilise la fonction RechercheV pour introduire dans une cellule la
valeur adjacente d'une cellule de référence, mais la recherche s'arrete
dès qu'elle trouve un nom qui s'approche. Je suis obligé de ranger mes nom
par ordre alphabétique pour que cela fonctionne.
N'y a-t-il pas d'alternative ?

Exemple :

Matrice F1:G5

MachineA Temps1
MachineB Temps2
MachineC Temps3
MachineD Temps4
MachineE Temps5

Formules dans les cellules F9 "=RECHERCHEV(F9;$F$1:$G$5;2)" jusqu'a à F40
"=RECHERCHEV(F40;$F$1:$G$5;2)"

Exemple :

MachineA Temps1
MachineD Temps4
MachineC Temps3
MachineE Temps5
MachineB Temps2

Si F10 contien "MachineB" la formule devrait renvoyer la valeur "Temps2"

Mais "RECHERCHEV(F10;$F$1:$G$5;2)" renvoie la valeur "Temps4" qui est la
première valeur trouvée après "MachineA"

J'espère que j'ai été clair :-S

Pourriez-vous m'aider ?
Merci d'avance
Perceval



Thierry
Le #19392881
Bonjour,

tu a omis un paramètre dans ta formule: "Faux"
"=RECHERCHEV(F40;$F$1:$G$5;2;FAUX)"
Bonne journée,
Thierry.


"Perceval" de news: I5MRl.35840$
Bonjour à tous,

J'utilise la fonction RechercheV pour introduire dans une cellule la


valeur
adjacente d'une cellule de référence, mais la recherche s'arrete dès


qu'elle
trouve un nom qui s'approche. Je suis obligé de ranger mes nom par ordre
alphabétique pour que cela fonctionne.
N'y a-t-il pas d'alternative ?

Exemple :

Matrice F1:G5

MachineA Temps1
MachineB Temps2
MachineC Temps3
MachineD Temps4
MachineE Temps5

Formules dans les cellules F9 "=RECHERCHEV(F9;$F$1:$G$5;2)" jusqu'a à F40
"=RECHERCHEV(F40;$F$1:$G$5;2)"

Exemple :

MachineA Temps1
MachineD Temps4
MachineC Temps3
MachineE Temps5
MachineB Temps2

Si F10 contien "MachineB" la formule devrait renvoyer la valeur "Temps2"

Mais "RECHERCHEV(F10;$F$1:$G$5;2)" renvoie la valeur "Temps4" qui est la
première valeur trouvée après "MachineA"

J'espère que j'ai été clair :-S

Pourriez-vous m'aider ?
Merci d'avance
Perceval




JB
Le #19392901
Bonjour,

http://boisgontierjacques.free.fr/pages_site/recherchev.htm

JB
http://boisgontierjacques.free.fr/

On 23 mai, 07:47, "Perceval" wrote:
Bonjour à tous,

J'utilise la fonction RechercheV pour introduire dans une cellule la vale ur
adjacente d'une cellule de référence, mais la recherche s'arrete dè s qu'elle
trouve un nom qui s'approche. Je suis obligé de ranger mes nom par ordr e
alphabétique pour que cela fonctionne.
N'y a-t-il pas d'alternative ?

Exemple :

Matrice F1:G5

MachineA    Temps1
MachineB    Temps2
MachineC    Temps3
MachineD    Temps4
MachineE    Temps5

Formules dans les cellules F9 "=RECHERCHEV(F9;$F$1:$G$5;2)" jusqu'a à F40
"=RECHERCHEV(F40;$F$1:$G$5;2)"

Exemple :

MachineA    Temps1
MachineD    Temps4
MachineC    Temps3
MachineE    Temps5
MachineB    Temps2

Si F10 contien "MachineB" la formule devrait renvoyer la valeur "Temps2"

Mais "RECHERCHEV(F10;$F$1:$G$5;2)" renvoie la valeur "Temps4" qui est la
première valeur trouvée après "MachineA"

J'espère que j'ai été clair :-S

Pourriez-vous m'aider ?
Merci d'avance
Perceval


Perceval
Le #19404091
Ca marche impeccable :-)
Merci :-)
Perc


"Thierry"
Bonjour,

tu a omis un paramètre dans ta formule: "Faux"
"=RECHERCHEV(F40;$F$1:$G$5;2;FAUX)"
Bonne journée,
Thierry.


"Perceval" message
de news: I5MRl.35840$
Bonjour à tous,

J'utilise la fonction RechercheV pour introduire dans une cellule la


valeur
adjacente d'une cellule de référence, mais la recherche s'arrete dès


qu'elle
trouve un nom qui s'approche. Je suis obligé de ranger mes nom par ordre
alphabétique pour que cela fonctionne.
N'y a-t-il pas d'alternative ?

Exemple :

Matrice F1:G5

MachineA Temps1
MachineB Temps2
MachineC Temps3
MachineD Temps4
MachineE Temps5

Formules dans les cellules F9 "=RECHERCHEV(F9;$F$1:$G$5;2)" jusqu'a à F40
"=RECHERCHEV(F40;$F$1:$G$5;2)"

Exemple :

MachineA Temps1
MachineD Temps4
MachineC Temps3
MachineE Temps5
MachineB Temps2

Si F10 contien "MachineB" la formule devrait renvoyer la valeur "Temps2"

Mais "RECHERCHEV(F10;$F$1:$G$5;2)" renvoie la valeur "Temps4" qui est la
première valeur trouvée après "MachineA"

J'espère que j'ai été clair :-S

Pourriez-vous m'aider ?
Merci d'avance
Perceval








Publicité
Poster une réponse
Anonyme