Une recherche assez spécial

Le
GARAULT
Bonjour tout le monde et bon week end.

J'ai un petit soucis pour effectuer une recherche.
Dans une feuil2 de mon classeur je vois apparaitre des renseignement de ce
genre:

CROUS YANNICK DEBIT 10/05/2007 20:58:15
LOGILOG ERIC DEBIT 10/07/2007 11:26:43 11:26:43
CROUS YANNICK MONTAGE 10/07/2007 15:14:23
DISTRIM CATHY MONTAGE 10/07/2007 15:14:29
LOGILOG ERIC DEBIT 10/07/2007 15:22:03


en gros: CHANTIER, suivit de la PERSONNE, LA DATE, heure de debut ou de fin
de fabrication.

Dans une feuil5 je voudrais pouvoir effectuer une recherche genre, si dans
une liste je choisi le chantier CROUS, la recherche va m'afficher toutes les
ligne ou CROUS apparait

C'est possible ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #4972631
Bonjour GARAULT,
Oui, c'est très probablement possible ; mais avant de risquer de monter une
usine à gaz, deux questions :
Les données de feuil2 sont elles réparties en colonnes ?
Si oui, un filtre automatique appliqué sur cette feuille ne conviendrait il
pas ?
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"GARAULT" news:
Bonjour tout le monde et bon week end.

J'ai un petit soucis pour effectuer une recherche.
Dans une feuil2 de mon classeur je vois apparaitre des renseignement de ce
genre:

CROUS YANNICK DEBIT 10/05/2007 20:58:15
LOGILOG ERIC DEBIT 10/07/2007 11:26:43 11:26:43
CROUS YANNICK MONTAGE 10/07/2007 15:14:23
DISTRIM CATHY MONTAGE 10/07/2007 15:14:29
LOGILOG ERIC DEBIT 10/07/2007 15:22:03


en gros: CHANTIER, suivit de la PERSONNE, LA DATE, heure de debut ou de
fin
de fabrication.

Dans une feuil5 je voudrais pouvoir effectuer une recherche genre, si dans
une liste je choisi le chantier CROUS, la recherche va m'afficher toutes
les
ligne ou CROUS apparait......

C'est possible ?


claudy
Le #4972611
Bonjour,
en fait, il te faudrait trois colonnes: Chantier Personne Date
Ta colonne Chantier triée de A>>>Z
Et dans ta feuille 5 une formule du genre =RECHERCHEV(A1;Tes données; 2)
pour la personne
Fais une recherche dans l'aide "Touche F1" sur la fonction RECHERCHEV
Tu peux aussi mettre ton classeur sur http://cjoint.com/ et je t'arrange ça.
A+
Claudy
Une formule dans le
"GARAULT" news:
Bonjour tout le monde et bon week end.

J'ai un petit soucis pour effectuer une recherche.
Dans une feuil2 de mon classeur je vois apparaitre des renseignement de ce
genre:

CROUS YANNICK DEBIT 10/05/2007 20:58:15
LOGILOG ERIC DEBIT 10/07/2007 11:26:43 11:26:43
CROUS YANNICK MONTAGE 10/07/2007 15:14:23
DISTRIM CATHY MONTAGE 10/07/2007 15:14:29
LOGILOG ERIC DEBIT 10/07/2007 15:22:03


en gros: CHANTIER, suivit de la PERSONNE, LA DATE, heure de debut ou de
fin
de fabrication.

Dans une feuil5 je voudrais pouvoir effectuer une recherche genre, si dans
une liste je choisi le chantier CROUS, la recherche va m'afficher toutes
les
ligne ou CROUS apparait......

C'est possible ?


François
Le #4972591
Bonjour GARAULT,

Si j'ai bien compris ce que tu voulais dire, ces données sont sur des
colonnes différentes (CHANTIER en A, PERSONNE en B, DATE en C, heure de
debout ou de fin en D ...). Le plus simple serait alors d'activer les
filtres automatiques (Données/Filtre/Filtre automatiques) pour une recherche
ponctuelle, ou pour une recherche par type, d'activer les filtres élaborés
(Données/Filtre/Filtre élaboré) après avoir sélectionné le tableau avec les
titres ...
comme dans cet exemple :
http://cjoint.com/?kojuQ8XVxi
ou sur le site de JB : http://boisgontierj.free.fr/ rubrique filtre élaboré
...

François



"GARAULT" news:
Bonjour tout le monde et bon week end.

J'ai un petit soucis pour effectuer une recherche.
Dans une feuil2 de mon classeur je vois apparaitre des renseignement de ce
genre:

CROUS YANNICK DEBIT 10/05/2007 20:58:15
LOGILOG ERIC DEBIT 10/07/2007 11:26:43 11:26:43
CROUS YANNICK MONTAGE 10/07/2007 15:14:23
DISTRIM CATHY MONTAGE 10/07/2007 15:14:29
LOGILOG ERIC DEBIT 10/07/2007 15:22:03


en gros: CHANTIER, suivit de la PERSONNE, LA DATE, heure de debut ou de
fin
de fabrication.

Dans une feuil5 je voudrais pouvoir effectuer une recherche genre, si dans
une liste je choisi le chantier CROUS, la recherche va m'afficher toutes
les
ligne ou CROUS apparait......

C'est possible ?


ChrisV
Le #4972531
Bonjour Garault,

En supposant que la plage de données initiales (nommée ici Zn) se situe,
selon ton exemple, en A1:F5
et en Feuil5!A1 le nom du chantier recherché.

A saisir (sans les { }) sur une plage verticale (dans notre exemple, sur
Feuil5!B1:B5) de même dimension que Zn
et valider par Ctrl+shift+Entrée:

{=SI(ESTERR(PETITE.VALEUR(SI(DECALER(Zn;;;;1)=$A1;1+LIGNE(Zn)-CELLULE("ligne";Zn));LIGNE(INDIRECT("1:"&LIGNES(Zn)))));"";INDEX(Zn;PETITE.VALEUR(SI(DECALER(Zn;;;;1)=$A1;1+LIGNE(Zn)-CELLULE("ligne";Zn));LIGNE(INDIRECT("1:"&LIGNES(Zn))));COLONNE()))}

puis recopier vers F5
formater ensuite les colonnes:
D au format jj:mm:aaaa
E et F au format hh:mm:ss


ChrisV
[une formule qui devrait faire plaisir à Philippe...]



"GARAULT" news:
Bonjour tout le monde et bon week end.

J'ai un petit soucis pour effectuer une recherche.
Dans une feuil2 de mon classeur je vois apparaitre des renseignement de ce
genre:

CROUS YANNICK DEBIT 10/05/2007 20:58:15
LOGILOG ERIC DEBIT 10/07/2007 11:26:43 11:26:43
CROUS YANNICK MONTAGE 10/07/2007 15:14:23
DISTRIM CATHY MONTAGE 10/07/2007 15:14:29
LOGILOG ERIC DEBIT 10/07/2007 15:22:03


en gros: CHANTIER, suivit de la PERSONNE, LA DATE, heure de debut ou de
fin
de fabrication.

Dans une feuil5 je voudrais pouvoir effectuer une recherche genre, si dans
une liste je choisi le chantier CROUS, la recherche va m'afficher toutes
les
ligne ou CROUS apparait......

C'est possible ?


Philippe.R
Le #4972481
Mmmmh !
Je me la déguste au repas de ce midi !
;o))))
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"ChrisV" news:
Bonjour Garault,

En supposant que la plage de données initiales (nommée ici Zn) se situe,
selon ton exemple, en A1:F5
et en Feuil5!A1 le nom du chantier recherché.

A saisir (sans les { }) sur une plage verticale (dans notre exemple, sur
Feuil5!B1:B5) de même dimension que Zn
et valider par Ctrl+shift+Entrée:

{=SI(ESTERR(PETITE.VALEUR(SI(DECALER(Zn;;;;1)=$A1;1+LIGNE(Zn)-CELLULE("ligne";Zn));LIGNE(INDIRECT("1:"&LIGNES(Zn)))));"";INDEX(Zn;PETITE.VALEUR(SI(DECALER(Zn;;;;1)=$A1;1+LIGNE(Zn)-CELLULE("ligne";Zn));LIGNE(INDIRECT("1:"&LIGNES(Zn))));COLONNE()))}

puis recopier vers F5
formater ensuite les colonnes:
D au format jj:mm:aaaa
E et F au format hh:mm:ss


ChrisV
[une formule qui devrait faire plaisir à Philippe...]



"GARAULT" news:
Bonjour tout le monde et bon week end.

J'ai un petit soucis pour effectuer une recherche.
Dans une feuil2 de mon classeur je vois apparaitre des renseignement de
ce
genre:

CROUS YANNICK DEBIT 10/05/2007 20:58:15
LOGILOG ERIC DEBIT 10/07/2007 11:26:43 11:26:43
CROUS YANNICK MONTAGE 10/07/2007 15:14:23
DISTRIM CATHY MONTAGE 10/07/2007 15:14:29
LOGILOG ERIC DEBIT 10/07/2007 15:22:03


en gros: CHANTIER, suivit de la PERSONNE, LA DATE, heure de debut ou de
fin
de fabrication.

Dans une feuil5 je voudrais pouvoir effectuer une recherche genre, si
dans
une liste je choisi le chantier CROUS, la recherche va m'afficher toutes
les
ligne ou CROUS apparait......

C'est possible ?






Philippe.R
Le #4972461
Re ChrisV,
Comme j'ai placé une liste de validation en A1 pour appeler les chantiers,
pour ne pas être gêné par la superposition de la flèche avec la cellule B1,
j'ai décalé la plage de formules et ajusté ainsi en conséquence :

=SI(ESTERR(PETITE.VALEUR(SI(DECALER(zn;;;;1)=$A1;1+LIGNE(zn)-CELLULE("ligne";zn));LIGNE(INDIRECT("1:"&LIGNES(zn)))));"";INDEX(zn;PETITE.VALEUR(SI(DECALER(zn;;;;1)=$A1;1+LIGNE(zn)-CELLULE("ligne";zn));LIGNE(INDIRECT("1:"&LIGNES(zn))));COLONNE()-1))

me régale, moi ;o)))
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R
"ChrisV" news:
Bonjour Garault,

En supposant que la plage de données initiales (nommée ici Zn) se situe,
selon ton exemple, en A1:F5
et en Feuil5!A1 le nom du chantier recherché.

A saisir (sans les { }) sur une plage verticale (dans notre exemple, sur
Feuil5!B1:B5) de même dimension que Zn
et valider par Ctrl+shift+Entrée:

{=SI(ESTERR(PETITE.VALEUR(SI(DECALER(Zn;;;;1)=$A1;1+LIGNE(Zn)-CELLULE("ligne";Zn));LIGNE(INDIRECT("1:"&LIGNES(Zn)))));"";INDEX(Zn;PETITE.VALEUR(SI(DECALER(Zn;;;;1)=$A1;1+LIGNE(Zn)-CELLULE("ligne";Zn));LIGNE(INDIRECT("1:"&LIGNES(Zn))));COLONNE()))}

puis recopier vers F5
formater ensuite les colonnes:
D au format jj:mm:aaaa
E et F au format hh:mm:ss


ChrisV
[une formule qui devrait faire plaisir à Philippe...]



"GARAULT" news:
Bonjour tout le monde et bon week end.

J'ai un petit soucis pour effectuer une recherche.
Dans une feuil2 de mon classeur je vois apparaitre des renseignement de
ce
genre:

CROUS YANNICK DEBIT 10/05/2007 20:58:15
LOGILOG ERIC DEBIT 10/07/2007 11:26:43 11:26:43
CROUS YANNICK MONTAGE 10/07/2007 15:14:23
DISTRIM CATHY MONTAGE 10/07/2007 15:14:29
LOGILOG ERIC DEBIT 10/07/2007 15:22:03


en gros: CHANTIER, suivit de la PERSONNE, LA DATE, heure de debut ou de
fin
de fabrication.

Dans une feuil5 je voudrais pouvoir effectuer une recherche genre, si
dans
une liste je choisi le chantier CROUS, la recherche va m'afficher toutes
les
ligne ou CROUS apparait......

C'est possible ?






ChrisV
Le #4988451
Ok Philippe, tout à fait exact ! ;-)

Toutefois, si l'on souhaite déplacer, sans contrainte, la plage de
résultats, tu aurais pu aussi utiliser:
(à saisir sans les { } et valider par Ctrl+Shift+Entrée, sur la plage
Feuil5!B1:F5

{=SI(ESTERR(PETITE.VALEUR(SI(DECALER(Zn;;;;1)=$A1;1+LIGNE(Zn)-CELLULE("ligne";Zn));LIGNE(INDIRECT("1:"&LIGNES(Zn)))));"";INDEX(Zn;PETITE.VALEUR(SI(DECALER(Zn;;;;1)=$A1;1+LIGNE(Zn)-CELLULE("ligne";Zn));LIGNE(INDIRECT("1:"&LIGNES(Zn))));{2.3.4.5.6}))}

ou si Zn comportait un grand nombre de colonnes, et afin d'éviter
"l'allongement" du {2.3.4..............n}

{=SI(ESTERR(PETITE.VALEUR(SI(DECALER(Zn;;;;1)=$A1;1+LIGNE(Zn)-CELLULE("ligne";Zn));LIGNE(INDIRECT("1:"&LIGNES(Zn)))));"";INDEX(Zn;PETITE.VALEUR(SI(DECALER(Zn;;;;1)=$A1;1+LIGNE(Zn)-CELLULE("ligne";Zn));LIGNE(INDIRECT("1:"&LIGNES(Zn))));1+COLONNE(INDIRECT("1:"&COLONNES(Zn)))))}


ChrisV



"Philippe.R" %231bD3$
Re ChrisV,
Comme j'ai placé une liste de validation en A1 pour appeler les chantiers,
pour ne pas être gêné par la superposition de la flèche avec la cellule
B1, j'ai décalé la plage de formules et ajusté ainsi en conséquence :

=SI(ESTERR(PETITE.VALEUR(SI(DECALER(zn;;;;1)=$A1;1+LIGNE(zn)-CELLULE("ligne";zn));LIGNE(INDIRECT("1:"&LIGNES(zn)))));"";INDEX(zn;PETITE.VALEUR(SI(DECALER(zn;;;;1)=$A1;1+LIGNE(zn)-CELLULE("ligne";zn));LIGNE(INDIRECT("1:"&LIGNES(zn))));COLONNE()-1))

me régale, moi ;o)))
--
http://www.excelabo.net/mpfe/connexion.php
http://dj.joss.free.fr/trombine.htm
Avec plaisir
Philippe.R


Publicité
Poster une réponse
Anonyme