recherche avec si et

Le
freedo
Bonjour à Toutes et à Tous,
j'aimerais réaliser une recherche suivant 2 conditions et je n'arrive
pas à imbriquer la formulation Si et ET
dans la cellule A5 j'ai un carractère , par exemple "<" ou bien
"--" .
dans la cellule B4 je tape 1000 ou 1200
et dans une autre cellule j'ai la formule suivante:
=SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E
$12;5);SI(B4=1000;RECHERCHEV(G5;tarifs!$A$4:$C$12;3))))

j'essaie ceci , pfff ! !
=SI(B4=1000;SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E
$12;5);SI(B4=1000;RECHERCHEV(G5;tarifs!$A$4:$C$12;3))))
j'aimerais combiner avec la condition suivante :
=SI(B4=1200;SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E
$12;15);SI(B4=1000;RECHERCHEV(G5;tarifs!$A$4:$C$12;13))))
donc j'aimerais une seule formule qui traite le cas selon qu'il y ait
1000 ou 1200 dans la cellule B4.
merci de suivre,
Freedo
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #5280371
Bonjour,

Si j'ai bien compris....
essaie ceci
=SI(A5<>"<";"";SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;3);SI(B400;RECHERCHEV(G5;tarifs!$A$4:$E$12;5);"")))

--
Salutations
JJ


"freedo"
Bonjour à Toutes et à Tous,
j'aimerais réaliser une recherche suivant 2 conditions et je n'arrive
pas à imbriquer la formulation Si et ET
dans la cellule A5 j'ai un carractère , par exemple "<" ou bien
"--" ....
dans la cellule B4 je tape 1000 ou 1200
et dans une autre cellule j'ai la formule suivante:
=SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E
$12;5);SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;3))))

j'essaie ceci , pfff ! !
=SI(B400;SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E
$12;5);SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;3))))
j'aimerais combiner avec la condition suivante :
=SI(B400;SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E
$12;15);SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;13))))
donc j'aimerais une seule formule qui traite le cas selon qu'il y ait
1000 ou 1200 dans la cellule B4.
merci de suivre,
Freedo
freedo
Le #5280361
On 8 fév, 13:50, "Jacky"
Bonjour,

Si j'ai bien compris....
essaie ceci
=SI(A5<>"<";"";SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;3);SI(B4=1 200;REC­HERCHEV(G5;tarifs!$A$4:$E$12;5);"")))

--
Salutations
JJ

"freedo"
Bonjour à Toutes et à Tous,
j'aimerais réaliser une recherche suivant 2 conditions et je n'arrive
pas à imbriquer la formulation Si et ET
dans la cellule A5 j'ai un carractère , par exemple "<" ou bien
"--" ....
dans la cellule B4 je tape 1000 ou 1200
et dans une autre cellule j'ai la formule suivante:
=SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E
$12;5);SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;3))))

j'essaie ceci ,  pfff ! !
=SI(B400;SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E
$12;5);SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;3))))
j'aimerais combiner avec la condition suivante :
=SI(B400;SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E
$12;15);SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;13))))
donc j'aimerais une seule formule qui traite le cas selon qu'il y ait
1000 ou 1200 dans la cellule B4.
merci de suivre,
Freedo


Bonjour Jacky,
en fait il y a 2 type des recherches dans deux zone de tableaux
différents
si B400 , la plage de recherche est tarifs!$A$4:$E> $12;5) si
vrai
et tarifs!$A
$4:$E> $12;3) si faux

tandis que si B400, la plage de recherche est tarifs!$A$4:$E>
$12;15) si vrai
et
tarifs!$A$4:$E> $12;13) si faux
merci de suivre,
Freedo

Michel Samoey
Le #5280341
Bonjour,
je crois qu'il faut essayer (Aucune suggestion) les données de départ :
en A5 y a t'il que < ou --
en B4 y a t'il que 1000 ou 1200

et de comprendre le besoin comme ceci par exemple

si A5="<" et B400 aller chercher dans la colonne J
si A5="<" et B400 aller chercher dans la colonne L
si A5="--" (ou différent de "<" ) et B400 aller chercher dans la colonne
?
si A5="--" (ou différent de "<" ) et B400 aller chercher dans la colonne
?

Une fois que l'on a ça, un minimum d'algèbre de boole va permettre aux pros
du forum d'éditer la formule qui va bien.
Cordialement
Michel

"freedo"
Bonjour à Toutes et à Tous,
j'aimerais réaliser une recherche suivant 2 conditions et je n'arrive
pas à imbriquer la formulation Si et ET
dans la cellule A5 j'ai un carractère , par exemple "<" ou bien
"--" ....
dans la cellule B4 je tape 1000 ou 1200
et dans une autre cellule j'ai la formule suivante:
=SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E
$12;5);SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;3))))

j'essaie ceci , pfff ! !
=SI(B400;SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E
$12;5);SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;3))))
j'aimerais combiner avec la condition suivante :
=SI(B400;SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E
$12;15);SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;13))))
donc j'aimerais une seule formule qui traite le cas selon qu'il y ait
1000 ou 1200 dans la cellule B4.
merci de suivre,
Freedo
Michel Samoey
Le #5280321
Bonjour,
prière de remplacer dans le mail précèdent "(Aucune suggestion) " par
"connaître"
ah, la correction automatique orthographe !
Cordialement
Michel
"Michel Samoey" 47ac547a$0$835$

Bonjour,
je crois qu'il faut essayer (Aucune suggestion) les données de départ :
en A5 y a t'il que < ou --
en B4 y a t'il que 1000 ou 1200

et de comprendre le besoin comme ceci par exemple

si A5="<" et B400 aller chercher dans la colonne J
si A5="<" et B400 aller chercher dans la colonne L
si A5="--" (ou différent de "<" ) et B400 aller chercher dans la
colonne ?
si A5="--" (ou différent de "<" ) et B400 aller chercher dans la
colonne ?

Une fois que l'on a ça, un minimum d'algèbre de boole va permettre aux
pros du forum d'éditer la formule qui va bien.
Cordialement
Michel

"freedo"
Bonjour à Toutes et à Tous,
j'aimerais réaliser une recherche suivant 2 conditions et je n'arrive
pas à imbriquer la formulation Si et ET
dans la cellule A5 j'ai un carractère , par exemple "<" ou bien
"--" ....
dans la cellule B4 je tape 1000 ou 1200
et dans une autre cellule j'ai la formule suivante:
=SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E
$12;5);SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;3))))

j'essaie ceci , pfff ! !
=SI(B400;SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E
$12;5);SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;3))))
j'aimerais combiner avec la condition suivante :
=SI(B400;SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E
$12;15);SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;13))))
donc j'aimerais une seule formule qui traite le cas selon qu'il y ait
1000 ou 1200 dans la cellule B4.
merci de suivre,
Freedo



freedo
Le #5280151
On 8 fév, 14:09, "Michel Samoey"
Bonjour,
je crois qu'il faut essayer (Aucune suggestion) les données de départ :
en A5 y a t'il que < ou --
en B4 y a t'il que 1000 ou 1200

et de comprendre le besoin comme ceci par exemple

si A5="<" et B400 aller chercher dans la colonne J
si A5="<" et B400 aller chercher dans la colonne L
si A5="--" (ou différent de "<" ) et B400 aller chercher dans la colonne
?
si A5="--" (ou différent de "<" ) et B400 aller chercher dans la colonne
?

Une fois que l'on a ça, un minimum d'algèbre de boole va permettre aux pros
du forum d'éditer la formule qui va bien.
Cordialement
Michel

"freedo"
Bonjour à Toutes et à Tous,
j'aimerais réaliser une recherche suivant 2 conditions et je n'arrive
pas à imbriquer la formulation Si et ET
dans la cellule A5 j'ai un carractère , par exemple "<" ou bien
"--" ....
dans la cellule B4 je tape 1000 ou 1200
et dans une autre cellule j'ai la formule suivante:
=SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E$12;5);SI(B400;RECHERCHEV( G5;tarifs!$A$4:$C$12;3))))
j'essaie ceci ,  pfff ! !
=SI(B400;SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E$12;5);SI(B40 0;RECHERCHEV(G5;tarifs!$A$4:$C$12;3))))
j'aimerais combiner avec la condition suivante :
=SI(B400;SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E$12;15);SI(B4 00;RECHERCHEV(G5;tarifs!$A$4:$C$12;13))))
donc j'aimerais une seule formule qui traite le cas selon qu'il y ait
1000 ou 1200 dans la cellule B4.
merci de suivre,
Freedo
Bonjour Michel,

Tu as bien interprèté ma demande
en fait il faut comprendre en A5 il y a "< " ou différent de "<"
en B4 il n'y a que 1000 ou 1200
donc
si A5="<" et B400 aller chercher dans la colonne E
si A5="<" et B400 aller chercher dans la colonne N
si A5 différent de "<" et B400 aller chercher dans la colonne C
si A5 différent de "<" et B400 aller chercher dans la colonne L
Merci de suivre,
Freedo

Jacky
Le #5280131
Re...
tandis que si B400, la plage de recherche est tarifs!$A$4:$E>$12;15)
si vrai et tarifs!$A$4:$E> $12;13) si faux
Les colonnes 15 et13 ne sont pas comprises dans la plage de recherche au

moins "tarifs!$A$4:$O$15" est nécessaire.
Et le dernier paramètre de rechercheV (que j'ai aussi oublié dans ma
réponse) est nécessaire
=SI(A5<>"<";"";SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;3);SI(B400;REC­HERCHEV(G5;tarifs!$A$4:$E$12;5);"")))
=SI(A5


freedo
Le #5280051
On 8 fév, 16:26, "Jacky"
Re...>tandis que si B400, la plage de recherche est tarifs!$A$4:$E>$1 2;15)
si vrai et tarifs!$A$4:$E> $12;13)  si faux


Les colonnes 15 et13 ne sont pas comprises dans la plage de recherche au
moins "tarifs!$A$4:$O$15" est nécessaire.
Et le dernier paramètre de rechercheV (que j'ai aussi oublié dans ma
réponse) est nécessaire> =SI(A5<>"<";"";SI(B400;RECHERCHEV(G5;t arifs!$A$4:$C$12;3);SI(B400;REC­­HERCHEV(G5;tarifs!$A$4:$E$12;5);"" )))

 =SI(A5

RE-bonjour à Toutes et à Tous,
eh bien voilà avec les aides que vous m'avez donnés j'ai mis en ordre
cette formule qui a l'air de fonctionner :
=SI($B$400;(SI(A5<>"<";RECHERCHEV(G5;tarifs!$A$4:$O
$12;3);RECHERCHEV(G5;tarifs!$A$4:$O
$12;5)));SI(A5<>"<";RECHERCHEV(G5;tarifs!$A$4:$O
$12;12);RECHERCHEV(G5;tarifs!$A$4:$O$12;14)))
Bien sûr si vous avez une solutions plus radicale , je suis preneur.
Cordialement
Freedo


Jacky
Le #5279971
Re..
Il manque aussi le dernier paramètre de rechercheV
......RECHERCHEV(G5;tarifs!$A$4:$O$12;3;0).....

Pas testé ;o(

Ps: tu veux bien répondre au-dessus des réponses stp
--
Salutations
JJ


"freedo"
On 8 fév, 16:26, "Jacky"
Re...>tandis que si B400, la plage de recherche est
tarifs!$A$4:$E>$12;15)
si vrai et tarifs!$A$4:$E> $12;13) si faux


Les colonnes 15 et13 ne sont pas comprises dans la plage de recherche au
moins "tarifs!$A$4:$O$15" est nécessaire.
Et le dernier paramètre de rechercheV (que j'ai aussi oublié dans ma
réponse) est nécessaire>
=SI(A5<>"<";"";SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;3);SI(B400;REC­­HERCHEV(G5;tarifs!$A$4:$E$12;5);"")))

=SI(A5<>"<";"";SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;3;0);SI(B400;R­EC­HERCHEV(G5;tarifs!$A$4:$E$12;5;0);"")))Je
n'ai pas compris ta dernière remarque si vrai et tarifs!$A$4:$E> $12;13)
si fauxC'est quoi vrai/faux le retour de rechercheV ou la valeur de B4
??--SalutationsJJ"freedo" news: 8
fév, 13:50, "Jacky" compris....> essaie
ceci>=SI(A5<>"<";"";SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;3);SI(B40­0;REC­HERCHEV(G5;tarifs!$A$4:$E$12;5);"")))>>
--> Salutations> JJ>> "freedo" message de news:>

Bonjour à Toutes et à Tous,> j'aimerais réaliser une recherche suivant 2
conditions et je n'arrive> pas à imbriquer la formulation Si et ET> dans
la cellule A5 j'ai un carractère , par exemple " dans la cellule B4 je tape 1000 ou 1200> et dans une autre cellule j'ai la
formule suivante:> =SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E>
$12;5);SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;3))))>> j'essaie ceci ,
pfff ! !> =SI(B400;SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E>
$12;5);SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;3))))> j'aimerais
combiner avec la condition suivante :>
=SI(B400;SI(A5="<";RECHERCHEV(G5;tarifs!$A$4:$E>
$12;15);SI(B400;RECHERCHEV(G5;tarifs!$A$4:$C$12;13))))> donc j'aimerais
une seule formule qui traite le cas selon qu'il y ait> 1000 ou 1200 dans
la cellule B4.> merci de suivre,> FreedoBonjour Jacky,en fait il y a 2
type des recherches dans deux zone de tableauxdifférentssi B400 , la
plage de recherche est tarifs!$A$4:$E> $12;5) sivrai et tarifs!$A$4:$E>
$12;3) si fauxtandis que si B400, la plage de recherche est
tarifs!$A$4:$E>$12;15) si vrai ettarifs!$A$4:$E> $12;13) si fauxmerci de
suivre,Freedo


RE-bonjour à Toutes et à Tous,
eh bien voilà avec les aides que vous m'avez donnés j'ai mis en ordre
cette formule qui a l'air de fonctionner :
=SI($B$400;(SI(A5<>"<";RECHERCHEV(G5;tarifs!$A$4:$O
$12;3);RECHERCHEV(G5;tarifs!$A$4:$O
$12;5)));SI(A5<>"<";RECHERCHEV(G5;tarifs!$A$4:$O
$12;12);RECHERCHEV(G5;tarifs!$A$4:$O$12;14)))
Bien sûr si vous avez une solutions plus radicale , je suis preneur.
Cordialement
Freedo


Michel Samoey
Le #5279951
Bonjour,
y aurait ça aussi
=RECHERCHEV(G5;tarifs!$A$4:$O$12;SI(A5="<";2;0)+SI(B400;3;12))

Cordialement
Michel
Publicité
Poster une réponse
Anonyme