Recherche dans une liste

Le
--- Laurent ---
Bonjour,

Je n'arrive pas à faire une formule qui me parait pourtant simple. J'ai une
colonne d'une centaine de ligne qui peut prendre plusieurs valeurs. Dans
l'onglet d'à côté, j'ai un tableau recap qui compte le nombre d'occurences
de certaines valeurs (index/equiv) que je suis particulièrement. Je n'arrive
pas à faire la formule qui donnerait le total des "autres" sauf à faire par
différence du total ce que je ne trouve pas très élégant. avz-vous une idée

--
Merci d'avance
Laurent
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
DanielCo
Le #25214912
Bonjour,
Je ne comprends pas la disposition de tes données et comment tu peux
compter des occurences avec index/equiv. Le mieux serait que tu charges
un classeur exemple - sans pièces joointes - sur cjoint.com et que tu
postes ici le lien généré.
Cordialement.
Daniel


Bonjour,

Je n'arrive pas à faire une formule qui me parait pourtant simple. J'ai une
colonne d'une centaine de ligne qui peut prendre plusieurs valeurs. Dans
l'onglet d'à côté, j'ai un tableau recap qui compte le nombre d'occurences de
certaines valeurs (index/equiv) que je suis particulièrement. Je n'arrive pas
à faire la formule qui donnerait le total des "autres" sauf à faire par
différence du total ce que je ne trouve pas très élégant. avz-vous une idée
--- Laurent ---
Le #25214902
Bonjour,

Je n'ai pas le classeur sous la main, c'est pour le boulot. J'en ai refait
un vite fait ici http://cjoint.com/?0BkoeInaokx

Je me suis trompé, c'est pas index/equiv, c'est sommeprod ;o))

--
Merci
Laurent






"DanielCo" kf84t3$e71$
Bonjour,
Je ne comprends pas la disposition de tes données et comment tu peux
compter des occurences avec index/equiv. Le mieux serait que tu charges un
classeur exemple - sans pièces joointes - sur cjoint.com et que tu postes
ici le lien généré.
Cordialement.
Daniel


Bonjour,

Je n'arrive pas à faire une formule qui me parait pourtant simple. J'ai
une colonne d'une centaine de ligne qui peut prendre plusieurs valeurs.
Dans l'onglet d'à côté, j'ai un tableau recap qui compte le nombre
d'occurences de certaines valeurs (index/equiv) que je suis
particulièrement. Je n'arrive pas à faire la formule qui donnerait le
total des "autres" sauf à faire par différence du total ce que je ne
trouve pas très élégant. avz-vous une idée




DanielCo
Le #25215042
Faire la différence n'est peut-être pas élégant (quoique...), mais
c'est surement le plus efficace.
Daniel


Bonjour,

Je n'ai pas le classeur sous la main, c'est pour le boulot. J'en ai refait un
vite fait ici http://cjoint.com/?0BkoeInaokx

Je me suis trompé, c'est pas index/equiv, c'est sommeprod ;o))

--
Merci
Laurent






"DanielCo" kf84t3$e71$
Bonjour,
Je ne comprends pas la disposition de tes données et comment tu peux
compter des occurences avec index/equiv. Le mieux serait que tu charges un
classeur exemple - sans pièces joointes - sur cjoint.com et que tu postes
ici le lien généré.
Cordialement.
Daniel


Bonjour,

Je n'arrive pas à faire une formule qui me parait pourtant simple. J'ai
une colonne d'une centaine de ligne qui peut prendre plusieurs valeurs.
Dans l'onglet d'à côté, j'ai un tableau recap qui compte le nombre
d'occurences de certaines valeurs (index/equiv) que je suis
particulièrement. Je n'arrive pas à faire la formule qui donnerait le
total des "autres" sauf à faire par différence du total ce que je ne
trouve pas très élégant. avz-vous une idée




tarzan
Le #25215312
Bonjour,

J'ai testé ceci , le résultat est conforme.
Mais la méthode pour y arriver n'est peut-être pas la meilleure.
Je suis preneur si quelqu'un trouve mieux

Sélectionner en G les données recherchées et définir.nom BASE

En C1 =si(recherchev(A1;base;1;faux)<>"#N/A";A1&B1;"")
Tirer la formule jusqu'en bas du tableau
Copier
Collage special valeurs

selectionner A definir nom BIF
selectionner C definir nom BOF


Ensuite, j'ai indiqué les formules sous : total, O et N

A B C D E F G H
I J
toto O totoO Total O
N
tata n tatan toto 10 8
2
tutu O tutuO tata 7 4
3
toto O totoO tutu 6 4
2
tata n tatan "=NB.SI(bif;G5)
"=NB.SI(bof;G5&$I$1) "=NB.SI(bof;G5&$J$1)
tutu O tutuO
toto n toton Autres
- -
toto O totoO "=NB.SI(bof;G6)
"=NB.SI(bof;G6&$I$1) "=NB.SI(bof;G6&$J$1)
tutu O tutuO
toto n toton
tata O tataO
lala n autres
toto O totoO
tata O tataO
tutu n tutun
lala O autres
tata O tataO
toto O totoO
lulu O autres
tata n tatan
lulu O autres
toto O totoO
lolo n autres
tutu O tutuO
toto O totoO
tata O tataO
tutu n tutun
toto O totoO

Bonne soirée à vous

Jack


"DanielCo" a écrit dans le message de groupe de discussion :
kf8cqj$4eh$

Faire la différence n'est peut-être pas élégant (quoique...), mais
c'est surement le plus efficace.
Daniel


Bonjour,

Je n'ai pas le classeur sous la main, c'est pour le boulot. J'en ai refait
un vite fait ici http://cjoint.com/?0BkoeInaokx

Je me suis trompé, c'est pas index/equiv, c'est sommeprod ;o))

--
Merci
Laurent






"DanielCo" kf84t3$e71$
Bonjour,
Je ne comprends pas la disposition de tes données et comment tu peux
compter des occurences avec index/equiv. Le mieux serait que tu charges
un classeur exemple - sans pièces joointes - sur cjoint.com et que tu
postes ici le lien généré.
Cordialement.
Daniel


Bonjour,

Je n'arrive pas à faire une formule qui me parait pourtant simple. J'ai
une colonne d'une centaine de ligne qui peut prendre plusieurs valeurs.
Dans l'onglet d'à côté, j'ai un tableau recap qui compte le nombre
d'occurences de certaines valeurs (index/equiv) que je suis
particulièrement. Je n'arrive pas à faire la formule qui donnerait le
total des "autres" sauf à faire par différence du total ce que je ne
trouve pas très élégant. avz-vous une idée




--- Laurent ---
Le #25215422
Bonjour,

Au départ, j'ai travaillé à base de recherche de "#N/A" par rapport aux
données "toto" tata" "tutu" du deuxième onglet et puis j'ai laissé tomber
mais je pense que c'est une (bonne) piste.

Merci à tous les deux

--
Laurent


"tarzan" 5117d5c6$0$1973$
Bonjour,

J'ai testé ceci , le résultat est conforme.
Mais la méthode pour y arriver n'est peut-être pas la meilleure.
Je suis preneur si quelqu'un trouve mieux

Sélectionner en G les données recherchées et définir.nom BASE

En C1 =si(recherchev(A1;base;1;faux)<>"#N/A";A1&B1;"")
Tirer la formule jusqu'en bas du tableau
Copier
Collage special valeurs

selectionner A definir nom BIF
selectionner C definir nom BOF


Ensuite, j'ai indiqué les formules sous : total, O et N

A B C D E F G H I
J
toto O totoO Total O N
tata n tatan toto 10 8 2
tutu O tutuO tata 7 4 3
toto O totoO tutu 6 4 2
tata n tatan "=NB.SI(bif;G5)
"=NB.SI(bof;G5&$I$1) "=NB.SI(bof;G5&$J$1)
tutu O tutuO
toto n toton Autres - -
toto O totoO "=NB.SI(bof;G6)
"=NB.SI(bof;G6&$I$1) "=NB.SI(bof;G6&$J$1)
tutu O tutuO
toto n toton
tata O tataO
lala n autres
toto O totoO
tata O tataO
tutu n tutun
lala O autres
tata O tataO
toto O totoO
lulu O autres
tata n tatan
lulu O autres
toto O totoO
lolo n autres
tutu O tutuO
toto O totoO
tata O tataO
tutu n tutun
toto O totoO

Bonne soirée à vous

Jack


"DanielCo" a écrit dans le message de groupe de discussion :
kf8cqj$4eh$

Faire la différence n'est peut-être pas élégant (quoique...), mais
c'est surement le plus efficace.
Daniel


Bonjour,

Je n'ai pas le classeur sous la main, c'est pour le boulot. J'en ai
refait un vite fait ici http://cjoint.com/?0BkoeInaokx

Je me suis trompé, c'est pas index/equiv, c'est sommeprod ;o))

--
Merci
Laurent






"DanielCo" kf84t3$e71$
Bonjour,
Je ne comprends pas la disposition de tes données et comment tu peux
compter des occurences avec index/equiv. Le mieux serait que tu charges
un classeur exemple - sans pièces joointes - sur cjoint.com et que tu
postes ici le lien généré.
Cordialement.
Daniel


Bonjour,

Je n'arrive pas à faire une formule qui me parait pourtant simple. J'ai
une colonne d'une centaine de ligne qui peut prendre plusieurs valeurs.
Dans l'onglet d'à côté, j'ai un tableau recap qui compte le nombre
d'occurences de certaines valeurs (index/equiv) que je suis
particulièrement. Je n'arrive pas à faire la formule qui donnerait le
total des "autres" sauf à faire par différence du total ce que je ne
trouve pas très élégant. avz-vous une idée









tarzan
Le #25216082
Bonjour,

Ce que j'ai écrit hier soir n'était guère lisible.
J'ai donc joint le fichier (lien ci-dessous)

http://cjoint.com/?0BleV1eZcip

Bonne journée

Jack


"--- Laurent ---" a écrit dans le message de groupe de discussion :
5117e479$0$16469$

Bonjour,

Au départ, j'ai travaillé à base de recherche de "#N/A" par rapport aux
données "toto" tata" "tutu" du deuxième onglet et puis j'ai laissé tomber
mais je pense que c'est une (bonne) piste.

Merci à tous les deux

--
Laurent


"tarzan" 5117d5c6$0$1973$
Bonjour,

J'ai testé ceci , le résultat est conforme.
Mais la méthode pour y arriver n'est peut-être pas la meilleure.
Je suis preneur si quelqu'un trouve mieux

Sélectionner en G les données recherchées et définir.nom BASE

En C1 =si(recherchev(A1;base;1;faux)<>"#N/A";A1&B1;"")
Tirer la formule jusqu'en bas du tableau
Copier
Collage special valeurs

selectionner A definir nom BIF
selectionner C definir nom BOF


Ensuite, j'ai indiqué les formules sous : total, O et N

A B C D E F G H I
J
toto O totoO Total O N
tata n tatan toto 10 8 2
tutu O tutuO tata 7 4 3
toto O totoO tutu 6 4 2
tata n tatan "=NB.SI(bif;G5)
"=NB.SI(bof;G5&$I$1) "=NB.SI(bof;G5&$J$1)
tutu O tutuO
toto n toton Autres - -
toto O totoO "=NB.SI(bof;G6)
"=NB.SI(bof;G6&$I$1) "=NB.SI(bof;G6&$J$1)
tutu O tutuO
toto n toton
tata O tataO
lala n autres
toto O totoO
tata O tataO
tutu n tutun
lala O autres
tata O tataO
toto O totoO
lulu O autres
tata n tatan
lulu O autres
toto O totoO
lolo n autres
tutu O tutuO
toto O totoO
tata O tataO
tutu n tutun
toto O totoO

Bonne soirée à vous

Jack


"DanielCo" a écrit dans le message de groupe de discussion :
kf8cqj$4eh$

Faire la différence n'est peut-être pas élégant (quoique...), mais
c'est surement le plus efficace.
Daniel


Bonjour,

Je n'ai pas le classeur sous la main, c'est pour le boulot. J'en ai
refait un vite fait ici http://cjoint.com/?0BkoeInaokx

Je me suis trompé, c'est pas index/equiv, c'est sommeprod ;o))

--
Merci
Laurent






"DanielCo" kf84t3$e71$
Bonjour,
Je ne comprends pas la disposition de tes données et comment tu peux
compter des occurences avec index/equiv. Le mieux serait que tu charges
un classeur exemple - sans pièces joointes - sur cjoint.com et que tu
postes ici le lien généré.
Cordialement.
Daniel


Bonjour,

Je n'arrive pas à faire une formule qui me parait pourtant simple. J'ai
une colonne d'une centaine de ligne qui peut prendre plusieurs valeurs.
Dans l'onglet d'à côté, j'ai un tableau recap qui compte le nombre
d'occurences de certaines valeurs (index/equiv) que je suis
particulièrement. Je n'arrive pas à faire la formule qui donnerait le
total des "autres" sauf à faire par différence du total ce que je ne
trouve pas très élégant. avz-vous une idée









isabelle
Le #25217812
bonjour,

B1:B28 nommé baf

en cellule I2
=SOMMEPROD(--(bif=G2)*(baf=I$1))

en cellule J2
=SOMMEPROD(--(bif=G2)*(baf=J$1))

tiré vers le bas les 2 formules

isabelle



Le 2013-02-10 13:18, --- Laurent --- a écrit :
Bonjour,

Au départ, j'ai travaillé à base de recherche de "#N/A" par rapport aux
données "toto" tata" "tutu" du deuxième onglet et puis j'ai laissé tomber
mais je pense que c'est une (bonne) piste.

Merci à tous les deux

Publicité
Poster une réponse
Anonyme