Recherche dans plusieurs table

Le
azur75
Sur excel, j'avais l'habitude de faire des recherches avec la fonction
RechercheV du style :
=SI(ESTERREUR(RECHERCHEV(E4;mix;1;FAUX));SI(ESTERREUR(RECHERCHEV(C4;pôles;3;FAUX));"non
affecté";RECHERCHEV(C4;pôles;3;FAUX));"Activités institutionnelles"). Comment
faire dans une requête Access pour faire la même chose. : En Résumé :
Si tu ne trouve pas dans Table1, alors cherche dans Table2, sinon dans
Table3, sinon écrit "xyz".
Merci beaucoup de votre aide.
Jacques
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Claude Bergès
Le #6227621
Bonsoir,
Je crois que justement, on choisi Access pour ne plus avoir des données dans
des tables dispersées.
Si la base est bien faite au départ, les recherches ne doivent se faire que
sur LA table qu"il faut.
cette table peut être faite en compilant tout les tableaux Excel.
Sinon, je pense qu'il faudra écrire du code VBA.
Jean-Claude

"azur75"
| Sur excel, j'avais l'habitude de faire des recherches avec la fonction
| RechercheV du style :
|
=SI(ESTERREUR(RECHERCHEV(E4;mix;1;FAUX));SI(ESTERREUR(RECHERCHEV(C4;pôles;3;
FAUX));"non
| affecté";RECHERCHEV(C4;pôles;3;FAUX));"Activités institutionnelles").
Comment
| faire dans une requête Access pour faire la même chose. : En Résumé :
| Si tu ne trouve pas dans Table1, alors cherche dans Table2, sinon dans
| Table3, sinon écrit "xyz".
| Merci beaucoup de votre aide.
| Jacques
|
Jean-Claude Bergès
Le #6227611
Bonsoir,
Je crois que justement, on choisi Access pour ne plus avoir des données dans
des tables dispersées.
Si la base est bien faite au départ, les recherches ne doivent se faire que
sur LA table qu"il faut.
cette table peut être faite en compilant tout les tableaux Excel.
Sinon, je pense qu'il faudra écrire du code VBA.
Jean-Claude

"azur75"
| Sur excel, j'avais l'habitude de faire des recherches avec la fonction
| RechercheV du style :
|
=SI(ESTERREUR(RECHERCHEV(E4;mix;1;FAUX));SI(ESTERREUR(RECHERCHEV(C4;pôles;3;
FAUX));"non
| affecté";RECHERCHEV(C4;pôles;3;FAUX));"Activités institutionnelles").
Comment
| faire dans une requête Access pour faire la même chose. : En Résumé :
| Si tu ne trouve pas dans Table1, alors cherche dans Table2, sinon dans
| Table3, sinon écrit "xyz".
| Merci beaucoup de votre aide.
| Jacques
|
Publicité
Poster une réponse
Anonyme