Recherche dans un tableau suivant deux critères ?

Le
ysalut
Comprend pas, normalement ça devrai fonctionné !

Dans mon tableau en colonne A j'ai des réf, en B des indices et en C des
titres. Comment connaître dans une liste, le titre d’un plan en faisant la
cherche sur la ref ET l’indice.

La fonction sommeprod, me renvoie « 0 » car, ce n’est pas un chiffre
=SOMMEPROD((ref=Recherche!A2)*(indice=Recherche!B2);titre)

La fonction BDLIRE, me renvoie une bonne réponse que sur la 1er ligne, pour
la 2éme ligne j’ai « # NOMBRE ! »
½LIRE(Données!$A$1:$C$21;"titre";(A1:B3))

La fonction index me renvoi #VALEUR !
=INDEX(titre;EQUIV(A2 & B2;ref & indice;0))

Qu’elle est la bonne formule et qu’est ce qui ne va pas ? Merci de votre
aide sur un truc simple !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ellimac
Le #4630541
Bonjour,

La fonction Index est à valider en matricielle avec Ctrl Shift Entrée.

Camille

"ysalut" wrote:

Comprend pas, normalement ça devrai fonctionné !

Dans mon tableau en colonne A j'ai des réf, en B des indices et en C des
titres. Comment connaître dans une liste, le titre d’un plan en faisant la
cherche sur la ref ET l’indice.

La fonction sommeprod, me renvoie « 0 » car, ce n’est pas un chiffre
=SOMMEPROD((ref=Recherche!A2)*(indice=Recherche!B2);titre)

La fonction BDLIRE, me renvoie une bonne réponse que sur la 1er ligne, pour
la 2éme ligne j’ai « # NOMBRE ! »
½LIRE(Données!$A$1:$C$21;"titre";(A1:B3))

La fonction index me renvoi #VALEUR !
=INDEX(titre;EQUIV(A2 & B2;ref & indice;0))

Qu’elle est la bonne formule et qu’est ce qui ne va pas ? Merci de votre
aide sur un truc simple !



ysalut
Le #4630491
Meric bcp !


Bonjour,

La fonction Index est à valider en matricielle avec Ctrl Shift Entrée.

Camille

"ysalut" wrote:

Comprend pas, normalement ça devrai fonctionné !

Dans mon tableau en colonne A j'ai des réf, en B des indices et en C des
titres. Comment connaître dans une liste, le titre d’un plan en faisant la
cherche sur la ref ET l’indice.

La fonction sommeprod, me renvoie « 0 » car, ce n’est pas un chiffre
=SOMMEPROD((ref=Recherche!A2)*(indice=Recherche!B2);titre)

La fonction BDLIRE, me renvoie une bonne réponse que sur la 1er ligne, pour
la 2éme ligne j’ai « # NOMBRE ! »
½LIRE(Données!$A$1:$C$21;"titre";(A1:B3))

La fonction index me renvoi #VALEUR !
=INDEX(titre;EQUIV(A2 & B2;ref & indice;0))

Qu’elle est la bonne formule et qu’est ce qui ne va pas ? Merci de votre
aide sur un truc simple !





ysalut
Le #4630451
Merci bcp


Bonjour,

La fonction Index est à valider en matricielle avec Ctrl Shift Entrée.

Camille

"ysalut" wrote:

Comprend pas, normalement ça devrai fonctionné !

Dans mon tableau en colonne A j'ai des réf, en B des indices et en C des
titres. Comment connaître dans une liste, le titre d’un plan en faisant la
cherche sur la ref ET l’indice.

La fonction sommeprod, me renvoie « 0 » car, ce n’est pas un chiffre
=SOMMEPROD((ref=Recherche!A2)*(indice=Recherche!B2);titre)

La fonction BDLIRE, me renvoie une bonne réponse que sur la 1er ligne, pour
la 2éme ligne j’ai « # NOMBRE ! »
½LIRE(Données!$A$1:$C$21;"titre";(A1:B3))

La fonction index me renvoi #VALEUR !
=INDEX(titre;EQUIV(A2 & B2;ref & indice;0))

Qu’elle est la bonne formule et qu’est ce qui ne va pas ? Merci de votre
aide sur un truc simple !





Publicité
Poster une réponse
Anonyme