Recherche doublon sur plusieurs colonnes

Le
Gaze
Bonjour
J'aimerais à partir d'une une mise en forme conditionnelle; que les doublons
soient de couleur

Simple lorsque sur une colonne
=NB.SI(A3:A9;A3)>1
si je veux que ma recherche se fasse à la fois sur les 3 colonnes
A3:A9 ET B3:B9 ET C3:C9
Merci
--
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichDenis
Le #5282431
Tu sélectionnes toute la plage de cellules concernées :

=NB.SI($A$3:$C$9;A3)>1



"Gaze"
Bonjour
J'aimerais à partir d'une une mise en forme conditionnelle; que les doublons
soient de couleur

Simple lorsque sur une colonne
=NB.SI(A3:A9;A3)>1
si je veux que ma recherche se fasse à la fois sur les 3 colonnes
A3:A9 ET B3:B9 ET C3:C9
Merci
--
Starwing
Le #5282421
Bonsoir... Ça gaze...Gaze? ;-)

Simple lorsque sur une colonne
=NB.SI(A3:A9;A3)>1
si je veux que ma recherche se fasse à la fois sur les 3 colonnes
A3:A9 ET B3:B9 ET C3:C9


=SOMMEPROD(--($A$3:$A$9&$B$3:$B$9&$C$3:$C$9=$A3&$B3&$C3))>1

Starwing

JB
Le #5282341
Bonjour,

=SOMMEPROD(($A$2:$A$11=$A2)*($B$2:$B$11=$B2))*($C$2:$C$11=$C2))>1

http://boisgontierjacques.free.fr/pages_site/mfc.htm#Doublons2crit

JB
http://boisgontierjacques.free.fr/

On 6 fév, 02:46, "Gaze"
Bonjour
J'aimerais à partir d'une une mise en forme conditionnelle; que les doub lons
soient de couleur

Simple  lorsque sur une colonne
=NB.SI(A3:A9;A3)>1
si je veux que ma recherche se fasse à la fois sur les 3 colonnes
A3:A9 ET B3:B9 ET C3:C9
Merci
--


Gaze
Le #5281741
Pour commercer, merci pour le temps que vous m'offrez..
J'ai l'impression que je me suis mal exprimé ou que je n'ai pas compris vos
explications.
J'aurais du vous dire que mes 3 colonnes ne sont pas contiguës et ainsi:

Soit les colonnes :
A D E
qui contiennent des valeurs; je veux m'assurer qu'aucune valeur ne se répète
dans mes 3 colonnes

Si j'ai "coco" en A6 et en E7 je dois le savoir
ou "toto" en B4 et B1 ou "Bimbo" en B3 ET E6

=NB.SI($A$3:$C$9;A3)>1 fonctionne sur des colonnes contiguës; mais ce n'est
pas mon cas
Merci encore une fois
--

"Gaze" news:
Bonjour
J'aimerais à partir d'une une mise en forme conditionnelle; que les
doublons

soient de couleur

Simple lorsque sur une colonne
=NB.SI(A3:A9;A3)>1
si je veux que ma recherche se fasse à la fois sur les 3 colonnes
A3:A9 ET B3:B9 ET C3:C9
Merci
--




JB
Le #5281521
Function NbSiMZ(champrech As Range, valCherchée)
Application.Volatile
temp = 0
For i = 1 To champrech.Areas.Count
For j = 1 To champrech.Areas(i).Count
If valCherchée = champrech.Areas(i)(j) Then
temp = temp + 1
End If
Next j
Next i
NbSiMZ = temp
End Function

http://boisgontierjacques.free.fr/fichiers/fonctionsperso/FonctionNbSiMZ.xls

JB

On 6 fév, 15:20, "Gaze"
Pour commercer, merci pour le temps que vous m'offrez..
J'ai l'impression que je me suis mal exprimé ou que je n'ai pas compris vos
explications.
J'aurais du vous dire que mes 3 colonnes ne sont pas contiguës et ainsi:

Soit les colonnes :
A    D    E
qui contiennent des valeurs; je veux m'assurer qu'aucune valeur ne se ré pète
dans mes 3 colonnes

Si j'ai "coco" en A6 et en E7 je dois le savoir
ou "toto" en B4 et B1 ou  "Bimbo" en B3 ET E6

=NB.SI($A$3:$C$9;A3)>1 fonctionne sur des colonnes contiguës; mais ce n'est
pas mon cas
 Merci encore une fois
--

"Gaze"


Bonjour
J'aimerais à partir d'une une mise en forme conditionnelle; que les
doublons

soient de couleur

Simple  lorsque sur une colonne
=NB.SI(A3:A9;A3)>1
si je veux que ma recherche se fasse à la fois sur les 3 colonnes
A3:A9 ET B3:B9 ET C3:C9
Merci
--- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Gaze
Le #5281431
Wow ! Wow !

Un gros merci!!!
Quelle belle découverte !!
Je viens, grace à toi, de finir des heures de tentatives et de recherches
sans résultat

Merci encore

"JB" news:


Function NbSiMZ(champrech As Range, valCherchée)
Application.Volatile
temp = 0
For i = 1 To champrech.Areas.Count
For j = 1 To champrech.Areas(i).Count
If valCherchée = champrech.Areas(i)(j) Then
temp = temp + 1
End If
Next j
Next i
NbSiMZ = temp
End Function

http://boisgontierjacques.free.fr/fichiers/fonctionsperso/FonctionNbSiMZ.xls

JB

On 6 fév, 15:20, "Gaze"
Pour commercer, merci pour le temps que vous m'offrez..
J'ai l'impression que je me suis mal exprimé ou que je n'ai pas compris
vos

explications.
J'aurais du vous dire que mes 3 colonnes ne sont pas contiguës et ainsi:

Soit les colonnes :
A D E
qui contiennent des valeurs; je veux m'assurer qu'aucune valeur ne se
répète

dans mes 3 colonnes

Si j'ai "coco" en A6 et en E7 je dois le savoir
ou "toto" en B4 et B1 ou "Bimbo" en B3 ET E6

=NB.SI($A$3:$C$9;A3)>1 fonctionne sur des colonnes contiguës; mais ce
n'est

pas mon cas
Merci encore une fois
--

"Gaze" denews:




Bonjour
J'aimerais à partir d'une une mise en forme conditionnelle; que les
doublons

soient de couleur

Simple lorsque sur une colonne
=NB.SI(A3:A9;A3)>1
si je veux que ma recherche se fasse à la fois sur les 3 colonnes
A3:A9 ET B3:B9 ET C3:C9
Merci
--- Masquer le texte des messages précédents -


- Afficher le texte des messages précédents -



Publicité
Poster une réponse
Anonyme