Recherche enregistrements : quelle méthode préférer ?

Le
joey
Bonjour tous,

lors du parcours dune table HF, il y a plusieurs faons de rechercher
un enregistrement. Je sais que laide est assez dtaille mais n
arrive pas percevoir la diffrence entre les fonctions
HLitRecherche et HRecherche par exemple. Cest pourquoi si vous
pouviez valider ou amliorer les dclarations suivantes, je serais
fix une fois pour toutes :

*** Si je recherche un seul enregistrement dans une table :

HLitRecherchePremier(CLIENT, NOM, "DUPOND")

ou

HLitRecherche(CLIENT, NOM, "DUPOND")

*** Si je parcours une table la recherche de plusieurs
enregistrements rpondant une mme condition :

HLitPremier(Nomenclature, sRubClParcours)

TANTQUE PAS HEnDehors()
HLitSuivant(Nomenclature, sRubClParcours)
FIN

ou

HLitRecherche(Nomenclature, Nom, sRubClParcours)

TANTQUE HTrouve(Nomenclature)
HLitSuivant(Nomenclature, sRubClParcours)
FIN


Est-ce donc les 2 moyens pour chaque cas de recherche les plus
gnriques ?

Une des 2 options pour chaque cas est-elle prfrable ? et si oui,
pourquoi ?

Dautres ides ?

Merci davance tous.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
OPP
Le #20463521
On 28 oct, 17:57, joey
Bonjour à tous,

lors du parcours d´une table HF, il y a plusieurs façons de recherche r
un enregistrement. Je sais que l´aide est assez détaillée mais n
´arrive pas à percevoir la différence entre les fonctions
HLitRecherche et HRecherche par exemple. C´est pourquoi si vous
pouviez valider ou améliorer les déclarations suivantes, je serais
fixé une fois pour toutes :

*** Si je recherche un seul enregistrement dans une table :

     HLitRecherchePremier(CLIENT, NOM, "DUPOND")

     ou

     HLitRecherche(CLIENT, NOM, "DUPOND")

*** Si je parcours une table à la recherche de plusieurs
enregistrements répondant à une même condition :

     HLitPremier(Nomenclature, sRubCléParcours)

     TANTQUE PAS HEnDehors()
         HLitSuivant(Nomenclature, sRubCléParcours)
     FIN

     ou

     HLitRecherche(Nomenclature, Nom, sRubCléParcours)

     TANTQUE HTrouve(Nomenclature)
         HLitSuivant(Nomenclature, sRubCléParcours)
     FIN

Est-ce donc les 2 moyens pour chaque cas de recherche les plus
génériques ?

Une des 2 options pour chaque cas est-elle préférable ? et si oui,
pourquoi ?

D´autres idées ?

Merci d´avance à tous.



Pour parcourir selon une clé il vaut mieux utiliser POUR TOUT qui a le
mérite de prendre que les enreigstrements de la clé. Sinon avec
HlitrecherchePremier il faut tester chaque enregistrement pour savor
s'il fait partie de notre condition après Hlitsuivant. En plus on
parcours trop d'enregistreemnt pour rien.
Publicité
Poster une réponse
Anonyme