Recherche matriciel....pas simple

Le
Xavier powaga
bonjour à tous,
mon pb est somme toutes assez simple à énoncer mais je bute sur la solution.

Voilà j'ai un tableau où sur la première ligne on trouve les liens de
parenté
sur la 1ere colonne des dates

Tonton Tata Papa Maman
01/05/07 X
05/08/07 X X X
08/09/07 X X

Je souhaite dans un autre feuille que si je note Tonton en A1 il me donne 2
en A2 c'est à dire le nombre de Croix qu'il y a dans la colonne
Le pb c'est que dans le tableau Tonton n'est pas forcément au même endroit
et mon tableau peut ressembler à ça
Tata Papa Tonton Maman
01/05/07 X
05/08/07 X X X
08/09/07 X X

Je comptais utilisait la fonction SommeProduit et trouver la colonne de
recherche ainsi:
=SommeProduit(ADRESSE(2;EQUIV("Tonton";Collecte!$B$1:$E$1;0);;;"Feuil1")&":"&ADRESSE(100;EQUIV("Tonton";Collecte!$B$1:$E$1;0);;;)="X")
mais je n'obtiens pas une matrice

Avez vous une idée ?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #5237591
Bonjour,

H1 contient le nom cherché

=NB.SI(INDEX(Croix;;EQUIV(H1;Noms;0));"x")
Valider avec mj+ctrl+entrée

http://cjoint.com/?cCkAePfJWC

JB
http://boisgontierjacques.free.fr

On 28 fév, 10:16, "Xavier powaga"
bonjour à tous,
mon pb est somme toutes assez simple à énoncer mais je bute sur la sol ution.

Voilà j'ai un tableau où sur la première ligne on trouve les liens d e
parenté
sur la 1ere colonne des dates

                    Tonton    Tata    Papa    Maman
01/05/07                    X
05/08/07        X                        X        X
08/09/07        X                        X

Je souhaite dans un autre feuille que si je note Tonton en A1 il me donne 2
en A2 c'est à dire le nombre de Croix qu'il y a dans la colonne
Le pb c'est que dans le tableau Tonton n'est pas forcément au même end roit
et mon tableau peut ressembler à ça
                    Tata    Papa    Tonton    Maman
01/05/07        X
05/08/07                   X           X        X
08/09/07                   X           X

Je comptais utilisait la fonction SommeProduit et trouver la colonne de
recherche ainsi:
=SommeProduit(ADRESSE(2;EQUIV("Tonton";Collecte!$B$1:$E$1;0);;;"Feuil1") &":­"&ADRESSE(100;EQUIV("Tonton";Collecte!$B$1:$E$1;0);;;)="X")
mais je n'obtiens pas une matrice

Avez vous une idée ?


Xavier powaga
Le #5237521
Rapide et efficace
Merci
"JB"
Bonjour,

H1 contient le nom cherché

=NB.SI(INDEX(Croix;;EQUIV(H1;Noms;0));"x")
Valider avec mj+ctrl+entrée

http://cjoint.com/?cCkAePfJWC

JB
http://boisgontierjacques.free.fr

On 28 fév, 10:16, "Xavier powaga"
bonjour à tous,
mon pb est somme toutes assez simple à énoncer mais je bute sur la
solution.

Voilà j'ai un tableau où sur la première ligne on trouve les liens de
parenté
sur la 1ere colonne des dates

Tonton Tata Papa Maman
01/05/07 X
05/08/07 X X X
08/09/07 X X

Je souhaite dans un autre feuille que si je note Tonton en A1 il me donne
2
en A2 c'est à dire le nombre de Croix qu'il y a dans la colonne
Le pb c'est que dans le tableau Tonton n'est pas forcément au même endroit
et mon tableau peut ressembler à ça
Tata Papa Tonton Maman
01/05/07 X
05/08/07 X X X
08/09/07 X X

Je comptais utilisait la fonction SommeProduit et trouver la colonne de
recherche ainsi:
=SommeProduit(ADRESSE(2;EQUIV("Tonton";Collecte!$B$1:$E$1;0);;;"Feuil1")&":­"&ADRESSE(100;EQUIV("Tonton";Collecte!$B$1:$E$1;0);;;)="X")
mais je n'obtiens pas une matrice

Avez vous une idée ?


Publicité
Poster une réponse
Anonyme