Recherche de mots et additions de montants

Le
Vincent CHRISTOL
Bonjour à tous,

J'ai un tableau de deux colonnes, en colonne 1 du texte, en colonne 2 des
montants
Je voudrais rechercher un mot clé répété dans la colonne de texte, puis
faire l'addition des montants en fonction du mot recherché.

Je cherche le mot beau dans l'exemple suivant

Il fait beau aujourd'hui 5000
Demain sera un beau jour 1200
Sophie a un beau chapeau 500
Marc n'en a pas 4000

Et voudrais obtenir le résultat de l'addition (5000+1200+500) 6700 dans une
cellule de mon classeur.

Sûr qu'il existe une solution, je vous remercie d'avance pour votre aide.
Cordialement
Vincent
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #21407901
Bonjour.
Avec tes donées en A1:A4 :
=SOMMEPROD((NBCAR(A1:A4)<>NBCAR(SUBSTITUE(A1:A4;"beau";"")))*B1:B4)
Le mot "beau" est supposé connu. Sinon, c'est beaucoup plus compliqué.
Daniel

Bonjour à tous,

J'ai un tableau de deux colonnes, en colonne 1 du texte, en colonne 2 des
montants
Je voudrais rechercher un mot clé répété dans la colonne de texte, puis
faire l'addition des montants en fonction du mot recherché.

Je cherche le mot beau dans l'exemple suivant

Il fait beau aujourd'hui 5000
Demain sera un beau jour 1200
Sophie a un beau chapeau 500
Marc n'en a pas 4000

Et voudrais obtenir le résultat de l'addition (5000+1200+500) 6700 dans une
cellule de mon classeur.

Sûr qu'il existe une solution, je vous remercie d'avance pour votre aide.
Cordialement
Vincent
Caetera
Le #21407881
"Vincent CHRISTOL" C7CA5DEE.33CC2%
J'ai un tableau de deux colonnes, en colonne 1 du texte, en colonne 2 des
montants
Je voudrais rechercher un mot clé répété dans la colonne de texte, puis
faire l'addition des montants en fonction du mot recherché.

Je cherche le mot beau dans l'exemple suivant

Il fait beau aujourd'hui 5000
Demain sera un beau jour 1200
Sophie a un beau chapeau 500
Marc n'en a pas 4000
Et voudrais obtenir le résultat de l'addition (5000+1200+500) 6700 dans une
cellule de mon classeur.



*************

=SOMMEPROD((ESTNUM(TROUVE("beau";A1:A4)))*B1:B4)

Etc
JB
Le #21408021
Bonjour,

=SOMMEPROD((ESTNUM(TROUVE("beau";phrase))*nb))

JB
http://boisgontierjacques.free.fr

On 20 mar, 11:11, Vincent CHRISTOL
Bonjour à tous,

J'ai un tableau de deux colonnes, en colonne 1 du texte, en colonne 2 des
montants
Je voudrais rechercher un mot clé répété dans la colonne de texte , puis
faire l'addition des montants en fonction du mot recherché.

Je cherche le mot beau dans l'exemple suivant

Il fait beau aujourd'hui         5000
Demain sera un beau jour     1200
Sophie a un beau chapeau    500
Marc n'en a pas                   4000

Et voudrais obtenir le résultat de l'addition (5000+1200+500) 6700 dans une
cellule de mon classeur.

Sûr qu'il existe une solution, je vous remercie d'avance pour votre aid e.
Cordialement
Vincent
JB
Le #21410361
http://cjoint.com/?dusdegiM81

JB


On 20 mar, 11:52, JB
Bonjour,

=SOMMEPROD((ESTNUM(TROUVE("beau";phrase))*nb))

JBhttp://boisgontierjacques.free.fr

On 20 mar, 11:11, Vincent CHRISTOL


> Bonjour à tous,

> J'ai un tableau de deux colonnes, en colonne 1 du texte, en colonne 2 d es
> montants
> Je voudrais rechercher un mot clé répété dans la colonne de tex te, puis
> faire l'addition des montants en fonction du mot recherché.

> Je cherche le mot beau dans l'exemple suivant

> Il fait beau aujourd'hui         5000
> Demain sera un beau jour     1200
> Sophie a un beau chapeau    500
> Marc n'en a pas                   4000

> Et voudrais obtenir le résultat de l'addition (5000+1200+500) 6700 da ns une
> cellule de mon classeur.

> Sûr qu'il existe une solution, je vous remercie d'avance pour votre a ide.
> Cordialement
> Vincent- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -
Publicité
Poster une réponse
Anonyme