Recherche de la présence d'un caractére

Le
Michel B
Bonjour a toutes et a tous

je souhaite indiquer dans les celleules de la colonne "D", 1 si le chiffre 7
est présent et rien si il n'y est pas.
J'ai ecris en colonne "B" :
=CHERCHE(7;A2;1)
cela me trouve bien la présence du chiffre en question et la position, du
premier trouvé.
Mais en absence du 7 recherché la réponse est "#VALEUR!" ce qui est normal.
J'ai donc essayé de faire un "SI" dans la colonne "D"
SI (B2>0;1;"")
Mais la réponse est toujours "#VALEUR!"

Une piste peut être ?

D'avance merci
Michel
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #10854371
Bonjour,

Une piste peut être ?



=SI(ESTERREUR(CHERCHE(7;A2;1));"";1)
ou
NON(ESTERREUR(CHERCHE(7;A2;1)))*1

--
Salutations
JJ


"Michel B" 48679504$0$5023$
Bonjour a toutes et a tous

je souhaite indiquer dans les celleules de la colonne "D", 1 si le chiffre
7 est présent et rien si il n'y est pas.
J'ai ecris en colonne "B" :
=CHERCHE(7;A2;1)
cela me trouve bien la présence du chiffre en question et la position, du
premier trouvé.
Mais en absence du 7 recherché la réponse est "#VALEUR!" ce qui est
normal.
J'ai donc essayé de faire un "SI" dans la colonne "D"
SI (B2>0;1;"")
Mais la réponse est toujours "#VALEUR!"

Une piste peut être ?

D'avance merci
Michel



JB
Le #10854361
Bonjour,

=SI(ESTNUM(CHERCHE(7;A2));CHERCHE(7;A2);"inconnu")

JB
http://boisgontierjacques.free.fr/

On 29 juin, 15:53, "Michel B"
Bonjour a toutes et a tous

je souhaite indiquer dans les celleules de la colonne "D", 1 si le chiffr e 7
est présent et rien si il n'y est pas.
J'ai ecris en colonne "B" :
=CHERCHE(7;A2;1)
cela me trouve bien la présence du chiffre en question et la position, du
premier trouvé.
Mais en absence du 7 recherché la réponse est "#VALEUR!" ce qui est n ormal.
J'ai donc essayé de faire un "SI" dans la colonne "D"
SI (B2>0;1;"")
Mais la réponse est toujours "#VALEUR!"

Une piste peut être ?

D'avance merci
Michel


Michel B
Le #10854461
Un grand merci a tous deux,

=SI(ESTERREUR(CHERCHE(7;A2;1));"";1)

est la bonne, résultat en tous points à ce que je souhaitais.

Encore merci et bon dimanche

Michel



"Michel B" 48679504$0$5023$
Bonjour a toutes et a tous

je souhaite indiquer dans les celleules de la colonne "D", 1 si le chiffre
7 est présent et rien si il n'y est pas.
J'ai ecris en colonne "B" :
=CHERCHE(7;A2;1)
cela me trouve bien la présence du chiffre en question et la position, du
premier trouvé.
Mais en absence du 7 recherché la réponse est "#VALEUR!" ce qui est
normal.
J'ai donc essayé de faire un "SI" dans la colonne "D"
SI (B2>0;1;"")
Mais la réponse est toujours "#VALEUR!"

Une piste peut être ?

D'avance merci
Michel



Publicité
Poster une réponse
Anonyme