Recherche selon 3 critères

Le
Fred
Bonjour,

Je suis un peu embêté car je n'arrive pas à faire une recherche qui
porterait sur 3 critères :

Sur une feuille X , un tableau avec:
Colone A : Nom de ville
Colone B : Mois
Colone C : Tarif

Sur une feuille Y :
Colone A : Nom de ville
Colone B : Mois en cours
Colone C : Tarif

Je souhaiterais que sur la feuille Y, en automatique, selon le nom de la
ville, apparaisse le tarif du mois en cours (car sur la feuille X je garde
tous les mois en archive)

J'espère que cela est clair et pas trop embrouillé !!!

Merci.

FRED.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
ChristianM
Le #17893511
Bonjour,
Je suppose que tu n'as dans la feuille X qu'un seule ligne par couple
Ville/mois.
Si tu nommes tes plages :
colonne A = ville
colonne B = mois
colonne C = tarif

sur la feuille Y en colonne C :
=SOMMEPROD((ville¢)*(mois²)*tarif)

Est-ce cela ?

--
ChristianM


"Fred" %
Bonjour,

Je suis un peu embêté car je n'arrive pas à faire une recherche qui
porterait sur 3 critères :

Sur une feuille X , un tableau avec:
Colone A : Nom de ville
Colone B : Mois
Colone C : Tarif

Sur une feuille Y :
Colone A : Nom de ville
Colone B : Mois en cours
Colone C : Tarif

Je souhaiterais que sur la feuille Y, en automatique, selon le nom de la
ville, apparaisse le tarif du mois en cours (car sur la feuille X je garde
tous les mois en archive)...

J'espère que cela est clair et pas trop embrouillé !!!

Merci.

FRED.





Fred
Le #17893821
Bonjour,

Euh, vraiment désolé, mais sur ma deuxième feuille (Y), je n'ai que :
A Nom de ville
C Tarif
Je cherche à afficher le tarif sur la feuille Y en fonction du mois en cours
(la colonne B de la feuille X comprendra des lignes Octobre, Novembre ...).

Merci d'avance,

FRED.




"ChristianM" a écrit dans le message de
news:
Bonjour,
Je suppose que tu n'as dans la feuille X qu'un seule ligne par couple
Ville/mois.
Si tu nommes tes plages :
colonne A = ville
colonne B = mois
colonne C = tarif

sur la feuille Y en colonne C :
=SOMMEPROD((ville¢)*(mois²)*tarif)

Est-ce cela ?

--
ChristianM


"Fred" %
Bonjour,

Je suis un peu embêté car je n'arrive pas à faire une recherche qui
porterait sur 3 critères :

Sur une feuille X , un tableau avec:
Colone A : Nom de ville
Colone B : Mois
Colone C : Tarif

Sur une feuille Y :
Colone A : Nom de ville
Colone B : Mois en cours
Colone C : Tarif

Je souhaiterais que sur la feuille Y, en automatique, selon le nom de la
ville, apparaisse le tarif du mois en cours (car sur la feuille X je
garde tous les mois en archive)...

J'espère que cela est clair et pas trop embrouillé !!!

Merci.

FRED.









ChristianM
Le #17893811
Cependant sur ton post initial tu mets que tu as en colonne B de ta feuille
Y le mois en cours !
Si ton mois sur la feuille X peut être de format numérique ( 1 à 12 ) tu
peux mettre en B sur la feuille Y =MOIS(AUJOURDHUI())


--
ChristianM


"Fred" %
Bonjour,

Euh, vraiment désolé, mais sur ma deuxième feuille (Y), je n'ai que :
A Nom de ville
C Tarif
Je cherche à afficher le tarif sur la feuille Y en fonction du mois en
cours (la colonne B de la feuille X comprendra des lignes Octobre,
Novembre ...).

Merci d'avance,

FRED.




"ChristianM" a écrit dans le message de
news:
Bonjour,
Je suppose que tu n'as dans la feuille X qu'un seule ligne par couple
Ville/mois.
Si tu nommes tes plages :
colonne A = ville
colonne B = mois
colonne C = tarif

sur la feuille Y en colonne C :
=SOMMEPROD((ville¢)*(mois²)*tarif)

Est-ce cela ?

--
ChristianM


"Fred" %
Bonjour,

Je suis un peu embêté car je n'arrive pas à faire une recherche qui
porterait sur 3 critères :

Sur une feuille X , un tableau avec:
Colone A : Nom de ville
Colone B : Mois
Colone C : Tarif

Sur une feuille Y :
Colone A : Nom de ville
Colone B : Mois en cours
Colone C : Tarif

Je souhaiterais que sur la feuille Y, en automatique, selon le nom de la
ville, apparaisse le tarif du mois en cours (car sur la feuille X je
garde tous les mois en archive)...

J'espère que cela est clair et pas trop embrouillé !!!

Merci.

FRED.












ChristianM
Le #17893801
tu peux mettre en B =AUJOURDHUI() puis pour la colonne B aller dans Format
Cellule Nombre Personnalisé et dans Type mettre mmmm (4 fois la lettre m)

--
ChristianM


"ChristianM" a écrit dans le message de news:

Cependant sur ton post initial tu mets que tu as en colonne B de ta
feuille Y le mois en cours !
Si ton mois sur la feuille X peut être de format numérique ( 1 à 12 ) tu
peux mettre en B sur la feuille Y =MOIS(AUJOURDHUI())


--
ChristianM


"Fred" %
Bonjour,

Euh, vraiment désolé, mais sur ma deuxième feuille (Y), je n'ai que :
A Nom de ville
C Tarif
Je cherche à afficher le tarif sur la feuille Y en fonction du mois en
cours (la colonne B de la feuille X comprendra des lignes Octobre,
Novembre ...).

Merci d'avance,

FRED.




"ChristianM" a écrit dans le message de
news:
Bonjour,
Je suppose que tu n'as dans la feuille X qu'un seule ligne par couple
Ville/mois.
Si tu nommes tes plages :
colonne A = ville
colonne B = mois
colonne C = tarif

sur la feuille Y en colonne C :
=SOMMEPROD((ville¢)*(mois²)*tarif)

Est-ce cela ?

--
ChristianM


"Fred" %
Bonjour,

Je suis un peu embêté car je n'arrive pas à faire une recherche qui
porterait sur 3 critères :

Sur une feuille X , un tableau avec:
Colone A : Nom de ville
Colone B : Mois
Colone C : Tarif

Sur une feuille Y :
Colone A : Nom de ville
Colone B : Mois en cours
Colone C : Tarif

Je souhaiterais que sur la feuille Y, en automatique, selon le nom de
la ville, apparaisse le tarif du mois en cours (car sur la feuille X je
garde tous les mois en archive)...

J'espère que cela est clair et pas trop embrouillé !!!

Merci.

FRED.
















Fred
Le #17893951
Désolé,

j'espère que ce sera plus clair comme ça.
Sur la feuille Y , j'ai les villes, je souhaites afficher le montant en
fonction du mois en cours de la feuille X :


Feuille X :

Toulouse octobre 100?
Paris octobre 200?
Toulouse novembre 150 ?
Paris novembre 160 ?

Feuille Y :

Toulouse 150?
Paris 160 ?



"ChristianM" a écrit dans le message de
news:
Cependant sur ton post initial tu mets que tu as en colonne B de ta
feuille Y le mois en cours !
Si ton mois sur la feuille X peut être de format numérique ( 1 à 12 ) tu
peux mettre en B sur la feuille Y =MOIS(AUJOURDHUI())


--
ChristianM


"Fred" %
Bonjour,

Euh, vraiment désolé, mais sur ma deuxième feuille (Y), je n'ai que :
A Nom de ville
C Tarif
Je cherche à afficher le tarif sur la feuille Y en fonction du mois en
cours (la colonne B de la feuille X comprendra des lignes Octobre,
Novembre ...).

Merci d'avance,

FRED.




"ChristianM" a écrit dans le message de
news:
Bonjour,
Je suppose que tu n'as dans la feuille X qu'un seule ligne par couple
Ville/mois.
Si tu nommes tes plages :
colonne A = ville
colonne B = mois
colonne C = tarif

sur la feuille Y en colonne C :
=SOMMEPROD((ville¢)*(mois²)*tarif)

Est-ce cela ?

--
ChristianM


"Fred" %
Bonjour,

Je suis un peu embêté car je n'arrive pas à faire une recherche qui
porterait sur 3 critères :

Sur une feuille X , un tableau avec:
Colone A : Nom de ville
Colone B : Mois
Colone C : Tarif

Sur une feuille Y :
Colone A : Nom de ville
Colone B : Mois en cours
Colone C : Tarif

Je souhaiterais que sur la feuille Y, en automatique, selon le nom de
la ville, apparaisse le tarif du mois en cours (car sur la feuille X je
garde tous les mois en archive)...

J'espère que cela est clair et pas trop embrouillé !!!

Merci.

FRED.
















isabelle
Le #17894131
bonjour Fred,

=SOMMEPROD((Feuilx!$A$2:$A$100¢)*(Feuilx!$B$2:$B$100=TEXTE(MOIS(AUJOURDHUI());"mmm")*(Feuilx!$C$2:$C$100))

isabelle



Fred a écrit :
Désolé,

j'espère que ce sera plus clair comme ça.
Sur la feuille Y , j'ai les villes, je souhaites afficher le montant
en fonction du mois en cours de la feuille X :


Feuille X :

Toulouse octobre 100?
Paris octobre 200?
Toulouse novembre 150 ?
Paris novembre 160 ?

Feuille Y :

Toulouse 150?
Paris 160 ?



"ChristianM" a écrit dans le message de
news:
Cependant sur ton post initial tu mets que tu as en colonne B de ta
feuille Y le mois en cours !
Si ton mois sur la feuille X peut être de format numérique ( 1 à 12 )
tu peux mettre en B sur la feuille Y =MOIS(AUJOURDHUI())


--
ChristianM


"Fred" %
Bonjour,

Euh, vraiment désolé, mais sur ma deuxième feuille (Y), je n'ai que :
A Nom de ville
C Tarif
Je cherche à afficher le tarif sur la feuille Y en fonction du mois
en cours (la colonne B de la feuille X comprendra des lignes
Octobre, Novembre ...).

Merci d'avance,

FRED.




"ChristianM" a écrit dans le message de
news:
Bonjour,
Je suppose que tu n'as dans la feuille X qu'un seule ligne par
couple Ville/mois.
Si tu nommes tes plages :
colonne A = ville
colonne B = mois
colonne C = tarif

sur la feuille Y en colonne C :
=SOMMEPROD((ville¢)*(mois²)*tarif)

Est-ce cela ?

--
ChristianM


"Fred" %
Bonjour,

Je suis un peu embêté car je n'arrive pas à faire une recherche
qui porterait sur 3 critères :

Sur une feuille X , un tableau avec:
Colone A : Nom de ville
Colone B : Mois
Colone C : Tarif

Sur une feuille Y :
Colone A : Nom de ville
Colone B : Mois en cours
Colone C : Tarif

Je souhaiterais que sur la feuille Y, en automatique, selon le nom
de la ville, apparaisse le tarif du mois en cours (car sur la
feuille X je garde tous les mois en archive)...

J'espère que cela est clair et pas trop embrouillé !!!

Merci.

FRED.



















Corto
Le #17894291
Bonjour Fred et ChristianM,
La solution de Christian ne fonctionne que si les tarifs sont des
chiffres mais je pense qu'il s'agit de chaines de caratères contenant o u
non des chiffres.
colonne A = Villes
colonne B = Mois
colonne C = Tarifs

{=INDEX(Tarifs;EQUIV($B2;SI(Villes=$A2;Mois;"");0))}
Attention il ne faut pas taper les accolades mais valider par
Ctrl+Maj+Entrée

Corto


ChristianM a écrit :
Bonjour,
Je suppose que tu n'as dans la feuille X qu'un seule ligne par couple
Ville/mois.
Si tu nommes tes plages :
colonne A = ville
colonne B = mois
colonne C = tarif

sur la feuille Y en colonne C :
=SOMMEPROD((ville¢)*(mois²)*tarif)

Est-ce cela ?




Fred
Le #17894471
Bonjour,

Heu, bon désolé, mais je positionne la formule sur feuily en B1; mais
j'obtiens une erreur...
Arrrg, je pense que je nage !

FRED.

"isabelle" a écrit dans le message de
news:
bonjour Fred,

=SOMMEPROD((Feuilx!$A$2:$A$100¢)*(Feuilx!$B$2:$B$100=TEXTE(MOIS(AUJOURDHUI());"mmm")*(Feuilx!$C$2:$C$100))

isabelle



Fred a écrit :
Désolé,

j'espère que ce sera plus clair comme ça.
Sur la feuille Y , j'ai les villes, je souhaites afficher le montant en
fonction du mois en cours de la feuille X :


Feuille X :

Toulouse octobre 100?
Paris octobre 200?
Toulouse novembre 150 ?
Paris novembre 160 ?

Feuille Y :

Toulouse 150?
Paris 160 ?



"ChristianM" a écrit dans le message de
news:
Cependant sur ton post initial tu mets que tu as en colonne B de ta
feuille Y le mois en cours !
Si ton mois sur la feuille X peut être de format numérique ( 1 à 12 ) tu
peux mettre en B sur la feuille Y =MOIS(AUJOURDHUI())


--
ChristianM


"Fred" %
Bonjour,

Euh, vraiment désolé, mais sur ma deuxième feuille (Y), je n'ai que :
A Nom de ville
C Tarif
Je cherche à afficher le tarif sur la feuille Y en fonction du mois en
cours (la colonne B de la feuille X comprendra des lignes Octobre,
Novembre ...).

Merci d'avance,

FRED.




"ChristianM" a écrit dans le message de
news:
Bonjour,
Je suppose que tu n'as dans la feuille X qu'un seule ligne par couple
Ville/mois.
Si tu nommes tes plages :
colonne A = ville
colonne B = mois
colonne C = tarif

sur la feuille Y en colonne C :
=SOMMEPROD((ville¢)*(mois²)*tarif)

Est-ce cela ?

--
ChristianM


"Fred" %
Bonjour,

Je suis un peu embêté car je n'arrive pas à faire une recherche qui
porterait sur 3 critères :

Sur une feuille X , un tableau avec:
Colone A : Nom de ville
Colone B : Mois
Colone C : Tarif

Sur une feuille Y :
Colone A : Nom de ville
Colone B : Mois en cours
Colone C : Tarif

Je souhaiterais que sur la feuille Y, en automatique, selon le nom de
la ville, apparaisse le tarif du mois en cours (car sur la feuille X
je garde tous les mois en archive)...

J'espère que cela est clair et pas trop embrouillé !!!

Merci.

FRED.





















ChristianM
Le #17894941
Si tu veux, met ton tableau sur cjoint et comme cela on pourra mieux
regarder (enlève ou modifie les informations confidentielles)

--
ChristianM


"Fred" %
Bonjour,

Heu, bon désolé, mais je positionne la formule sur feuily en B1; mais
j'obtiens une erreur...
Arrrg, je pense que je nage !

FRED.

"isabelle" a écrit dans le message de
news:
bonjour Fred,

=SOMMEPROD((Feuilx!$A$2:$A$100¢)*(Feuilx!$B$2:$B$100=TEXTE(MOIS(AUJOURDHUI());"mmm")*(Feuilx!$C$2:$C$100))

isabelle



Fred a écrit :
Désolé,

j'espère que ce sera plus clair comme ça.
Sur la feuille Y , j'ai les villes, je souhaites afficher le montant en
fonction du mois en cours de la feuille X :


Feuille X :

Toulouse octobre 100?
Paris octobre 200?
Toulouse novembre 150 ?
Paris novembre 160 ?

Feuille Y :

Toulouse 150?
Paris 160 ?



"ChristianM" a écrit dans le message de
news:
Cependant sur ton post initial tu mets que tu as en colonne B de ta
feuille Y le mois en cours !
Si ton mois sur la feuille X peut être de format numérique ( 1 à 12 )
tu peux mettre en B sur la feuille Y =MOIS(AUJOURDHUI())


--
ChristianM


"Fred" %
Bonjour,

Euh, vraiment désolé, mais sur ma deuxième feuille (Y), je n'ai que :
A Nom de ville
C Tarif
Je cherche à afficher le tarif sur la feuille Y en fonction du mois en
cours (la colonne B de la feuille X comprendra des lignes Octobre,
Novembre ...).

Merci d'avance,

FRED.




"ChristianM" a écrit dans le message de
news:
Bonjour,
Je suppose que tu n'as dans la feuille X qu'un seule ligne par couple
Ville/mois.
Si tu nommes tes plages :
colonne A = ville
colonne B = mois
colonne C = tarif

sur la feuille Y en colonne C :
=SOMMEPROD((ville¢)*(mois²)*tarif)

Est-ce cela ?

--
ChristianM


"Fred" %
Bonjour,

Je suis un peu embêté car je n'arrive pas à faire une recherche qui
porterait sur 3 critères :

Sur une feuille X , un tableau avec:
Colone A : Nom de ville
Colone B : Mois
Colone C : Tarif

Sur une feuille Y :
Colone A : Nom de ville
Colone B : Mois en cours
Colone C : Tarif

Je souhaiterais que sur la feuille Y, en automatique, selon le nom
de la ville, apparaisse le tarif du mois en cours (car sur la
feuille X je garde tous les mois en archive)...

J'espère que cela est clair et pas trop embrouillé !!!

Merci.

FRED.
























ChristianM
Le #17894901
le voilà en retour : clique sur ce lien
http://cjoint.com/?ltsbsMDP4N

--
ChristianM


"Fred"
Ouf, oui, merci pour ta proposition.
Je joins le fichier.
ce que je cherche à obtenir, c'est le calcul automatique sur la feuille 1
en
colone B, en fonction du mois en cours.

Merci.

FRED.



"ChristianM" a écrit dans le message de
news:%
Si tu veux, met ton tableau sur cjoint et comme cela on pourra mieux
regarder (enlève ou modifie les informations confidentielles)

--
ChristianM


"Fred" %
Bonjour,

Heu, bon désolé, mais je positionne la formule sur feuily en B1; mais
j'obtiens une erreur...
Arrrg, je pense que je nage !

FRED.

"isabelle" a écrit dans le message de
news:
bonjour Fred,

=SOMMEPROD((Feuilx!$A$2:$A$100¢)*(Feuilx!$B$2:$B$100=TEXTE(MOIS(AUJOURDHUI());"mmm")*(Feuilx!$C$2:$C$100))

isabelle



Fred a écrit :
Désolé,

j'espère que ce sera plus clair comme ça.
Sur la feuille Y , j'ai les villes, je souhaites afficher le montant
en
fonction du mois en cours de la feuille X :


Feuille X :

Toulouse octobre 100?
Paris octobre 200?
Toulouse novembre 150 ?
Paris novembre 160 ?

Feuille Y :

Toulouse 150?
Paris 160 ?



"ChristianM" a écrit dans le message de
news:
Cependant sur ton post initial tu mets que tu as en colonne B de ta
feuille Y le mois en cours !
Si ton mois sur la feuille X peut être de format numérique ( 1 à 12 )
tu peux mettre en B sur la feuille Y =MOIS(AUJOURDHUI())


--
ChristianM


"Fred" %
Bonjour,

Euh, vraiment désolé, mais sur ma deuxième feuille (Y), je n'ai que
:
A Nom de ville
C Tarif
Je cherche à afficher le tarif sur la feuille Y en fonction du mois
en cours (la colonne B de la feuille X comprendra des lignes
Octobre,
Novembre ...).

Merci d'avance,

FRED.




"ChristianM" a écrit dans le message de
news:
Bonjour,
Je suppose que tu n'as dans la feuille X qu'un seule ligne par
couple Ville/mois.
Si tu nommes tes plages :
colonne A = ville
colonne B = mois
colonne C = tarif

sur la feuille Y en colonne C :
=SOMMEPROD((ville¢)*(mois²)*tarif)

Est-ce cela ?

--
ChristianM


"Fred" %
Bonjour,

Je suis un peu embêté car je n'arrive pas à faire une recherche
qui
porterait sur 3 critères :

Sur une feuille X , un tableau avec:
Colone A : Nom de ville
Colone B : Mois
Colone C : Tarif

Sur une feuille Y :
Colone A : Nom de ville
Colone B : Mois en cours
Colone C : Tarif

Je souhaiterais que sur la feuille Y, en automatique, selon le nom
de la ville, apparaisse le tarif du mois en cours (car sur la
feuille X je garde tous les mois en archive)...

J'espère que cela est clair et pas trop embrouillé !!!

Merci.

FRED.































Publicité
Poster une réponse
Anonyme