Recherche v dans un classeur externe

Le
dav8669
Bonjour,
Je cherche à faire un recherche v dans un classeur externe. Comment indiquer le chemin vers ce fichier ? J'ai fait plusieurs essais. Pour le moment, j'ai =RECHERCHEV(A2;c:test[tableau.xlsx]produits!A2:B9;2). J'ai essayé avec des guillemets simples, doubles sans succès.
Merci pour votre aide
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
FdeCourt
Le #20677011
Salut,

Essayes :

=RECHERCHEV(A2;'c:test[tableau.xlsx]produits'!A2:B9;2)

Cordialement,

F.
dav8669
Le #20677441
FdeCourt a écrit le 02/12/2009 à 10h18 :
Salut,

Essayes :

=RECHERCHEV(A2;'c:test[tableau.xlsx]produits'!A2:B9;2)

Cordialement,

F.


Merci cela fonctionne et si je veux tester l'existence de la valeur A2 afin de ne pas avoir #N/A comment modifier la formule? Merci
FdeCourt
Le #20677901
Salut,
En ajoutant une condition :
=SI(ESTERREUR(RECHERCHEV(A2;'c:test[tableau.xlsx]produits'!
A2:B9;2));"EN CAS D'ERREUR";RECHERCHEV(A2;'c:test[tableau.xlsx]
produits'!A2:B9;2))

Cordialement,

F.
dav8669
Le #20705441
FdeCourt a écrit le 02/12/2009 à 12h37 :
Salut,
En ajoutant une condition :
=SI(ESTERREUR(RECHERCHEV(A2;'c:test[tableau.xlsx]produits'!
A2:B9;2));"EN CAS D'ERREUR";RECHERCHEV(A2;'c:test[tableau.xlsx]
produits'!A2:B9;2))

Cordialement,

F.


Rebonjour

J'ai un problème avec ma référence produit qui est le champ commun aux deux tableaux.
Elle est de la forme AA123 (soit un mélange de lettres et chiffres) et des que ma reference comporte les deux, elle me sort des résultats aberrants. J'ai vérifié les formats de cellule qui sont les mêmes et lorsque j'ai que des chiffres cela fonctionne sans probleme.
Merci pour votre aide.
FdeCourt
Le #20713041
Salut,

Alors essaye avec la combinaison Index/Equiv :
SI(ESTERREUR(EQUIV(A2;'c:test[tableau.xlsx]produits'!A2:B9,0);"EN CAS
D'ERREUR";INDEX('c:test[tableau.xlsx]produits'!B2:B9;EQUIV(A2;'c:test
[tableau.xlsx]produits'!A2:B9,0)))

Cordialement,

F.
Publicité
Poster une réponse
Anonyme