Recherche d'une valeur dans une matrice

Le
EmanuelL
Bonjour à Tous,

Je cherche une fonction qui peut vérifier l'existance d'une valeur dans
dans une matrice d'une ligne, exemple :

32 dans(22;31;32;35;36;45) => 1 si existe et 0 si n'existe pas


Merci d'avance

--

*!* --
EmanuelL
Membre d'AtoutFox
www.atoutfox.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #18852721
bonjour Emanuel,

=SI(ESTERREUR(EQUIV(32;1:1;0));0;1)
1:1 étant la ligne 1

isabelle

EmanuelL a écrit :
Bonjour à Tous,

Je cherche une fonction qui peut vérifier l'existance d'une valeur
dans dans une matrice d'une ligne, exemple :

32 dans(22;31;32;35;36;45) => 1 si existe et 0 si n'existe pas


Merci d'avance



Philippe.R
Le #18852871
Bonjour tous les deux,
En variante :

=NON(ESTNA(EQUIV(A3;{22;31;32;35;36;45};0)))+0

avec la matrice dans la formule et la valeur testée en A3
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"isabelle" a écrit dans le message de
news:%23k8sqy%
bonjour Emanuel,

=SI(ESTERREUR(EQUIV(32;1:1;0));0;1)
1:1 étant la ligne 1

isabelle

EmanuelL a écrit :
Bonjour à Tous,

Je cherche une fonction qui peut vérifier l'existance d'une valeur dans
dans une matrice d'une ligne, exemple :

32 dans(22;31;32;35;36;45) => 1 si existe et 0 si n'existe pas


Merci d'avance





Sam
Le #18855041
Bonjour,
un p'tit sommeprod ça marche aussi
=SOMMEPROD(({22;31;57;82;51;45;12}¡)*1)

Cordialement
Michel dit "Sam"

"Philippe.R" O1BsBG$
Bonjour tous les deux,
En variante :

=NON(ESTNA(EQUIV(A3;{22;31;32;35;36;45};0)))+0

avec la matrice dans la formule et la valeur testée en A3
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"isabelle" a écrit dans le message de
news:%23k8sqy%
bonjour Emanuel,

=SI(ESTERREUR(EQUIV(32;1:1;0));0;1)
1:1 étant la ligne 1

isabelle

EmanuelL a écrit :
Bonjour à Tous,

Je cherche une fonction qui peut vérifier l'existance d'une valeur dans
dans une matrice d'une ligne, exemple :

32 dans(22;31;32;35;36;45) => 1 si existe et 0 si n'existe pas


Merci d'avance








MichDenis
Le #18855241
Il y a aussi celle-ci qui ne requiert pas une matrice
seulement une chaîne de caractères :

=SI(ESTNUM(TROUVE(A1;"22,31,57,82,51,45,12"));1;0)



"Sam" 49b4020f$0$12647$


Bonjour,
un p'tit sommeprod ça marche aussi
=SOMMEPROD(({22;31;57;82;51;45;12}¡)*1)

Cordialement
Michel dit "Sam"

"Philippe.R" O1BsBG$
Bonjour tous les deux,
En variante :

=NON(ESTNA(EQUIV(A3;{22;31;32;35;36;45};0)))+0

avec la matrice dans la formule et la valeur testée en A3
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"isabelle" a écrit dans le message de
news:%23k8sqy%
bonjour Emanuel,

=SI(ESTERREUR(EQUIV(32;1:1;0));0;1)
1:1 étant la ligne 1

isabelle

EmanuelL a écrit :
Bonjour à Tous,

Je cherche une fonction qui peut vérifier l'existance d'une valeur dans
dans une matrice d'une ligne, exemple :

32 dans(22;31;32;35;36;45) => 1 si existe et 0 si n'existe pas


Merci d'avance








MichDenis
Le #18855231
Quelle ânerie ! à oublier ! ;-)

"MichDenis"
Il y a aussi celle-ci qui ne requiert pas une matrice
seulement une chaîne de caractères :

=SI(ESTNUM(TROUVE(A1;"22,31,57,82,51,45,12"));1;0)



"Sam" 49b4020f$0$12647$


Bonjour,
un p'tit sommeprod ça marche aussi
=SOMMEPROD(({22;31;57;82;51;45;12}¡)*1)

Cordialement
Michel dit "Sam"

"Philippe.R" O1BsBG$
Bonjour tous les deux,
En variante :

=NON(ESTNA(EQUIV(A3;{22;31;32;35;36;45};0)))+0

avec la matrice dans la formule et la valeur testée en A3
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"isabelle" a écrit dans le message de
news:%23k8sqy%
bonjour Emanuel,

=SI(ESTERREUR(EQUIV(32;1:1;0));0;1)
1:1 étant la ligne 1

isabelle

EmanuelL a écrit :
Bonjour à Tous,

Je cherche une fonction qui peut vérifier l'existance d'une valeur dans
dans une matrice d'une ligne, exemple :

32 dans(22;31;32;35;36;45) => 1 si existe et 0 si n'existe pas


Merci d'avance








Michel Angelosanto
Le #18855631
un simple nb.si aussi:
=MIN(NB.SI(A:A;32);1)

"Sam" news:49b4020f$0$12647$


Bonjour,
un p'tit sommeprod ça marche aussi
=SOMMEPROD(({22;31;57;82;51;45;12}¡)*1)

Cordialement
Michel dit "Sam"

"Philippe.R" O1BsBG$
Bonjour tous les deux,
En variante :

=NON(ESTNA(EQUIV(A3;{22;31;32;35;36;45};0)))+0

avec la matrice dans la formule et la valeur testée en A3
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"isabelle" a écrit dans le message de
news:%23k8sqy%
bonjour Emanuel,

=SI(ESTERREUR(EQUIV(32;1:1;0));0;1)
1:1 étant la ligne 1

isabelle

EmanuelL a écrit :
Bonjour à Tous,

Je cherche une fonction qui peut vérifier l'existance d'une valeur dans
dans une matrice d'une ligne, exemple :

32 dans(22;31;32;35;36;45) => 1 si existe et 0 si n'existe pas


Merci d'avance













--
Michel Angelosanto, Bordeaux
Dernières mises à jour du site Voyage au pays Internet
http://angelosa.free.fr/index.php?t=8
Philippe.R
Le #18855751
Bonsoir,
Dans cette solution, la matrice doit impérativement être transposée dans le
classeur.
En tous cas, le questionneur ne manquera pas de propositions.
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"Michel Angelosanto" news:u99gO%
un simple nb.si aussi:
=MIN(NB.SI(A:A;32);1)

"Sam" news:49b4020f$0$12647$


Bonjour,
un p'tit sommeprod ça marche aussi
=SOMMEPROD(({22;31;57;82;51;45;12}¡)*1)

Cordialement
Michel dit "Sam"

"Philippe.R" news: O1BsBG$
Bonjour tous les deux,
En variante :

=NON(ESTNA(EQUIV(A3;{22;31;32;35;36;45};0)))+0

avec la matrice dans la formule et la valeur testée en A3
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"isabelle" a écrit dans le message de
news:%23k8sqy%
bonjour Emanuel,

=SI(ESTERREUR(EQUIV(32;1:1;0));0;1)
1:1 étant la ligne 1

isabelle

EmanuelL a écrit :
Bonjour à Tous,

Je cherche une fonction qui peut vérifier l'existance d'une valeur
dans dans une matrice d'une ligne, exemple :

32 dans(22;31;32;35;36;45) => 1 si existe et 0 si n'existe pas


Merci d'avance













--
Michel Angelosanto, Bordeaux
Dernières mises à jour du site Voyage au pays Internet
http://angelosa.free.fr/index.php?t=8


garnote
Le #18857271
Ave,

Et aussi :
=--(NB.SI(plage;32)>0)
Valable pour une plage de cellules contiguës.

Serge


"EmanuelL"
Bonjour à Tous,

Je cherche une fonction qui peut vérifier l'existance d'une valeur dans dans une matrice d'une ligne, exemple :

32 dans(22;31;32;35;36;45) => 1 si existe et 0 si n'existe pas


Merci d'avance

--

*!* -----------------------------------
EmanuelL
Membre d'AtoutFox
www.atoutfox.org




EmanuelL
Le #18860451
Merci à tous de vos propositions, je suis attiré particulièrement à la
proposition de Michel qui me semble plus simple.

+ ;-)

EmanuelL avait prétendu :
Bonjour à Tous,

Je cherche une fonction qui peut vérifier l'existance d'une valeur dans dans
une matrice d'une ligne, exemple :

32 dans(22;31;32;35;36;45) => 1 si existe et 0 si n'existe pas


Merci d'avance



--

*!* -----------------------------------
EmanuelL
Membre d'AtoutFox
www.atoutfox.org
Publicité
Poster une réponse
Anonyme