Rechercher les noms composés dans une plage de cellule

Le
scgtpas75
Bonjour,

J'ai une longue liste de noms en colonne B.
Dans cette liste, certains noms sont des noms composés
Je souhaite savoir s'il est possible de récupérer dans cette liste les =
noms composés uniquement.

D'avance merci.

Pierre
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JP
Le #25564032
Bonjour,

Un exemple:

Pour une plage de B1 à B10. Les noms composés se réécrivent en colo nne C

Sub test()
Dim compose As Range
Dim k, Nom As Byte
k = 0
For Each compose In Range("B1:B10")
k = k + 1
Nom = Len(compose)
For i = 1 To Nom
If Mid(compose, i, 1) = "-" Then
Cells(k, 3) = Cells(k, 2).Value
End If
Next i
Next compose
End Sub


JP
isabelle
Le #25564042
bonjour Pierre,

pour un prénom composé de 2 noms,

=SI(NBCAR(A1)-NBCAR(SUBSTITUE(A1;" ";""))>1;SUBSTITUE(GAUCHE(A1;TROUVE("
";A1)-1);" ";"")&" "&SUBSTITUE(GAUCHE(STXT(A1;TROUVE("
";A1)+1;9^9);TROUVE(" ";STXT(A1;TROUVE(" ";A1)+1;9^9))-1);" ";"");"")

pour un prénom composé de 3 noms il faudrait ajouter une autre suite de
SUBSTITUE et ainsi de suite.

isabelle


Le 2013-07-25 08:41, a écrit :
Bonjour,

J'ai une longue liste de noms en colonne B.
Dans cette liste, certains noms sont des noms composés
Je souhaite savoir s'il est possible de récupérer dans cette liste les noms composés uniquement.

D'avance merci.

Pierre

isabelle
Le #25564202
une autre solution serait de "Convertir" les données avec l'espace comme
séparateur
puis "Concatener" les lignes dont la colonne C contient une donnée.

isabelle

Le 2013-07-25 10:22, isabelle a écrit :
bonjour Pierre,

pour un prénom composé de 2 noms,

=SI(NBCAR(A1)-NBCAR(SUBSTITUE(A1;" ";""))>1;SUBSTITUE(GAUCHE(A1;TROUVE("
";A1)-1);" ";"")&" "&SUBSTITUE(GAUCHE(STXT(A1;TROUVE("
";A1)+1;9^9);TROUVE(" ";STXT(A1;TROUVE(" ";A1)+1;9^9))-1);" ";"");"")

pour un prénom composé de 3 noms il faudrait ajouter une autre suite de
SUBSTITUE et ainsi de suite.

isabelle


Le 2013-07-25 08:41, a écrit :
Bonjour,

J'ai une longue liste de noms en colonne B.
Dans cette liste, certains noms sont des noms composés
Je souhaite savoir s'il est possible de récupérer dans cette liste les
noms composés uniquement.

D'avance merci.

Pierre

Jacquouille
Le #25564282
Isabelle fait dans la dentelle....

Jacques-Eugène-Gérard du Virage de la Rue des Sports de Strasbourde.

heu, combien de Substitue pour mon nom? -))))

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"isabelle" a écrit dans le message de groupe de discussion :
ksrcad$1tg$

bonjour Pierre,

pour un prénom composé de 2 noms,

=SI(NBCAR(A1)-NBCAR(SUBSTITUE(A1;" ";""))>1;SUBSTITUE(GAUCHE(A1;TROUVE("
";A1)-1);" ";"")&" "&SUBSTITUE(GAUCHE(STXT(A1;TROUVE("
";A1)+1;9^9);TROUVE(" ";STXT(A1;TROUVE(" ";A1)+1;9^9))-1);" ";"");"")

pour un prénom composé de 3 noms il faudrait ajouter une autre suite de
SUBSTITUE et ainsi de suite.

isabelle


Le 2013-07-25 08:41, a écrit :
Bonjour,

J'ai une longue liste de noms en colonne B.
Dans cette liste, certains noms sont des noms composés
Je souhaite savoir s'il est possible de récupérer dans cette liste les
noms composés uniquement.

D'avance merci.

Pierre

Jacky
Le #25564292
heu, combien de Substitue pour mon nom? -))))


Un seul puisqu'avec 1 il est déjà (dé)composé
Hé hé!
:o)))

--
Salutations
JJ


"Jacquouille" 51f15f79$0$32723$
Isabelle fait dans la dentelle....

Jacques-Eugène-Gérard du Virage de la Rue des Sports de Strasbourde.

heu, combien de Substitue pour mon nom? -))))

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"isabelle" a écrit dans le message de groupe de discussion : ksrcad$1tg$

bonjour Pierre,

pour un prénom composé de 2 noms,

=SI(NBCAR(A1)-NBCAR(SUBSTITUE(A1;" ";""))>1;SUBSTITUE(GAUCHE(A1;TROUVE("
";A1)-1);" ";"")&" "&SUBSTITUE(GAUCHE(STXT(A1;TROUVE("
";A1)+1;9^9);TROUVE(" ";STXT(A1;TROUVE(" ";A1)+1;9^9))-1);" ";"");"")

pour un prénom composé de 3 noms il faudrait ajouter une autre suite de
SUBSTITUE et ainsi de suite.

isabelle


Le 2013-07-25 08:41, a écrit :
Bonjour,

J'ai une longue liste de noms en colonne B.
Dans cette liste, certains noms sont des noms composés
Je souhaite savoir s'il est possible de récupérer dans cette liste les noms composés uniquement.

D'avance merci.

Pierre




isabelle
Le #25564372
aucun celui l'à a déjà "tiret" sa révérence ;-)
isabelle

Le 2013-07-25 13:25, Jacquouille a écrit :
Isabelle fait dans la dentelle....

Jacques-Eugène-Gérard du Virage de la Rue des Sports de Strasbourde.

heu, combien de Substitue pour mon nom? -))))

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"isabelle" a écrit dans le message de groupe de discussion :
ksrcad$1tg$
scgtpas75
Le #25564382
Je n'ai pas encore le temps de tester tout cela... quoiqu'il en soit merci pour vos réponses.
scgtpas75
Le #25564492
Le jeudi 25 juillet 2013 16:15:54 UTC+2, JP a écrit :
Bonjour,



Un exemple:



Pour une plage de B1 à B10. Les noms composés se réécrivent en co lonne C



Sub test()

Dim compose As Range

Dim k, Nom As Byte

k = 0

For Each compose In Range("B1:B10")

k = k + 1

Nom = Len(compose)

For i = 1 To Nom

If Mid(compose, i, 1) = "-" Then

Cells(k, 3) = Cells(k, 2).Value

End If

Next i

Next compose

End Sub





JP




JP

J'ai essayé ce que tu proposes en recopiant ton code dans un module.
En exécutant la macro je ne vois aucune réaction...
http://goo.gl/8BfXY2

J'ai peut-être loupé quelque chose...
scgtpas75
Le #25564482
Le jeudi 25 juillet 2013 16:22:10 UTC+2, isabelle a écrit :
bonjour Pierre,



pour un prénom composé de 2 noms,



=SI(NBCAR(A1)-NBCAR(SUBSTITUE(A1;" ";""))>1;SUBSTITUE(GAUCHE(A1;TROUVE( "

";A1)-1);" ";"")&" "&SUBSTITUE(GAUCHE(STXT(A1;TROUVE("

";A1)+1;9^9);TROUVE(" ";STXT(A1;TROUVE(" ";A1)+1;9^9))-1);" ";"");"")



pour un prénom composé de 3 noms il faudrait ajouter une autre suite de

SUBSTITUE et ainsi de suite.



isabelle



Isabelle

J'ai inséré ta formule en C1 et j'ai recopié jusqu'à C20
J'obtiens ceci : http://goo.gl/8BfXY2 (en colonne C)

Pas vraiment ce que je recherchais puisque le but pour moi est de voir appa raître en colonne C tous les prénoms composés
En fait dans une liste de prénom très longue j'aimerai automatiser la r echerche de prénoms composés...

Merci.
scgtpas75
Le #25564512
Le jeudi 25 juillet 2013 18:44:45 UTC+2, isabelle a écrit :
une autre solution serait de "Convertir" les données avec l'espace comm e

séparateur

puis "Concatener" les lignes dont la colonne C contient une donnée.



isabelle



J'ai réussi à convertir les données avec l'espace et/ou le tiret comm e séparateur (voir feuille Convertir) mais je ne comprends pas ce que tu veux dire par "concaténer" les lignes dont la colonne C contient une donn ée...
Publicité
Poster une réponse
Anonyme