Rechercher la valeur dans une colonne et remonte la valeur d'une a

Le
preston
Le problème :

J'ai un montant 69500 et j'aimerais trouver le montant supérieur à 69500
dans une colonne X ou Y.

Pouvez-vous m'aider

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
preston
Le #18391401
"preston" a écrit :

Le problème :

Dans une formule, j'ai le résultat d'un montant 69500 et j'aimerais trouver le montant supérieur à 69500 par rapport à la colonne X ou Y.


Ex.: chercher dans la colonne "7" le montant supérieur à 69500 et renvoyer
la valeur de la colonne "A"

4 5 6 7
0 52116 54462 56913 59475
1 52695 55040 57494 60082
2 53274 55618 58075 60689
3 53853 56196 58656 61296
4 55386 57726 60195 62904
5 56919 59256 61734 64512
6 58452 60786 63273 66120
7 59985 62316 64812 67728
8 61518 63846 66351 69336
9 63051 65376 67890 70944


Pouvez-vous m'aider...

Merci


FFO
Le #18391741
Salut à toi

Feuil1 à traiter
Je te propose ce code :

For Each c In Worksheets("Recherche").Range(Cells(2, 7).Address,
Range(Cells(65535, 7).Address).End(xlUp))
If c > 69500 Then
MsgBox (Range("A" & c.Row))
Exit For
End If
Next

Résultat dans une boîte de dialogue

Celà devrait convenir
Dis moi !!!!
FFO
Le #18391731
Rebonjour à toi

Une petite erreur dans mon code

si le nom de ta feuille est "Feuil1"
Mets à la place de :

Worksheets("Recherche")

Worksheets("Feuil1")

sinon adapte la en fonction de son nom


Mille excuses

Tiens moi informé !!!!
preston
Le #18391841
Bonjour et merci.

Je souhaiterais le faire sans VBA mais par des formules.

As-tu la solution?

Alain

"FFO" a écrit :

Rebonjour à toi

Une petite erreur dans mon code

si le nom de ta feuille est "Feuil1"
Mets à la place de :

Worksheets("Recherche")

Worksheets("Feuil1")

sinon adapte la en fonction de son nom


Mille excuses

Tiens moi informé !!!!



Daniel.C
Le #18391971
Bonjour.
Formule matricielle (à valider avec CTRL+Maj+Entrée) :
=MIN(SI(A1:D10>69500;A1:D10))
Cordialement.
Daniel

Bonjour et merci.

Je souhaiterais le faire sans VBA mais par des formules.

As-tu la solution?

Alain

"FFO" a écrit :

Rebonjour à toi

Une petite erreur dans mon code

si le nom de ta feuille est "Feuil1"
Mets à la place de :

Worksheets("Recherche")

Worksheets("Feuil1")

sinon adapte la en fonction de son nom


Mille excuses

Tiens moi informé !!!!





FFO
Le #18391961
Rebonjour à toi
En colonne 8 (Colonne H) ligne 2 mets cette formule

=SI(G2>69500;A2;"")

puis recopies la vers le bas

Résultat en colonne H

Est ce bien ce que tu souhaites ????
preston
Le #18392111
Non c'est plus complexe.

J'ai un montant qui est déterminé
J'ai également une classe déterminée

Je dois retrouver un échelon dans une table avec des classes (33) et des
échelons (22)

"FFO" a écrit :

Rebonjour à toi
En colonne 8 (Colonne H) ligne 2 mets cette formule

=SI(G2>69500;A2;"")

puis recopies la vers le bas

Résultat en colonne H

Est ce bien ce que tu souhaites ????



Daniel.C
Le #18392331
Donne le résultat de ce que tu attends avec l'exemple que tu as fourni.
Regarde le classeur à l'adresse :
http://www.cijoint.fr/cjlink.php?file=cj200901/cijf8KjWMR.xls
Daniel

Non c'est plus complexe.

J'ai un montant qui est déterminé
J'ai également une classe déterminée

Je dois retrouver un échelon dans une table avec des classes (33) et des
échelons (22)

"FFO" a écrit :

Rebonjour à toi
En colonne 8 (Colonne H) ligne 2 mets cette formule

=SI(G2>69500;A2;"")

puis recopies la vers le bas

Résultat en colonne H

Est ce bien ce que tu souhaites ????





preston
Le #18393191
rde le classeur à l'adresse :
http://www.cijoint.fr/cjlink.php?file=cj200901/cij0MTf4Wv.xls
dans la colonne z en jaune il y a ce que je souhaite remonter comme valeur
avec les différents onlets.



"Daniel.C" a écrit :

Donne le résultat de ce que tu attends avec l'exemple que tu as fourni.
Regarde le classeur à l'adresse :
http://www.cijoint.fr/cjlink.php?file=cj200901/cijf8KjWMR.xls
Daniel

> Non c'est plus complexe.
>
> J'ai un montant qui est déterminé
> J'ai également une classe déterminée
>
> Je dois retrouver un échelon dans une table avec des classes (33) et des
> échelons (22)
>
> "FFO" a écrit :
>
>> Rebonjour à toi
>> En colonne 8 (Colonne H) ligne 2 mets cette formule
>>
>> =SI(G2>69500;A2;"")
>>
>> puis recopies la vers le bas
>>
>> Résultat en colonne H
>>
>> Est ce bien ce que tu souhaites ????
>>





Daniel.C
Le #18393521
Désolé, je ne comprends pas ce que tu veux faire. Quelle valeur veux-tu
récupérer en Q12 ?
Daniel

rde le classeur à l'adresse :
http://www.cijoint.fr/cjlink.php?file=cj200901/cij0MTf4Wv.xls
dans la colonne z en jaune il y a ce que je souhaite remonter comme valeur
avec les différents onlets.



"Daniel.C" a écrit :

Donne le résultat de ce que tu attends avec l'exemple que tu as fourni.
Regarde le classeur à l'adresse :
http://www.cijoint.fr/cjlink.php?file=cj200901/cijf8KjWMR.xls
Daniel

Non c'est plus complexe.

J'ai un montant qui est déterminé
J'ai également une classe déterminée

Je dois retrouver un échelon dans une table avec des classes (33) et des
échelons (22)

"FFO" a écrit :

Rebonjour à toi
En colonne 8 (Colonne H) ligne 2 mets cette formule

=SI(G2>69500;A2;"")

puis recopies la vers le bas

Résultat en colonne H

Est ce bien ce que tu souhaites ????












Publicité
Poster une réponse
Anonyme