RechercheV, valeur suivante

Le
Alexandre Campeau
Bonjour,

Je fais une recherche verticale dans une matrice.
Disons:
1 10
2 20
3 30
4 40

Si j'entre =RECHERCHEV(2.5;matrice;2)
j'obtiens 20.

Cependant, j'aimerais avoir la valeur suivante, c'est à dire 30 !

J'ai chercher beaucoup et j'ai essayé d'autres formules comme "Cellule" mais
rien ne fonctionnait.

Comment puis-je faire ceci ?

Merci beaucoup,

Alexandre
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ellimac
Le #4915031
Bonjour,
Avec plage1 en A1:A4 et plage2 en B1:B4
=INDEX(B1:B4;EQUIV(2,5;A1:A4)+1)

Camille

"Alexandre Campeau" wrote:

Bonjour,

Je fais une recherche verticale dans une matrice.
Disons:
1 10
2 20
3 30
4 40

Si j'entre =RECHERCHEV(2.5;matrice;2)
j'obtiens 20.

Cependant, j'aimerais avoir la valeur suivante, c'est à dire 30 !

J'ai chercher beaucoup et j'ai essayé d'autres formules comme "Cellule" mais
rien ne fonctionnait.

Comment puis-je faire ceci ?

Merci beaucoup,

Alexandre


JB
Le #4915001
Bonjour,

Inverser l'ordre:

4 40
3 30
2 20
1 10

=INDEX(B2:B5;EQUIV(valeurCherchée;A2:A5;-1))

JB

On 14 juin, 17:05, Alexandre Campeau
Bonjour,

Je fais une recherche verticale dans une matrice.
Disons:
1 10
2 20
3 30
4 40

Si j'entre =RECHERCHEV(2.5;matrice;2)
j'obtiens 20.

Cependant, j'aimerais avoir la valeur suivante, c'est à dire 30 !

J'ai chercher beaucoup et j'ai essayé d'autres formules comme "Cellule" mais
rien ne fonctionnait.

Comment puis-je faire ceci ?

Merci beaucoup,

Alexandre


Daniel
Le #4914991
Bonjour.
Il y a sans doute plus fûté :
=SI(EQUIV(2.5;A1:A4;1)=2.5;RECHERCHEV(2.5;A1:B4;2;0);INDEX(B1:B4;EQUIV(2.5;A1:A4;1)+1;))
Cordialement.
Daniel
"Alexandre Campeau"
Bonjour,

Je fais une recherche verticale dans une matrice.
Disons:
1 10
2 20
3 30
4 40

Si j'entre =RECHERCHEV(2.5;matrice;2)
j'obtiens 20.

Cependant, j'aimerais avoir la valeur suivante, c'est à dire 30 !

J'ai chercher beaucoup et j'ai essayé d'autres formules comme "Cellule"
mais
rien ne fonctionnait.

Comment puis-je faire ceci ?

Merci beaucoup,

Alexandre


Publicité
Poster une réponse
Anonyme