Reconnaitre une lettre d'un chiffre.

Le
Guy72
Bonjour,
Qu'elle est la formule qui permet de différentier une lettre d'un chiffre ou
vice-versa?
=SI(AZ20="une lettre";BD20;"").
Merci de votre aide.
--
Cordialement
Guy
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
FFO
Le #17957411
Salut Guy

ceci pourrait convenir :

=SI(T(AZ20)<>"";BD20;"")

Celà devrait convenir
Dis moi !!!
Daniel.C
Le #17957401
Bonjour.
=SI(OU(ET(AZ20>="a";AZ20<="z");ET(CODE(AZ20)>e;CODE(AZ20)<));BD20;"")
Cordialement.
Daniel

Bonjour,
Qu'elle est la formule qui permet de différentier une lettre d'un chiffre ou
vice-versa?
=SI(AZ20="une lettre";BD20;"").
Merci de votre aide.


lSteph
Le #17957391
Bonjour,

=si(AZ20="";"";si(non(estnum(az20));BD20;""))

--
lSteph

On 25 nov, 16:34, "Guy72"
Bonjour,
Qu'elle est la formule qui permet de différentier une lettre d'un chiff re ou
vice-versa?
=SI(AZ20="une lettre";BD20;"").
Merci de votre aide.
--
Cordialement
Guy


Guy72
Le #17958321
Bonjour à tous,
Bravo à tous, toutes les formules fonctionnes.
Par contre, elles sont plus ou moins compliquées, je choisis donc celle de
FFO.
Je suppose que T est égal à Texte ?
--
Cordialement
Guy
"lSteph"
Bonjour,

=si(AZ20="";"";si(non(estnum(az20));BD20;""))

--
lSteph

On 25 nov, 16:34, "Guy72"
Bonjour,
Qu'elle est la formule qui permet de différentier une lettre d'un chiffre
ou
vice-versa?
=SI(AZ20="une lettre";BD20;"").
Merci de votre aide.
--
Cordialement
Guy


Daniel.C
Le #17958291
Si tu considères qu'un guillemet ou une virgule, ou un chiffre formaté
texte est une lettre, alors, oui.
Daniel

Bonjour à tous,
Bravo à tous, toutes les formules fonctionnes.
Par contre, elles sont plus ou moins compliquées, je choisis donc celle de
FFO.
Je suppose que T est égal à Texte ?
--
Cordialement
Guy
"lSteph"
Bonjour,

=si(AZ20="";"";si(non(estnum(az20));BD20;""))


LSteph
Le #17961301
Bonsoir,

à partir du moment où ce n'est pas du numérique c'est du caractère!

et je ne vois pas pourquoi (selon ta suggestion) il n'y aurait qu'un chr.
Aussi , nous devons nous incliner amha , la proposition de FFO est il me
semble la meilleure, qui plus est c'est celle qui convient au
demandeur.

@+

--
lSteph

Daniel.C a écrit :
Si tu considères qu'un guillemet ou une virgule, ou un chiffre formaté
texte est une lettre, alors, oui.
Daniel

Bonjour à tous,
Bravo à tous, toutes les formules fonctionnes.
Par contre, elles sont plus ou moins compliquées, je choisis donc
celle de FFO.
Je suppose que T est égal à Texte ?
--
Cordialement
Guy
"lSteph"
Bonjour,

=si(AZ20="";"";si(non(estnum(az20));BD20;""))






Daniel.C
Le #17961711
> à partir du moment où ce n'est pas du numérique c'est du caractère!



Oui, mais, justement, ce n'est pas exactement la question.

et je ne vois pas pourquoi (selon ta suggestion) il n'y aurait qu'un chr.



Ce n'est pas ma suggestion, c'est ce qui est écrit dans le titre : UN
chiffre d'UNE lettre.

qui plus est c'est celle qui convient au
demandeur.



Il fallait néanmoins attirer son attention sur ce point. Qu'il
choisisse bien en connaissance de cause. Après, si la formule de FFO
lui convient, c'est sans doute la meilleure. Je trouve cependant qu'il
fallait lui montrer tous les cas de figure possibles.
Bonne soirée.
Daniel

@+

--
lSteph

Daniel.C a écrit :
Si tu considères qu'un guillemet ou une virgule, ou un chiffre formaté
texte est une lettre, alors, oui.
Daniel

Bonjour à tous,
Bravo à tous, toutes les formules fonctionnes.
Par contre, elles sont plus ou moins compliquées, je choisis donc celle de
FFO.
Je suppose que T est égal à Texte ?
-- Cordialement
Guy
"lSteph"
Bonjour,

=si(AZ20="";"";si(non(estnum(az20));BD20;""))








LSteph
Le #17961821
certes !
ce qui m'a fait tiquer c'est cette expression:

=SI(AZ20="une lettre";BD20;"")

là il me semblesous entendu par "une lettre" qu'il s'agit en fait de
distinguer du texte , une chaine. Donc tout autre que nombre ou date...

Bonne soirée à toi aussi

@+

--
lSteph

Daniel.C a écrit :
à partir du moment où ce n'est pas du numérique c'est du caractère!



Oui, mais, justement, ce n'est pas exactement la question.

et je ne vois pas pourquoi (selon ta suggestion) il n'y aurait qu'un chr.



Ce n'est pas ma suggestion, c'est ce qui est écrit dans le titre : UN
chiffre d'UNE lettre.

qui plus est c'est celle qui convient au
demandeur.



Il fallait néanmoins attirer son attention sur ce point. Qu'il choisisse
bien en connaissance de cause. Après, si la formule de FFO lui convient,
c'est sans doute la meilleure. Je trouve cependant qu'il fallait lui
montrer tous les cas de figure possibles.
Bonne soirée.
Daniel

@+

--
lSteph

Daniel.C a écrit :
Si tu considères qu'un guillemet ou une virgule, ou un chiffre
formaté texte est une lettre, alors, oui.
Daniel

Bonjour à tous,
Bravo à tous, toutes les formules fonctionnes.
Par contre, elles sont plus ou moins compliquées, je choisis donc
celle de FFO.
Je suppose que T est égal à Texte ?
-- Cordialement
Guy
"lSteph"
Bonjour,

=si(AZ20="";"";si(non(estnum(az20));BD20;""))












Guy72
Le #17962241
Bonjour à tous,
=SI(AZ20="une lettre";BD20;"")
là il me semble sous entendu par "une lettre" qu'il s'agit en fait de
distinguer du texte , une chaine. Donc tout autre que nombre ou date...



non,non, dans AZ20 il n'y a bien "qu'une lettre".
--
Cordialement
Guy

"LSteph"
certes !
ce qui m'a fait tiquer c'est cette expression:

=SI(AZ20="une lettre";BD20;"")

là il me semblesous entendu par "une lettre" qu'il s'agit en fait de
distinguer du texte , une chaine. Donc tout autre que nombre ou date...

Bonne soirée à toi aussi

@+

--
lSteph

Daniel.C a écrit :
à partir du moment où ce n'est pas du numérique c'est du caractère!



Oui, mais, justement, ce n'est pas exactement la question.

et je ne vois pas pourquoi (selon ta suggestion) il n'y aurait qu'un
chr.



Ce n'est pas ma suggestion, c'est ce qui est écrit dans le titre : UN
chiffre d'UNE lettre.

qui plus est c'est celle qui convient au
demandeur.



Il fallait néanmoins attirer son attention sur ce point. Qu'il choisisse
bien en connaissance de cause. Après, si la formule de FFO lui convient,
c'est sans doute la meilleure. Je trouve cependant qu'il fallait lui
montrer tous les cas de figure possibles.
Bonne soirée.
Daniel

@+

--
lSteph

Daniel.C a écrit :
Si tu considères qu'un guillemet ou une virgule, ou un chiffre formaté
texte est une lettre, alors, oui.
Daniel

Bonjour à tous,
Bravo à tous, toutes les formules fonctionnes.
Par contre, elles sont plus ou moins compliquées, je choisis donc
celle de FFO.
Je suppose que T est égal à Texte ?
-- Cordialement
Guy
"lSteph"
Bonjour,

=si(AZ20="";"";si(non(estnum(az20));BD20;""))













LSteph
Le #17962351
...

alors maintenant c'est très clair,

en fait trois de +

;o))

@+

--
lSteph

Guy72 a écrit :
Bonjour à tous,
=SI(AZ20="une lettre";BD20;"")
là il me semble sous entendu par "une lettre" qu'il s'agit en fait de
distinguer du texte , une chaine. Donc tout autre que nombre ou date...



non,non, dans AZ20 il n'y a bien "qu'une lettre".


Publicité
Poster une réponse
Anonyme