Recuperer des doublons

Le
catbalou
Bonjour,
J'ai 2 colonnes A et B qui contiennent chacune des données chiffrées et je
voudrais recuperer les doublons entre les 2 colonnes dans la colonne D par
exemple, comment faire. Merci
P.S. Je suis novice dans excel
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #18799321
Bonjour,


-Créer un critère en F2: =NB.SI($B$2:$B$20;A2)>0
-Données/Filtre/Filtre élaboré
-Plage:A1:A1000
-Critère: F1:F2
-Copier : D1

http://cjoint.com/?deg1eYDr7J

http://boisgontierjacques.free.fr/pages_site/FiltreElabore.htm#ElementsComm uns2Listes


JB
http://boisgontierjacques.free.fr


On 28 fév, 00:36, catbalou
Bonjour,
J'ai 2 colonnes A et B qui contiennent chacune des données chiffrées et je
voudrais recuperer les doublons entre les 2 colonnes dans la colonne D pa r
exemple, comment faire. Merci
P.S. Je suis novice dans excel


JB
Le #18799311
Avec Dictionnary:

Sub Communs()
Set MonDico1 = CreateObject("Scripting.Dictionary")
For Each c In Range([A2], [A65000].End(xlUp))
If Not MonDico1.Exists(c.Value) Then MonDico1.Add c.Value,
c.Value
Next c
Set mondico2 = CreateObject("Scripting.Dictionary")
For Each c In Range([B2], [B65000].End(xlUp))
If MonDico1.Exists(c.Value) Then
If Not mondico2.Exists(c.Value) Then mondico2.Add c.Value,
c.Value
End If
Next c
Range("E2:E" & mondico2.Count + 1) = Application.Transpose
(mondico2.items)
End Sub

http://boisgontierjacques.free.fr/pages_site/Dictionnaire.htm#ElementsCommu ns2Listes

JB

On 2 mar, 06:54, JB
Bonjour,

-Créer un critère en F2: =NB.SI($B$2:$B$20;A2)>0
-Données/Filtre/Filtre élaboré
-Plage:A1:A1000
-Critère: F1:F2
-Copier : D1

http://cjoint.com/?deg1eYDr7J

http://boisgontierjacques.free.fr/pages_site/FiltreElabore.htm#Elemen...

JBhttp://boisgontierjacques.free.fr

On 28 fév, 00:36, catbalou


> Bonjour,
> J'ai 2 colonnes A et B qui contiennent chacune des données chiffrée s et je
> voudrais recuperer les doublons entre les 2 colonnes dans la colonne D par
> exemple, comment faire. Merci
> P.S. Je suis novice dans excel- Masquer le texte des messages précé dents -

- Afficher le texte des messages précédents -


MichDenis
Le #18802031
Suppose que tu as 2 colonnes de données A1:A10 et B1:B10
et que tu veux savoir si dans la plage "A1:A10" tu as des données
qui sont aussi présents(en double) en B1:B10.

Dans C1, tu places la formule suivante : =SI(NB.SI($B$1:$B$10;A1)>1;A1;"")
et tu la recopies sur toute la colonne C . Seules les valeurs en double
seront visibles.

Si tu veux faire disparaitre les lignes vides "" copier-coller valeur seulement
et tu tries la colonne C



"catbalou" discussion :
Bonjour,
J'ai 2 colonnes A et B qui contiennent chacune des données chiffrées et je
voudrais recuperer les doublons entre les 2 colonnes dans la colonne D par
exemple, comment faire. Merci
P.S. Je suis novice dans excel
Publicité
Poster une réponse
Anonyme