récurrence d'activité sur une année glissante

Le
grodep
Bonjour a tous, je rentre sur une meme ligne les dates correspondant aux
jours au cours desquels une personne a effectué une activité particuliere
afin de calculer sur une année glissante le nombre de fois ou cette personne
a fait cette dite activité. Mon souci est que je ne dois pas prendre en
compte les fois ou cette activité a été effectué plusieurs fois en 15 jours:
effectué : 10/01/07 15/01/07 20/01/07 30/01/07 : au total seuls le
10 et le 30 doivent etre comptés.

J'ai "résolu" le probleme en utilisant la fonction SI, mais le probleme est
que cette fonction est limitée en nombre d'occurence(7 si je ne me trompe).
Or, il se peut tres bien qu'une personne effectue cette activité 10 fois sur
15 jours, et là, je suis coincé
Quelqu'un saurait il me dire comment contourner le probleme?

Merci d'avance
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #5229531
Bonjour.
Suppose que tes valeurs sont en ligne 1. Sur une autre ligne (ou sur une
autre feuille, j'ai utilisé dans mes formules la ligne 3), en A3 :
¡
En B3 :
=SI(B1-A3>14;B1;A3)
(>14 ou >15, c'est à toi de voir)
à recopier vers la droite.
La formule donnant le total est matricielle (à valider avec CTRL+Maj+Entrée)
:
=SOMME(N(A3:D3¡:D1))
Cordialement.
Daniel
"grodep"
Bonjour a tous, je rentre sur une meme ligne les dates correspondant aux
jours au cours desquels une personne a effectué une activité particuliere
afin de calculer sur une année glissante le nombre de fois ou cette
personne a fait cette dite activité. Mon souci est que je ne dois pas
prendre en compte les fois ou cette activité a été effectué plusieurs fois
en 15 jours:
effectué : 10/01/07 15/01/07 20/01/07 30/01/07 : au total seuls le
10 et le 30 doivent etre comptés.

J'ai "résolu" le probleme en utilisant la fonction SI, mais le probleme
est que cette fonction est limitée en nombre d'occurence(7 si je ne me
trompe). Or, il se peut tres bien qu'une personne effectue cette activité
10 fois sur 15 jours, et là, je suis coincé...
Quelqu'un saurait il me dire comment contourner le probleme?

Merci d'avance




grodep
Le #5229221
grand merci !! C'est tout simple, encore fallait-il y penser :) :)
"Daniel.C"
Bonjour.
Suppose que tes valeurs sont en ligne 1. Sur une autre ligne (ou sur une
autre feuille, j'ai utilisé dans mes formules la ligne 3), en A3 :
¡
En B3 :
=SI(B1-A3>14;B1;A3)
(>14 ou >15, c'est à toi de voir)
à recopier vers la droite.
La formule donnant le total est matricielle (à valider avec
CTRL+Maj+Entrée) :
=SOMME(N(A3:D3¡:D1))
Cordialement.
Daniel
"grodep"
Bonjour a tous, je rentre sur une meme ligne les dates correspondant aux
jours au cours desquels une personne a effectué une activité particuliere
afin de calculer sur une année glissante le nombre de fois ou cette
personne a fait cette dite activité. Mon souci est que je ne dois pas
prendre en compte les fois ou cette activité a été effectué plusieurs
fois en 15 jours:
effectué : 10/01/07 15/01/07 20/01/07 30/01/07 : au total seuls
le 10 et le 30 doivent etre comptés.

J'ai "résolu" le probleme en utilisant la fonction SI, mais le probleme
est que cette fonction est limitée en nombre d'occurence(7 si je ne me
trompe). Or, il se peut tres bien qu'une personne effectue cette activité
10 fois sur 15 jours, et là, je suis coincé...
Quelqu'un saurait il me dire comment contourner le probleme?

Merci d'avance








grodep
Le #5229191
autre question concernant la formule matricielle en conservant le principe
des lignes 1 et 3, sur 6 colonnnes, la liste des dates se poursuit sur les 7
et 9 ainsi que sur les lignes 11 et13. Pour faire ma somme finale, je tente
de créer une formule du style : =
somme(N(A3:F3;A9:F9;A13:F13¡:F1;A7:F7;A11:F11)) mais celà me renvoie un
message d'erreur. Cette formule ne peut donc t'elle s'employer que ligne par
ligne =SOMME(N(A3:F3¡:F1)) ou alors est ce moi qui m'y prend mal ?

Merci d'avance
"Daniel.C"
Bonjour.
Suppose que tes valeurs sont en ligne 1. Sur une autre ligne (ou sur une
autre feuille, j'ai utilisé dans mes formules la ligne 3), en A3 :
¡
En B3 :
=SI(B1-A3>14;B1;A3)
(>14 ou >15, c'est à toi de voir)
à recopier vers la droite.
La formule donnant le total est matricielle (à valider avec
CTRL+Maj+Entrée) :
=SOMME(N(A3:D3¡:D1))
Cordialement.
Daniel
"grodep"
Bonjour a tous, je rentre sur une meme ligne les dates correspondant aux
jours au cours desquels une personne a effectué une activité particuliere
afin de calculer sur une année glissante le nombre de fois ou cette
personne a fait cette dite activité. Mon souci est que je ne dois pas
prendre en compte les fois ou cette activité a été effectué plusieurs
fois en 15 jours:
effectué : 10/01/07 15/01/07 20/01/07 30/01/07 : au total seuls
le 10 et le 30 doivent etre comptés.

J'ai "résolu" le probleme en utilisant la fonction SI, mais le probleme
est que cette fonction est limitée en nombre d'occurence(7 si je ne me
trompe). Or, il se peut tres bien qu'une personne effectue cette activité
10 fois sur 15 jours, et là, je suis coincé...
Quelqu'un saurait il me dire comment contourner le probleme?

Merci d'avance








grodep
Le #5229181
argh et derniere chose : comment faire pour que la somme matricielle ne me
compte pas de dates supplémentaires quand certaines cellules de dates n'ont
pas encore été remplies? Si je ne mets rien en E1 ni en F1, celà sera compté
comme 2 dates différentes et donc inclut dans la somme..

"Daniel.C"
Bonjour.
Suppose que tes valeurs sont en ligne 1. Sur une autre ligne (ou sur une
autre feuille, j'ai utilisé dans mes formules la ligne 3), en A3 :
¡
En B3 :
=SI(B1-A3>14;B1;A3)
(>14 ou >15, c'est à toi de voir)
à recopier vers la droite.
La formule donnant le total est matricielle (à valider avec
CTRL+Maj+Entrée) :
=SOMME(N(A3:D3¡:D1))
Cordialement.
Daniel
"grodep"
Bonjour a tous, je rentre sur une meme ligne les dates correspondant aux
jours au cours desquels une personne a effectué une activité particuliere
afin de calculer sur une année glissante le nombre de fois ou cette
personne a fait cette dite activité. Mon souci est que je ne dois pas
prendre en compte les fois ou cette activité a été effectué plusieurs
fois en 15 jours:
effectué : 10/01/07 15/01/07 20/01/07 30/01/07 : au total seuls
le 10 et le 30 doivent etre comptés.

J'ai "résolu" le probleme en utilisant la fonction SI, mais le probleme
est que cette fonction est limitée en nombre d'occurence(7 si je ne me
trompe). Or, il se peut tres bien qu'une personne effectue cette activité
10 fois sur 15 jours, et là, je suis coincé...
Quelqu'un saurait il me dire comment contourner le probleme?

Merci d'avance








grodep
Le #5229071
probleme réglé


"grodep" %23z%
autre question concernant la formule matricielle en conservant le
principe des lignes 1 et 3, sur 6 colonnnes, la liste des dates se
poursuit sur les 7 et 9 ainsi que sur les lignes 11 et13. Pour faire ma
somme finale, je tente de créer une formule du style : =
somme(N(A3:F3;A9:F9;A13:F13¡:F1;A7:F7;A11:F11)) mais celà me renvoie un
message d'erreur. Cette formule ne peut donc t'elle s'employer que ligne
par ligne =SOMME(N(A3:F3¡:F1)) ou alors est ce moi qui m'y prend mal ?

Merci d'avance
"Daniel.C"
Bonjour.
Suppose que tes valeurs sont en ligne 1. Sur une autre ligne (ou sur une
autre feuille, j'ai utilisé dans mes formules la ligne 3), en A3 :
¡
En B3 :
=SI(B1-A3>14;B1;A3)
(>14 ou >15, c'est à toi de voir)
à recopier vers la droite.
La formule donnant le total est matricielle (à valider avec
CTRL+Maj+Entrée) :
=SOMME(N(A3:D3¡:D1))
Cordialement.
Daniel
"grodep"
Bonjour a tous, je rentre sur une meme ligne les dates correspondant aux
jours au cours desquels une personne a effectué une activité
particuliere afin de calculer sur une année glissante le nombre de fois
ou cette personne a fait cette dite activité. Mon souci est que je ne
dois pas prendre en compte les fois ou cette activité a été effectué
plusieurs fois en 15 jours:
effectué : 10/01/07 15/01/07 20/01/07 30/01/07 : au total seuls
le 10 et le 30 doivent etre comptés.

J'ai "résolu" le probleme en utilisant la fonction SI, mais le probleme
est que cette fonction est limitée en nombre d'occurence(7 si je ne me
trompe). Or, il se peut tres bien qu'une personne effectue cette
activité 10 fois sur 15 jours, et là, je suis coincé...
Quelqu'un saurait il me dire comment contourner le probleme?

Merci d'avance












grodep
Le #5229061
probleme réglé

merci encore
"grodep"
argh et derniere chose : comment faire pour que la somme matricielle ne me
compte pas de dates supplémentaires quand certaines cellules de dates
n'ont pas encore été remplies? Si je ne mets rien en E1 ni en F1, celà
sera compté comme 2 dates différentes et donc inclut dans la somme..

"Daniel.C"
Bonjour.
Suppose que tes valeurs sont en ligne 1. Sur une autre ligne (ou sur une
autre feuille, j'ai utilisé dans mes formules la ligne 3), en A3 :
¡
En B3 :
=SI(B1-A3>14;B1;A3)
(>14 ou >15, c'est à toi de voir)
à recopier vers la droite.
La formule donnant le total est matricielle (à valider avec
CTRL+Maj+Entrée) :
=SOMME(N(A3:D3¡:D1))
Cordialement.
Daniel
"grodep"
Bonjour a tous, je rentre sur une meme ligne les dates correspondant aux
jours au cours desquels une personne a effectué une activité
particuliere afin de calculer sur une année glissante le nombre de fois
ou cette personne a fait cette dite activité. Mon souci est que je ne
dois pas prendre en compte les fois ou cette activité a été effectué
plusieurs fois en 15 jours:
effectué : 10/01/07 15/01/07 20/01/07 30/01/07 : au total seuls
le 10 et le 30 doivent etre comptés.

J'ai "résolu" le probleme en utilisant la fonction SI, mais le probleme
est que cette fonction est limitée en nombre d'occurence(7 si je ne me
trompe). Or, il se peut tres bien qu'une personne effectue cette
activité 10 fois sur 15 jours, et là, je suis coincé...
Quelqu'un saurait il me dire comment contourner le probleme?

Merci d'avance












Publicité
Poster une réponse
Anonyme