Régime pour formule

Le
Jol
Bonjour à tous,

J'ai la formule suivante que je trouve un peu lourde :

=SI(B12<>"";SI(ESTERREUR(E12*(C12-D12)-H12);E12*(C12-D12);E12*(C12-D12)-H12);"")

Auriez-vous une solution plus élégante sans vba ?

Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Philippe.R
Le #19862571
Bonsoir,
En variante :
=(B12<>"")*(E12*(C12-D12))-SI(ESTERR(E12*(C12-D12)-H12);0;H12)
c'est plus court, mais est ce plus compréhensible ?
--
Avec plaisir
http://dj.joss.free.fr/trombine.htm
http://jacxl.free.fr/mpfe/trombino.html
Philippe.R
Pour se connecter au forum :
http://www.excelabo.net/mpfe/connexion.php
News://news.microsoft.com/microsoft.public.fr.excel
"Jol" news:
Bonjour à tous,

J'ai la formule suivante que je trouve un peu lourde :

=SI(B12<>"";SI(ESTERREUR(E12*(C12-D12)-H12);E12*(C12-D12);E12*(C12-D12)-H12);"")

Auriez-vous une solution plus élégante sans vba ?

Merci



Sam
Le #19862971
Bonjour,
elle est bien en chair mais elle est clair, ça ne servira à pas grand chose
d'essayer de la réduire.

Par contre j'ai un doute sur ta formulation, la soustraction de H12 pourrait
provoquer une erreur ?
Cordialement
Michel dit "Sam"

"Jol"
Bonjour à tous,

J'ai la formule suivante que je trouve un peu lourde :

=SI(B12<>"";SI(ESTERREUR(E12*(C12-D12)-H12);E12*(C12-D12);E12*(C12-D12)-H12);"")

Auriez-vous une solution plus élégante sans vba ?

Merci



Jol
Le #19863161
Bien vu Sam,
C'est G12 à la place de H12.
En effet la formule de Philippe.R pour réduire la voilure mais c'est certain
on ne gagne rien en compréhension.
Dans tous les cas merci les gars.

"Sam" news:4a7334a9$0$12624$


Bonjour,
elle est bien en chair mais elle est clair, ça ne servira à pas grand
chose d'essayer de la réduire.

Par contre j'ai un doute sur ta formulation, la soustraction de H12
pourrait provoquer une erreur ?
Cordialement
Michel dit "Sam"

"Jol"
Bonjour à tous,

J'ai la formule suivante que je trouve un peu lourde :

=SI(B12<>"";SI(ESTERREUR(E12*(C12-D12)-H12);E12*(C12-D12);E12*(C12-D12)-H12);"")

Auriez-vous une solution plus élégante sans vba ?

Merci







sabbog
Le #19863751
Bonjour Jol,

Juste par curiosité, en passant... :)
Quelles types de valeurs peut contenir la cellule G12 ?

Par exemple, si la cellule G12 peut renvoyer une valeur alpha ou une valeur
numérique, et que tu ne veuilles faire bien évidemment la soustraction que
dans le second cas afin d'éviter l'erreur, on pourrait avoir:

=SI(B12<>"";E12*(C12-D12)-N(G12);"")

Mais il faudrait d'avantage de précisions...
:)


ChrisV




"Jol"
Bonjour à tous,

J'ai la formule suivante que je trouve un peu lourde :

=SI(B12<>"";SI(ESTERREUR(E12*(C12-D12)-G12);E12*(C12-D12);E12*(C12-D12)-G12);"")

Auriez-vous une solution plus élégante sans vba ?

Merci



Jol
Le #19867841
Bonjour sabbog,

G12 calcule le montant d'une remise.


"sabbog" news:%
Bonjour Jol,

Juste par curiosité, en passant... :)
Quelles types de valeurs peut contenir la cellule G12 ?

Par exemple, si la cellule G12 peut renvoyer une valeur alpha ou une
valeur numérique, et que tu ne veuilles faire bien évidemment la
soustraction que dans le second cas afin d'éviter l'erreur, on pourrait
avoir:

=SI(B12<>"";E12*(C12-D12)-N(G12);"")

Mais il faudrait d'avantage de précisions...
:)


ChrisV




"Jol"
Bonjour à tous,

J'ai la formule suivante que je trouve un peu lourde :

=SI(B12<>"";SI(ESTERREUR(E12*(C12-D12)-G12);E12*(C12-D12);E12*(C12-D12)-G12);"")

Auriez-vous une solution plus élégante sans vba ?

Merci







Publicité
Poster une réponse
Anonyme