regrouper une liste

Le
marc
Bonjour à vous tous. Voici mon problème
J'ai dans une feuille Excel 25 colonnes d'informations sur 15000 lignes Avec
des données qui se répètent. Voici un exemple.

Col A Col B Col C Col D
Amérique Usa Floride 5
Amérique Usa Floride 10
Amérique Usa Floride 15
Amérique Usa Texas 20
Amérique Usa Texas 20

etc..

J'aimerais avoir la même liste ( pas un tableau comme un tableau croissé
dynamique) mais avec la somme pour les données en colonne C

Voici le résultat

Amérique Usa Floride 30
Amérique Usa Texas 40

etc.

Mon problème (car j'avais fait un tableau croissé dynamique) c'est de ravoir
une liste de ces données. J'ai essayé sous-totaux mais là non-plus le
résultat n'est pas bon.
À moins que j'utilise mal le tableau croissé dynamique.

Merci de votre aide

Marc
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #5175571
Bonsoir,

-La liste des patys est obtenue avec un filtre élaboré sans doublons:
-Le total avec
=SOMMEPROD(($A$2:$A$6=G2)*($B$2:$B$6=H2)*($C$2:$C$6=I2)*$D$2:$D$6)

http://cjoint.com/?devoyOXNSO

JB

On 4 mar, 20:53, "marc"
Bonjour à vous tous. Voici mon problème
J'ai dans une feuille Excel 25 colonnes d'informations sur 15000 lignes Av ec
des données qui se répètent. Voici un exemple.

Col A             Col B                Col C        Col D
Amérique        Usa                   Floride        5
Amérique        Usa                   Floride        10
Amérique        Usa                   Floride        15
Amérique        Usa                   Texas          20
Amérique        Usa                   Texas          20

etc..

J'aimerais avoir la même liste ( pas un tableau comme un tableau croiss é
dynamique) mais avec la somme pour les données en  colonne C

Voici le résultat

Amérique        Usa                    Flori de        30
Amérique        Usa                    Texas          40

etc.

Mon problème (car j'avais fait un tableau croissé dynamique) c'est de ravoir
une liste de ces données. J'ai essayé sous-totaux... mais là non-plu s le
résultat n'est pas bon.
À moins que j'utilise mal le tableau croissé dynamique....

Merci de votre aide

Marc


marc
Le #5175541
Merci Jb
c'est exactement ce que je veux

Bonne fin de journée
Marc
"JB"
Bonsoir,

-La liste des patys est obtenue avec un filtre élaboré sans doublons:
-Le total avec
=SOMMEPROD(($A$2:$A$6=G2)*($B$2:$B$6=H2)*($C$2:$C$6=I2)*$D$2:$D$6)

http://cjoint.com/?devoyOXNSO

JB

On 4 mar, 20:53, "marc"
Bonjour à vous tous. Voici mon problème
J'ai dans une feuille Excel 25 colonnes d'informations sur 15000 lignes
Avec
des données qui se répètent. Voici un exemple.

Col A Col B Col C Col D
Amérique Usa Floride 5
Amérique Usa Floride 10
Amérique Usa Floride 15
Amérique Usa Texas 20
Amérique Usa Texas 20

etc..

J'aimerais avoir la même liste ( pas un tableau comme un tableau croissé
dynamique) mais avec la somme pour les données en colonne C

Voici le résultat

Amérique Usa Floride 30
Amérique Usa Texas 40

etc.

Mon problème (car j'avais fait un tableau croissé dynamique) c'est de
ravoir
une liste de ces données. J'ai essayé sous-totaux... mais là non-plus le
résultat n'est pas bon.
À moins que j'utilise mal le tableau croissé dynamique....

Merci de votre aide

Marc


Publicité
Poster une réponse
Anonyme