remise a vide d'une liste déroulante

Le
Péric
Suite
j'ai un formulaire avec un sous-formulaire qui est filtré par des listes
déroulantes positionnées sur le formulaire. J'ai un bouton qui annule le
filtre mais les choix faits dans mes listes déroulantes y restent
affichés ce qui peut induire en erreur, comment revenir à un affichage
vide? J'ai essayé avec Me.ld.value = " " mais cela génère des erreurs
sans doute parce-que mes champs liés sont de type numérique, quelles
autres solutions y a t il? Merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Eric
Le #6196131
re,

As-tu testé :
Private Sub Commande1_Click() 'Bouton d'annulation du filtre
Me.FilterOn = False
Me.Modifiable12 = Null ' ou 0 si tu l'utilises pas
End Sub

Suite...
j'ai un formulaire avec un sous-formulaire qui est filtré par des listes
déroulantes positionnées sur le formulaire. J'ai un bouton qui annule le
filtre mais les choix faits dans mes listes déroulantes y restent
affichés ce qui peut induire en erreur, comment revenir à un affichage
vide? J'ai essayé avec Me.ld.value = " " mais cela génère des erreurs
sans doute parce-que mes champs liés sont de type numérique, quelles
autres solutions y a t il? Merci


--
A+
Eric
http://www.mpfa.info/
Archives : http://groups.google.fr/group/microsoft.public.fr.access?hl=fr

Péric
Le #6196121
re,

As-tu testé :
Private Sub Commande1_Click() 'Bouton d'annulation du filtre
Me.FilterOn = False
Me.Modifiable12 = Null ' ou 0 si tu l'utilises pas
End Sub

Suite...
j'ai un formulaire avec un sous-formulaire qui est filtré par des
listes déroulantes positionnées sur le formulaire. J'ai un bouton qui
annule le filtre mais les choix faits dans mes listes déroulantes y
restent affichés ce qui peut induire en erreur, comment revenir à un
affichage vide? J'ai essayé avec Me.ld.value = " " mais cela génère
des erreurs sans doute parce-que mes champs liés sont de type
numérique, quelles autres solutions y a t il? Merci


Merci ,jai fini par trouver dans la FAQ je mettais la valeur à 0 alors

qu'il faut la mettre à Null


Publicité
Poster une réponse
Anonyme