Renseignement automatique d'onglet

Le
Xavier
Bonjour à tous,
je cherche une solution pour remplir automatiquement des onglets d'un
classeur sans VBA mais seulement à partir de formules

je m'explique.
dans mon classeur j'ai un onglet "Données" consacré aux données brutes
avec les champs "prenom" "age" "Poids" "taille".

ex:
Xavier 20 70 1m70
sylvie 25 55 1m55
Eric 32 65 1m75
Xavier 45 80 1m74

pour chaque prénom j'ai un onglet spécifique qui doit rapatrier l'age et
la taille (et pas le poids)

Ainsi pour l'onglet xavier je dois retrouver
20 1m70
45 1m74

y a t'il un moyen de rapatrier ces données sans passer par le VBA ?
merci
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Charabeuh
Le #19967831
bonjour,

Essayer cette formule:
---------------------------------------
=INDEX(Données!$B$2:$B$5;EQUIV(DROITE(CELLULE("nomfichier";$A$1);NBCAR(CELLULE("nomfichier";$A$1))-TROUVE("]";CELLULE("nomfichier";$A$1)));Données!$A$2:$A$5;0))
---------------------------------------
où Données!$A$2:$A$5 est la colonne des noms
où Données!$B$2:$B$5 est la colonne des ages.







"Xavier" news:4a8f9f14$0$27770$
Bonjour à tous,
je cherche une solution pour remplir automatiquement des onglets d'un
classeur sans VBA mais seulement à partir de formules

je m'explique.
dans mon classeur j'ai un onglet "Données" consacré aux données brutes
avec les champs "prenom" "age" "Poids" "taille"....

ex:
Xavier 20 70 1m70
sylvie 25 55 1m55
Eric 32 65 1m75
Xavier 45 80 1m74

pour chaque prénom j'ai un onglet spécifique qui doit rapatrier l'age et
la taille (et pas le poids)

Ainsi pour l'onglet xavier je dois retrouver
20 1m70
45 1m74

y a t'il un moyen de rapatrier ces données sans passer par le VBA ?
merci


Corona
Le #19968001
Bonjour Xavier,
Si ta base de données est triées par prénom voici un code qui
fonctionne
La plage de données est nommée 'bd' et la plage des prénoms 'pnPrenoms'
Chaque feuille étant nommée d'un des prénoms
En A1 la formule
'=STXT(CELLULE("filename";B1);CHERCHE("]";CELLULE("filename"))+1;50)
En B1 la formule '=NB.SI(pnPrenoms;Xavier!A1)
Dans la plage A2:Ax la formule
'=SI(LIGNE()-1<=$B$1;INDEX(bd;EQUIV($A$1;pnPrenoms;0)+LIGNE()-1;2);"")
Dans la plage B2:Bx la formule
'=SI(LIGNE()-1<=$B$1;INDEX(bd;EQUIV($A$1;pnPrenoms;0)+LIGNE()-1;4);"")

Fichier exemple sur http://cjoint.com/?iwlpyaKXje

Philippe Tulliez


Xavier a écrit :
Bonjour à tous,
je cherche une solution pour remplir automatiquement des onglets d'un
classeur sans VBA mais seulement à partir de formules

je m'explique.
dans mon classeur j'ai un onglet "Données" consacré aux données brutes
avec les champs "prenom" "age" "Poids" "taille"....

ex:
Xavier 20 70 1m70
sylvie 25 55 1m55
Eric 32 65 1m75
Xavier 45 80 1m74

pour chaque prénom j'ai un onglet spécifique qui doit rapatrier l'age et
la taille (et pas le poids)

Ainsi pour l'onglet xavier je dois retrouver
20 1m70
45 1m74

y a t'il un moyen de rapatrier ces données sans passer par le VBA ?
merci


Corona
Le #19968161
Petite erreur dans les formules sur les feuilles 'Prénoms'
Il faut faire ligne()-2 et non pas -1
donc
Dans la plage A2:Ax la formule
'=SI(LIGNE()-1<=$B$1;INDEX(bd;EQUIV($A$1;pnPrenoms;0)+LIGNE()-2;2);"")
Dans la plage B2:Bx la formule
'=SI(LIGNE()-1<=$B$1;INDEX(bd;EQUIV($A$1;pnPrenoms;0)+LIGNE()-2;4);"")
Bonne journée
Philippe Tulliez

Corona a écrit :
Bonjour Xavier,
Si ta base de données est triées par prénom voici un code qui fonctionne
La plage de données est nommée 'bd' et la plage des prénoms 'pnPrenoms'
Chaque feuille étant nommée d'un des prénoms
En A1 la formule
'=STXT(CELLULE("filename";B1);CHERCHE("]";CELLULE("filename"))+1;50)

En B1 la formule '=NB.SI(pnPrenoms;Xavier!A1)
Dans la plage A2:Ax la formule
'=SI(LIGNE()-1<=$B$1;INDEX(bd;EQUIV($A$1;pnPrenoms;0)+LIGNE()-1;2);"")
Dans la plage B2:Bx la formule
'=SI(LIGNE()-1<=$B$1;INDEX(bd;EQUIV($A$1;pnPrenoms;0)+LIGNE()-1;4);"")

Fichier exemple sur http://cjoint.com/?iwlpyaKXje

Philippe Tulliez


Xavier a écrit :
Bonjour à tous,
je cherche une solution pour remplir automatiquement des onglets d'un
classeur sans VBA mais seulement à partir de formules

je m'explique.
dans mon classeur j'ai un onglet "Données" consacré aux données brutes
avec les champs "prenom" "age" "Poids" "taille"....

ex:
Xavier 20 70 1m70
sylvie 25 55 1m55
Eric 32 65 1m75
Xavier 45 80 1m74

pour chaque prénom j'ai un onglet spécifique qui doit rapatrier l'age
et la taille (et pas le poids)

Ainsi pour l'onglet xavier je dois retrouver
20 1m70
45 1m74

y a t'il un moyen de rapatrier ces données sans passer par le VBA ?
merci




Publicité
Poster une réponse
Anonyme