repérer 2 plages de cellules identiques

Le
Phil
Bonjour,

Je souhaiterais trouver une fonction pour identifier 2 plages de
cellules identiques.

Si la plage A1:A50 est strictement identique à la plage B1:B50, alors C1=1.
Autrement dit :
colonne A = a, b, c, d, e
colonne B = a, b, c, d, e
C1 = 1

Je pourrai obtenir facilement le résultat cherché avec une boucle dans
une macro, mais je suis curieux de savoir si c'est possible avec une
simple fonction.

Merci d'avance pour vos recherches !
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
michdenis
Le #22151381
Bonjour,


toto = Plage nommée : A1:B50
titi = Plage nommée B1:B50

Si le contenu de la plage Toto est égale au contenu de la plage Titi
c'est à dire :
A1 = B1
A2 = B2
A3 = C3
Etc
Tu mets la formule en C1
'Validation matricielle : Maj + Ctrl + Enter
=SI(SOMME((Toto=titi)*1)=LIGNES(Toto);"Pareil";"Pas pareil")



"Phil" discussion : O6b9kkQ#
Bonjour,

Je souhaiterais trouver une fonction pour identifier 2 plages de cellules
identiques.

Si la plage A1:A50 est strictement identique à la plage B1:B50, alors
C1=1.
Autrement dit :
colonne A = a, b, c, d, e...
colonne B = a, b, c, d, e...
C1 = 1

Je pourrai obtenir facilement le résultat cherché avec une boucle dans une
macro, mais je suis curieux de savoir si c'est possible avec une simple
fonction.

Merci d'avance pour vos recherches !
Phil
Le #22151421
Le 21/05/2010 20:56, michdenis a écrit :
Bonjour,


toto = Plage nommée : A1:B50
titi = Plage nommée B1:B50

Si le contenu de la plage Toto est égale au contenu de la plage Titi
c'est à dire :
A1 = B1
A2 = B2
A3 = C3
Etc
Tu mets la formule en C1
'Validation matricielle : Maj + Ctrl + Enter
=SI(SOMME((Toto=titi)*1)=LIGNES(Toto);"Pareil";"Pas pareil")



"Phil" discussion : O6b9kkQ#
Bonjour,

Je souhaiterais trouver une fonction pour identifier 2 plages de
cellules identiques.

Si la plage A1:A50 est strictement identique à la plage B1:B50, alors
C1=1.
Autrement dit :
colonne A = a, b, c, d, e...
colonne B = a, b, c, d, e...
C1 = 1

Je pourrai obtenir facilement le résultat cherché avec une boucle dans
une macro, mais je suis curieux de savoir si c'est possible avec une
simple fonction.

Merci d'avance pour vos recherches !





Excellent !!!
Ta solution et très élégante et me convient parfaitement.
Je te remercie beaucoup !
Publicité
Poster une réponse
Anonyme