Répéter le même calcul dans une formule

Le
JBF
Bonjour à tous,

Est-ce possible de répéter le même type de calcul dans une formule.

Exemple :

A1 : 50 B1 : 100
A2 : 25 B2 : 200

A9 : 30 B9 : 70

Le calcul que je souhaite faire consiste à multiplier colonne A par colonne
B de chaque ligne PUIS d'additionner les résultats. Ce qui revient à faire :

=(A1*B1)+(A2*B2)++(A9*B9)

Il y a t-il une formule pour répéter le même type d'opération de la ligne 1
à la ligne 9?

Dans les faits mon tableau comporte 360 lignes et, pour des questions de
mise en page et autre, je ne peux pas ajouter la moindre colonne.

Merci pour votre aide

JBF
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Caetera
Le #19804741
> Le calcul que je souhaite faire consiste à multiplier colonne A par colonne B
de chaque ligne PUIS d'additionner les résultats. Ce qui revient à faire :

=(A1*B1)+(A2*B2)+...+(A9*B9)



**************
=SOMMEPROD(A1:A9;B1:B9)

Etc
Azo4
Le #19804841
si je comprends bien, tu mets $ (référence absolue) -- ou touche F4-- devant
chaque terme puis tu recopies la formule...

soit = $A$1*$B$1 + ....

--
Serge CENCI
MVP MS Windows Desktop Experience
https://mvp.support.microsoft.com/profile/Serge.Cenci
http://www.communautes-numeriques.net/



"JBF" news:
Bonjour à tous,

Est-ce possible de répéter le même type de calcul dans une formule.

Exemple :

A1 : 50 B1 : 100
A2 : 25 B2 : 200
...
A9 : 30 B9 : 70

Le calcul que je souhaite faire consiste à multiplier colonne A par
colonne B de chaque ligne PUIS d'additionner les résultats. Ce qui revient
à faire :

=(A1*B1)+(A2*B2)+...+(A9*B9)

Il y a t-il une formule pour répéter le même type d'opération de la ligne
1 à la ligne 9?

Dans les faits mon tableau comporte 360 lignes et, pour des questions de
mise en page et autre, je ne peux pas ajouter la moindre colonne.

Merci pour votre aide

JBF



Misange
Le #19805081
Caetera a écrit :

=SOMMEPROD(A1:A9;B1:B9)



et pour une fois sur ce forum, voilà l'illustration de la fonction
primaire de sommeprod : faire la somme des produits.
Plus d'infos ici
http://www.excelabo.net/pasapas/sommeprod1

Misange migrateuse
http://www.excelabo.net : Participez à un travail collaboratif sur excel !
JBF
Le #19805151
Merci à vous deux pour vos réponses.
La bonne solution m'a été donnée par Cætera.

Bonne journée,

JBF


"JBF"
Bonjour à tous,

Est-ce possible de répéter le même type de calcul dans une formule.

Exemple :

A1 : 50 B1 : 100
A2 : 25 B2 : 200
...
A9 : 30 B9 : 70

Le calcul que je souhaite faire consiste à multiplier colonne A par
colonne B de chaque ligne PUIS d'additionner les résultats. Ce qui revient
à faire :

=(A1*B1)+(A2*B2)+...+(A9*B9)

Il y a t-il une formule pour répéter le même type d'opération de la ligne
1 à la ligne 9?

Dans les faits mon tableau comporte 360 lignes et, pour des questions de
mise en page et autre, je ne peux pas ajouter la moindre colonne.

Merci pour votre aide

JBF



garnote
Le #19807141
> et pour une fois sur ce forum, voilà l'illustration de la fonction
primaire de sommeprod : faire la somme des produits.


Ce qui, soit dit en passant, correspond au produit scalaire de deux
vecteurs algébriques a = (a1, a2, a3, ... , an) et
b = (b1, b2, b3, ...,bn).

Serge


"Misange" u$



Caetera a écrit :

=SOMMEPROD(A1:A9;B1:B9)



et pour une fois sur ce forum, voilà l'illustration de la fonction
primaire de sommeprod : faire la somme des produits.
Plus d'infos ici
http://www.excelabo.net/pasapas/sommeprod1

Misange migrateuse
http://www.excelabo.net : Participez à un travail collaboratif sur excel !


JBF
Le #19814021
Bonjour,

Cette formule marche bien sauf dans le cas où toutes les lignes ne sont pas
concernés par la sélection.

=SOMMEPROD(A1:A9;B1:B9)

Si je ne veux pas inclure les lignes 3 et 7 en colonne A et B, la formule ne
marche plus (sauf erreur de ma part).

J'utilise SOMMEPROD. Je maintiens la touche [Ctrl] pour sélectionner les
lignes de mon choix. Ce qui me donne ça :

=SOMMEPROD(A1:A2;A4:A6;A8:A9;B1:B2;B4:B6;B8:B9)

Qq'un aurait une solution?

Merci à tous


"Caetera" eY9%
Le calcul que je souhaite faire consiste à multiplier colonne A par
colonne B de chaque ligne PUIS d'additionner les résultats. Ce qui
revient à faire :

=(A1*B1)+(A2*B2)+...+(A9*B9)



**************
=SOMMEPROD(A1:A9;B1:B9)

Etc



isabelle
Le #19814161
bonjour Jbf,

=SOMMEPROD((A1:A2)*(B1:B2))+SOMMEPROD((A4:A6)*(B4:B6))+SOMMEPROD((A8:A9)*(B8:B9))

isabelle

JBF a écrit :
Bonjour,

Cette formule marche bien sauf dans le cas où toutes les lignes ne sont pas
concernés par la sélection.

=SOMMEPROD(A1:A9;B1:B9)

Si je ne veux pas inclure les lignes 3 et 7 en colonne A et B, la formule ne
marche plus (sauf erreur de ma part).

J'utilise SOMMEPROD. Je maintiens la touche [Ctrl] pour sélectionner les
lignes de mon choix. Ce qui me donne ça :

=SOMMEPROD(A1:A2;A4:A6;A8:A9;B1:B2;B4:B6;B8:B9)

Qq'un aurait une solution?

Merci à tous


"Caetera" eY9%

Le calcul que je souhaite faire consiste à multiplier colonne A par
colonne B de chaque ligne PUIS d'additionner les résultats. Ce qui
revient à faire :

=(A1*B1)+(A2*B2)+...+(A9*B9)



**************
=SOMMEPROD(A1:A9;B1:B9)

Etc









JBF
Le #19814661
merci.
je vais essayer ça.

JBF

"isabelle" a écrit dans le message de news:

bonjour Jbf,

=SOMMEPROD((A1:A2)*(B1:B2))+SOMMEPROD((A4:A6)*(B4:B6))+SOMMEPROD((A8:A9)*(B8:B9))

isabelle

JBF a écrit :
Bonjour,

Cette formule marche bien sauf dans le cas où toutes les lignes ne sont
pas concernés par la sélection.

=SOMMEPROD(A1:A9;B1:B9)

Si je ne veux pas inclure les lignes 3 et 7 en colonne A et B, la formule
ne marche plus (sauf erreur de ma part).

J'utilise SOMMEPROD. Je maintiens la touche [Ctrl] pour sélectionner les
lignes de mon choix. Ce qui me donne ça :

=SOMMEPROD(A1:A2;A4:A6;A8:A9;B1:B2;B4:B6;B8:B9)

Qq'un aurait une solution?

Merci à tous


"Caetera" eY9%

Le calcul que je souhaite faire consiste à multiplier colonne A par
colonne B de chaque ligne PUIS d'additionner les résultats. Ce qui
revient à faire :

=(A1*B1)+(A2*B2)+...+(A9*B9)



**************
=SOMMEPROD(A1:A9;B1:B9)

Etc











JBF
Le #19823951
bonjour,

Cette formule marche, mais j'aimerais "compliquer" un peu les choses.

Est-il possible de faire ce calcul uniquement si en colonne C (C1:C9) il y a
la mention "GO"?

Merci bcp

JBF


"isabelle" a écrit dans le message de news:

bonjour Jbf,

=SOMMEPROD((A1:A2)*(B1:B2))+SOMMEPROD((A4:A6)*(B4:B6))+SOMMEPROD((A8:A9)*(B8:B9))

isabelle

JBF a écrit :
Bonjour,

Cette formule marche bien sauf dans le cas où toutes les lignes ne sont
pas concernés par la sélection.

=SOMMEPROD(A1:A9;B1:B9)

Si je ne veux pas inclure les lignes 3 et 7 en colonne A et B, la formule
ne marche plus (sauf erreur de ma part).

J'utilise SOMMEPROD. Je maintiens la touche [Ctrl] pour sélectionner les
lignes de mon choix. Ce qui me donne ça :

=SOMMEPROD(A1:A2;A4:A6;A8:A9;B1:B2;B4:B6;B8:B9)

Qq'un aurait une solution?

Merci à tous


"Caetera" eY9%

Le calcul que je souhaite faire consiste à multiplier colonne A par
colonne B de chaque ligne PUIS d'additionner les résultats. Ce qui
revient à faire :

=(A1*B1)+(A2*B2)+...+(A9*B9)



**************
=SOMMEPROD(A1:A9;B1:B9)

Etc











JBF
Le #19824061
oups je tâtonnais mais je n'y arrivais pas. C'est désormais chose faite, il
suffisait de faire:

=SOMMEPROD(C1:C9="GO")*(A1:A9)*(B1:B9))

Merci


"isabelle" a écrit dans le message de news:

bonjour Jbf,

=SOMMEPROD((A1:A2)*(B1:B2))+SOMMEPROD((A4:A6)*(B4:B6))+SOMMEPROD((A8:A9)*(B8:B9))

isabelle

JBF a écrit :
Bonjour,

Cette formule marche bien sauf dans le cas où toutes les lignes ne sont
pas concernés par la sélection.

=SOMMEPROD(A1:A9;B1:B9)

Si je ne veux pas inclure les lignes 3 et 7 en colonne A et B, la formule
ne marche plus (sauf erreur de ma part).

J'utilise SOMMEPROD. Je maintiens la touche [Ctrl] pour sélectionner les
lignes de mon choix. Ce qui me donne ça :

=SOMMEPROD(A1:A2;A4:A6;A8:A9;B1:B2;B4:B6;B8:B9)

Qq'un aurait une solution?

Merci à tous


"Caetera" eY9%

Le calcul que je souhaite faire consiste à multiplier colonne A par
colonne B de chaque ligne PUIS d'additionner les résultats. Ce qui
revient à faire :

=(A1*B1)+(A2*B2)+...+(A9*B9)



**************
=SOMMEPROD(A1:A9;B1:B9)

Etc











Publicité
Poster une réponse
Anonyme