Réplication de fusion sur SQL 2005

Le
rabacagale
J'ai une réplication de fusion sur SQL 2000 qui fonctionne correctement. Je
fais la même chose sur SQL 2005, la réplication fonctionne mais j'ai des
lenteurs lorsque je fais des insertions dans la base. Si je désactive la
réplication les insertions sont instantanées. Si je la réactive les
insertions mettent 2 à 3 secondes.
Sous 2000 je n'avais aucun soucis d'insertion.
Y a t il un parametrage à réaliser pour ne pas avoir ces lenteurs à
l'insertion?
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
bruno reiter
Le #19413551
lance une trace, peut etre un problème avec les triggers de la répli

BR

"rabacagale" news:
J'ai une réplication de fusion sur SQL 2000 qui fonctionne correctement.
Je
fais la même chose sur SQL 2005, la réplication fonctionne mais j'ai des
lenteurs lorsque je fais des insertions dans la base. Si je désactive la
réplication les insertions sont instantanées. Si je la réactive les
insertions mettent 2 à 3 secondes.
Sous 2000 je n'avais aucun soucis d'insertion.
Y a t il un parametrage à réaliser pour ne pas avoir ces lenteurs à
l'insertion?


rabacagale
Le #19461181
J'ai lancé une trace avec la réplication de fusion active et une trace avec
la réplication de fusion désactivée. La seule différence c'est le temps
d'exécution des insert et update. Je ne vois rien d'autre.

"bruno reiter" a écrit :

lance une trace, peut etre un problème avec les triggers de la répli

BR

"rabacagale" news:
> J'ai une réplication de fusion sur SQL 2000 qui fonctionne correctement.
> Je
> fais la même chose sur SQL 2005, la réplication fonctionne mais j'ai des
> lenteurs lorsque je fais des insertions dans la base. Si je désactive la
> réplication les insertions sont instantanées. Si je la réactive les
> insertions mettent 2 à 3 secondes.
> Sous 2000 je n'avais aucun soucis d'insertion.
> Y a t il un parametrage à réaliser pour ne pas avoir ces lenteurs à
> l'insertion?




rabacagale
Le #19461171
J'ai lancé une trace avec la réplication de fusion active et une trace avec
la réplication de fusion désactivée. La seule différence c'est le temps
d'exécution des insert et update. Je ne vois rien d'autre.

"bruno reiter" a écrit :

lance une trace, peut etre un problème avec les triggers de la répli

BR

"rabacagale" news:
> J'ai une réplication de fusion sur SQL 2000 qui fonctionne correctement.
> Je
> fais la même chose sur SQL 2005, la réplication fonctionne mais j'ai des
> lenteurs lorsque je fais des insertions dans la base. Si je désactive la
> réplication les insertions sont instantanées. Si je la réactive les
> insertions mettent 2 à 3 secondes.
> Sous 2000 je n'avais aucun soucis d'insertion.
> Y a t il un parametrage à réaliser pour ne pas avoir ces lenteurs à
> l'insertion?




WOLO Laurent
Le #19565571
Utiliser le profiler et le plan d'éxecution pour déterminer la cause de la
lenteur !
"rabacagale" de news:
J'ai une réplication de fusion sur SQL 2000 qui fonctionne correctement.
Je
fais la même chose sur SQL 2005, la réplication fonctionne mais j'ai des
lenteurs lorsque je fais des insertions dans la base. Si je désactive la
réplication les insertions sont instantanées. Si je la réactive les
insertions mettent 2 à 3 secondes.
Sous 2000 je n'avais aucun soucis d'insertion.
Y a t il un parametrage à réaliser pour ne pas avoir ces lenteurs à
l'insertion?


Publicité
Poster une réponse
Anonyme