Requête après fermeture formulaire

Le
JV
Bonjour,

J'ai un formulaire de saisie de données.
Je souhaite exécuter une requête une fois ce formulaire fermé (et non pas à
la fermeture de ce formulaire) car la requête travaillera avec la même table
que le formulaire.
Comment faire ? En VBA ? Par une macro ?

Merci d'avance.

JV
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fabien
Le #11160611
JV wrote:
Bonjour,

J'ai un formulaire de saisie de données.
Je souhaite exécuter une requête une fois ce formulaire fermé (et non pas à
la fermeture de ce formulaire) car la requête travaillera avec la même table
que le formulaire.
Comment faire ? En VBA ? Par une macro ?

Merci d'avance.

JV




Bonjour,
Le plus facile c'est un docmd.openquery "Nom de la requete" sur
l'évenement On_close du formulaire.
@+
JV
Le #11161361
Merci Fabien, mais cela ne marche pas.
J'ai un message "La table XXX est déjà ouverte en mode exclusif ou par un
autre utilisateur..."
La requête travaille avec la mêmetable XXX que le formulaire.

"Fabien"
JV wrote:
> Bonjour,
>
> J'ai un formulaire de saisie de données.
> Je souhaite exécuter une requête une fois ce formulaire fermé (et non


pas à
> la fermeture de ce formulaire) car la requête travaillera avec la même


table
> que le formulaire.
> Comment faire ? En VBA ? Par une macro ?
>
> Merci d'avance.
>
> JV
>
>
Bonjour,
Le plus facile c'est un docmd.openquery "Nom de la requete" sur
l'évenement On_close du formulaire.
@+



Fabien
Le #11161861
JV wrote:
Merci Fabien, mais cela ne marche pas.
J'ai un message "La table XXX est déjà ouverte en mode exclusif ou par un
autre utilisateur..."
La requête travaille avec la mêmetable XXX que le formulaire.

"Fabien"
JV wrote:
Bonjour,

J'ai un formulaire de saisie de données.
Je souhaite exécuter une requête une fois ce formulaire fermé (et non




pas à
la fermeture de ce formulaire) car la requête travaillera avec la même




table
que le formulaire.
Comment faire ? En VBA ? Par une macro ?

Merci d'avance.

JV




Bonjour,
Le plus facile c'est un docmd.openquery "Nom de la requete" sur
l'évenement On_close du formulaire.
@+







Au vu de ton post précédent(Travail a deux sur une même table), as tu
controlé les options de mode d'ouverture de ta base?
JV
Le #11164301
Oui, j'ai vérifié.
Le mode d'ouverture est bien le mode partagé.

JV


"Fabien" #tI$
JV wrote:
> Merci Fabien, mais cela ne marche pas.
> J'ai un message "La table XXX est déjà ouverte en mode exclusif ou par


un
> autre utilisateur..."
> La requête travaille avec la mêmetable XXX que le formulaire.
>
> "Fabien" >
>> JV wrote:
>>> Bonjour,
>>>
>>> J'ai un formulaire de saisie de données.
>>> Je souhaite exécuter une requête une fois ce formulaire fermé (et non
> pas à
>>> la fermeture de ce formulaire) car la requête travaillera avec la même
> table
>>> que le formulaire.
>>> Comment faire ? En VBA ? Par une macro ?
>>>
>>> Merci d'avance.
>>>
>>> JV
>>>
>>>
>> Bonjour,
>> Le plus facile c'est un docmd.openquery "Nom de la requete" sur
>> l'évenement On_close du formulaire.
>> @+
>>
>
>
Au vu de ton post précédent(Travail a deux sur une même table), as tu
controlé les options de mode d'ouverture de ta base?



JV
Le #11164781
Re-bonjour,
Ce post est indépendant du post précédent.
En effet, je fais des essais, chez moi, pour trouver une solution de
secours.
Et ce que j'ai décrit dans mon message initial ci-dessous est ce que je
constate sur mon ordinateur personnel qui n'est pas en réseau.

JV

"Fabien" #tI$
JV wrote:
> Merci Fabien, mais cela ne marche pas.
> J'ai un message "La table XXX est déjà ouverte en mode exclusif ou par


un
> autre utilisateur..."
> La requête travaille avec la mêmetable XXX que le formulaire.
>
> "Fabien" >
>> JV wrote:
>>> Bonjour,
>>>
>>> J'ai un formulaire de saisie de données.
>>> Je souhaite exécuter une requête une fois ce formulaire fermé (et non
> pas à
>>> la fermeture de ce formulaire) car la requête travaillera avec la même
> table
>>> que le formulaire.
>>> Comment faire ? En VBA ? Par une macro ?
>>>
>>> Merci d'avance.
>>>
>>> JV
>>>
>>>
>> Bonjour,
>> Le plus facile c'est un docmd.openquery "Nom de la requete" sur
>> l'évenement On_close du formulaire.
>> @+
>>
>
>
Au vu de ton post précédent(Travail a deux sur une même table), as tu
controlé les options de mode d'ouverture de ta base?



Fabien
Le #11167781
JV wrote:
Re-bonjour,
Ce post est indépendant du post précédent.
En effet, je fais des essais, chez moi, pour trouver une solution de
secours.
Et ce que j'ai décrit dans mon message initial ci-dessous est ce que je
constate sur mon ordinateur personnel qui n'est pas en réseau.

JV

"Fabien" #tI$
JV wrote:
Merci Fabien, mais cela ne marche pas.
J'ai un message "La table XXX est déjà ouverte en mode exclusif ou par




un
autre utilisateur..."
La requête travaille avec la mêmetable XXX que le formulaire.

"Fabien"
JV wrote:
Bonjour,

J'ai un formulaire de saisie de données.
Je souhaite exécuter une requête une fois ce formulaire fermé (et non




pas à
la fermeture de ce formulaire) car la requête travaillera avec la même




table
que le formulaire.
Comment faire ? En VBA ? Par une macro ?

Merci d'avance.

JV




Bonjour,
Le plus facile c'est un docmd.openquery "Nom de la requete" sur
l'évenement On_close du formulaire.
@+






Au vu de ton post précédent(Travail a deux sur une même table), as tu
controlé les options de mode d'ouverture de ta base?







Bonjour,
Tu travail sur la même base que celle qui te pose probléme en reseau ?
As tu (on ne sait jamais) essayé d'ouvrir une nouvelle base et d'y
importer les éléments de l'ancienne ?
Es tu a jour de Services pack ?
Tu as jeter un oeuil sur
http://groups.google.fr/group/microsoft.public.fr.access/search?group=microsoft.public.fr.access&q=ouverte+en+mode+exclusif&qt_g=Rechercher+dans+ce+groupe
C'est des questions c... mais ... ;-)
@+
JV
Le #11173811
Oui, c'est la même base (ou plutôt sur les 2 mêmes bases car les tables sont
dans une base séparée) que celles qui me posent problème en réseau.

Non, je ne dois pas être à jour de Services pack.
Je vais regarder.

Merci pour tes réponses.

Bonjour,
Tu travail sur la même base que celle qui te pose probléme en reseau ?
As tu (on ne sait jamais) essayé d'ouvrir une nouvelle base et d'y
importer les éléments de l'ancienne ?
Es tu a jour de Services pack ?
Tu as jeter un oeuil sur



http://groups.google.fr/group/microsoft.public.fr.access/search?group=micros
oft.public.fr.access&q=ouverte+en+mode+exclusif&qt_g=Rechercher+dans+ce+grou
pe
C'est des questions c... mais ... ;-)
@+


Publicité
Poster une réponse
Anonyme