requete odbc access 2010

Le
P3859
bonjour

Je rencontre un petit pb dans le cadre de l'utilisation d'une requête vers une base Mysql.

J'ai installé le driver ODBC
J'ai créé ma base
j'ai lié ma base Mysql avec ma base Access 2010

jusque la tout va bien

j'ai tenté quelques requêtes mono table/multitable en avec l'assistant. je les ai modifiées avec l'interface graphique pas de pb.

par contre, si je bascule en mode SQL et que je modifie le contenu, Access me redemande de me connecter au lien odbc à chaque fois !!!!!

Merci de vos réponses et de vos conseils
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Gloops
Le #24080761
P3859 a écrit, le 17/12/2011 13:15 :
bonjour

Je rencontre un petit pb dans le cadre de l'utilisation d'une requête
vers une base Mysql.

J'ai installé le driver ODBC
J'ai créé ma base
j'ai lié ma base Mysql avec ma base Access 2010

jusque la tout va bien

j'ai tenté quelques requêtes mono table/multitable en avec l'assist ant.
je les ai modifiées avec l'interface graphique ...pas de pb.

par contre, si je bascule en mode SQL et que je modifie le contenu,
Access me redemande de me connecter au lien odbc à chaque fois !!!!!

Merci de vos réponses et de vos conseils



Bonjour,

En mode édition, avec l'assistant, ça baigne, et c'est en mode SQL qu e
ça coince ?

Quelle est la requête tapée ?
Ou ça coince dès le premier caractère modifié ? A priori, j'imagi ne
plutôt que c'est à la validation, non ?
C'est pour ça que ça serait intéressant de savoir ce qu'on cherche à
valider.
P3859
Le #24081211
Le 17/12/2011 15:58, Gloops a écrit :
P3859 a écrit, le 17/12/2011 13:15 :
bonjour

Je rencontre un petit pb dans le cadre de l'utilisation d'une requête
vers une base Mysql.

J'ai installé le driver ODBC
J'ai créé ma base
j'ai lié ma base Mysql avec ma base Access 2010

jusque la tout va bien

j'ai tenté quelques requêtes mono table/multitable en avec l'assistant.
je les ai modifiées avec l'interface graphique ...pas de pb.

par contre, si je bascule en mode SQL et que je modifie le contenu,
Access me redemande de me connecter au lien odbc à chaque fois !!!!!

Merci de vos réponses et de vos conseils



Bonjour,

En mode édition, avec l'assistant, ça baigne, et c'est en mode SQL que ça coince ?

Quelle est la requête tapée ?
Ou ça coince dès le premier caractère modifié ? A priori, j'imagine plutôt que c'est à la validation, non ?
C'est pour ça que ça serait intéressant de savoir ce qu'on cherche à valider.





bsr,

non, ce n'est pas la requête en elle même qui coince. Il n'y a pas de message d'erreur. Mais Access ouvre la fenêtre
d'administration d'obdec pour que je resélectionne ma source. Une fois ceci fait, le clic sur le bouton [ok] lance la requête est
Access me renvoit le résultat escompté
Gloops
Le #24084581
P3859 a écrit, le 17/12/2011 17:28 :
Le 17/12/2011 15:58, Gloops a écrit :
P3859 a écrit, le 17/12/2011 13:15 :
bonjour

Je rencontre un petit pb dans le cadre de l'utilisation d'une requê te
vers une base Mysql.

J'ai installé le driver ODBC
J'ai créé ma base
j'ai lié ma base Mysql avec ma base Access 2010

jusque la tout va bien

j'ai tenté quelques requêtes mono table/multitable en avec l'assi stant.
je les ai modifiées avec l'interface graphique ...pas de pb.

par contre, si je bascule en mode SQL et que je modifie le contenu,
Access me redemande de me connecter au lien odbc à chaque fois !!!! !

Merci de vos réponses et de vos conseils



Bonjour,

En mode édition, avec l'assistant, ça baigne, et c'est en mode SQL que
ça coince ?

Quelle est la requête tapée ?
Ou ça coince dès le premier caractère modifié ? A priori, j'im agine
plutôt que c'est à la validation, non ?
C'est pour ça que ça serait intéressant de savoir ce qu'on cherc he à
valider.





bsr,

non, ce n'est pas la requête en elle même qui coince. Il n'y a pas de
message d'erreur. Mais Access ouvre la fenêtre d'administration d'obd ec
pour que je resélectionne ma source. Une fois ceci fait, le clic sur le
bouton [ok] lance la requête est Access me renvoit le résultat esco mpté



Ah, ben c'est ça, qu'il fallait dire ...

Et donc les données sont désignées via des tables liées ?

Tiens, ça ne me rappelle rien ...
Access dit quoi, comme source de la table liée ?


Euh, c'est vrai que quand j'ai utilisé MySql, c'était depuis C#, donc ce
n'est pas forcément la meilleure comparaison.

Là je n'ai pas Access à la maison, et en général quand j'ai Acces s au
bureau il n'y a pas MySql avec.

Cela étant, souvent, ça ne m'empêche pas de poser les bonnes questi ons.
P3859
Le #24088541
Le 18/12/2011 15:59, Gloops a écrit :
P3859 a écrit, le 17/12/2011 17:28 :
Le 17/12/2011 15:58, Gloops a écrit :
P3859 a écrit, le 17/12/2011 13:15 :
bonjour

Je rencontre un petit pb dans le cadre de l'utilisation d'une requête
vers une base Mysql.

J'ai installé le driver ODBC
J'ai créé ma base
j'ai lié ma base Mysql avec ma base Access 2010

jusque la tout va bien

j'ai tenté quelques requêtes mono table/multitable en avec l'assistant.
je les ai modifiées avec l'interface graphique ...pas de pb.

par contre, si je bascule en mode SQL et que je modifie le contenu,
Access me redemande de me connecter au lien odbc à chaque fois !!!!!

Merci de vos réponses et de vos conseils



Bonjour,

En mode édition, avec l'assistant, ça baigne, et c'est en mode SQL que
ça coince ?

Quelle est la requête tapée ?
Ou ça coince dès le premier caractère modifié ? A priori, j'imagine
plutôt que c'est à la validation, non ?
C'est pour ça que ça serait intéressant de savoir ce qu'on cherche à
valider.





bsr,

non, ce n'est pas la requête en elle même qui coince. Il n'y a pas de
message d'erreur. Mais Access ouvre la fenêtre d'administration d'obdec
pour que je resélectionne ma source. Une fois ceci fait, le clic sur le
bouton [ok] lance la requête est Access me renvoit le résultat escompté



Ah, ben c'est ça, qu'il fallait dire ...

Et donc les données sont désignées via des tables liées ?

Tiens, ça ne me rappelle rien ...
Access dit quoi, comme source de la table liée ?


Euh, c'est vrai que quand j'ai utilisé MySql, c'était depuis C#, donc ce n'est pas forcément la meilleure comparaison.

Là je n'ai pas Access à la maison, et en général quand j'ai Access au bureau il n'y a pas MySql avec.

Cela étant, souvent, ça ne m'empêche pas de poser les bonnes questions.





juste pour infos

SELECT glpi_computers.name, glpi_computers.FK_users

FROM glpi_computers

WHERE (((glpi_computers.FK_users)=(SELECT glpi_users.ID

FROM glpi_users where name like"S9990531")));


et lorsque je lance la requête : ouverture de la fenetre "Sélectionner la source de données"
Gloops
Le #24090471
P3859 a écrit, le 19/12/2011 13:57 :
Le 18/12/2011 15:59, Gloops a écrit :
P3859 a écrit, le 17/12/2011 17:28 :
Le 17/12/2011 15:58, Gloops a écrit :
P3859 a écrit, le 17/12/2011 13:15 :
bonjour

Je rencontre un petit pb dans le cadre de l'utilisation d'une requê te
vers une base Mysql.

J'ai installé le driver ODBC
J'ai créé ma base
j'ai lié ma base Mysql avec ma base Access 2010

jusque la tout va bien

j'ai tenté quelques requêtes mono table/multitable en avec
l'assistant.
je les ai modifiées avec l'interface graphique ...pas de pb.

par contre, si je bascule en mode SQL et que je modifie le contenu,
Access me redemande de me connecter au lien odbc à chaque fois !! !!!

Merci de vos réponses et de vos conseils



Bonjour,

En mode édition, avec l'assistant, ça baigne, et c'est en mode S QL que
ça coince ?

Quelle est la requête tapée ?
Ou ça coince dès le premier caractère modifié ? A priori, j' imagine
plutôt que c'est à la validation, non ?
C'est pour ça que ça serait intéressant de savoir ce qu'on che rche à
valider.





bsr,

non, ce n'est pas la requête en elle même qui coince. Il n'y a pa s de
message d'erreur. Mais Access ouvre la fenêtre d'administration d'o bdec
pour que je resélectionne ma source. Une fois ceci fait, le clic su r le
bouton [ok] lance la requête est Access me renvoit le résultat es compté



Ah, ben c'est ça, qu'il fallait dire ...

Et donc les données sont désignées via des tables liées ?

Tiens, ça ne me rappelle rien ...
Access dit quoi, comme source de la table liée ?


Euh, c'est vrai que quand j'ai utilisé MySql, c'était depuis C#, d onc
ce n'est pas forcément la meilleure comparaison.

Là je n'ai pas Access à la maison, et en général quand j'ai Ac cess au
bureau il n'y a pas MySql avec.

Cela étant, souvent, ça ne m'empêche pas de poser les bonnes que stions.





juste pour infos

SELECT glpi_computers.name, glpi_computers.FK_users

FROM glpi_computers

WHERE (((glpi_computers.FK_users)=(SELECT glpi_users.ID

FROM glpi_users where name like"S9990531")));


et lorsque je lance la requête : ouverture de la fenetre "Sélection ner
la source de données"





Mais, euh ... Tu en es satisfait, de tes parenthèses ?
Gloops
Le #24090461
Gloops a écrit, le 20/12/2011 05:07 :
P3859 a écrit, le 19/12/2011 13:57 :
Le 18/12/2011 15:59, Gloops a écrit :
P3859 a écrit, le 17/12/2011 17:28 :
Le 17/12/2011 15:58, Gloops a écrit :
P3859 a écrit, le 17/12/2011 13:15 :
bonjour

Je rencontre un petit pb dans le cadre de l'utilisation d'une requ ête
vers une base Mysql.

J'ai installé le driver ODBC
J'ai créé ma base
j'ai lié ma base Mysql avec ma base Access 2010

jusque la tout va bien

j'ai tenté quelques requêtes mono table/multitable en avec
l'assistant.
je les ai modifiées avec l'interface graphique ...pas de pb.

par contre, si je bascule en mode SQL et que je modifie le contenu ,
Access me redemande de me connecter au lien odbc à chaque fois ! !!!!

Merci de vos réponses et de vos conseils



Bonjour,

En mode édition, avec l'assistant, ça baigne, et c'est en mode SQL que
ça coince ?

Quelle est la requête tapée ?
Ou ça coince dès le premier caractère modifié ? A priori, j 'imagine
plutôt que c'est à la validation, non ?
C'est pour ça que ça serait intéressant de savoir ce qu'on ch erche à
valider.





bsr,

non, ce n'est pas la requête en elle même qui coince. Il n'y a p as de
message d'erreur. Mais Access ouvre la fenêtre d'administration d' obdec
pour que je resélectionne ma source. Une fois ceci fait, le clic s ur le
bouton [ok] lance la requête est Access me renvoit le résultat e scompté



Ah, ben c'est ça, qu'il fallait dire ...

Et donc les données sont désignées via des tables liées ?

Tiens, ça ne me rappelle rien ...
Access dit quoi, comme source de la table liée ?


Euh, c'est vrai que quand j'ai utilisé MySql, c'était depuis C#, donc
ce n'est pas forcément la meilleure comparaison.

Là je n'ai pas Access à la maison, et en général quand j'ai A ccess au
bureau il n'y a pas MySql avec.

Cela étant, souvent, ça ne m'empêche pas de poser les bonnes qu estions.





juste pour infos

SELECT glpi_computers.name, glpi_computers.FK_users

FROM glpi_computers

WHERE (((glpi_computers.FK_users)=(SELECT glpi_users.ID

FROM glpi_users where name like"S9990531")));


et lorsque je lance la requête : ouverture de la fenetre "Sélectio nner
la source de données"





Mais, euh ... Tu en es satisfait, de tes parenthèses ?





Ah mais je n'avais pas percuté tout de suite ...
Les requêtes imbriquées, sous Oracle ou SQL Server ça marche, si ç a
marche sous Access c'est récent.
Essaie en remplaçant la requête imbriquée par une requête enregis trée,
pour voir ...
P3859
Le #24091351
Le 20/12/2011 05:10, Gloops a écrit :
Gloops a écrit, le 20/12/2011 05:07 :
P3859 a écrit, le 19/12/2011 13:57 :
Le 18/12/2011 15:59, Gloops a écrit :
P3859 a écrit, le 17/12/2011 17:28 :
Le 17/12/2011 15:58, Gloops a écrit :
P3859 a écrit, le 17/12/2011 13:15 :
bonjour

Je rencontre un petit pb dans le cadre de l'utilisation d'une requête
vers une base Mysql.

J'ai installé le driver ODBC
J'ai créé ma base
j'ai lié ma base Mysql avec ma base Access 2010

jusque la tout va bien

j'ai tenté quelques requêtes mono table/multitable en avec
l'assistant.
je les ai modifiées avec l'interface graphique ...pas de pb.

par contre, si je bascule en mode SQL et que je modifie le contenu,
Access me redemande de me connecter au lien odbc à chaque fois !!!!!

Merci de vos réponses et de vos conseils



Bonjour,

En mode édition, avec l'assistant, ça baigne, et c'est en mode SQL que
ça coince ?

Quelle est la requête tapée ?
Ou ça coince dès le premier caractère modifié ? A priori, j'imagine
plutôt que c'est à la validation, non ?
C'est pour ça que ça serait intéressant de savoir ce qu'on cherche à
valider.





bsr,

non, ce n'est pas la requête en elle même qui coince. Il n'y a pas de
message d'erreur. Mais Access ouvre la fenêtre d'administration d'obdec
pour que je resélectionne ma source. Une fois ceci fait, le clic sur le
bouton [ok] lance la requête est Access me renvoit le résultat escompté



Ah, ben c'est ça, qu'il fallait dire ...

Et donc les données sont désignées via des tables liées ?

Tiens, ça ne me rappelle rien ...
Access dit quoi, comme source de la table liée ?


Euh, c'est vrai que quand j'ai utilisé MySql, c'était depuis C#, donc
ce n'est pas forcément la meilleure comparaison.

Là je n'ai pas Access à la maison, et en général quand j'ai Access au
bureau il n'y a pas MySql avec.

Cela étant, souvent, ça ne m'empêche pas de poser les bonnes questions.





juste pour infos

SELECT glpi_computers.name, glpi_computers.FK_users

FROM glpi_computers

WHERE (((glpi_computers.FK_users)=(SELECT glpi_users.ID

FROM glpi_users where name like"S9990531")));


et lorsque je lance la requête : ouverture de la fenetre "Sélectionner
la source de données"





Mais, euh ... Tu en es satisfait, de tes parenthèses ?





Ah mais je n'avais pas percuté tout de suite ...
Les requêtes imbriquées, sous Oracle ou SQL Server ça marche, si ça marche sous Access c'est récent.
Essaie en remplaçant la requête imbriquée par une requête enregistrée, pour voir ...





SELECT glpi_computers.name, glpi_computers.FK_users
FROM glpi_computers
WHERE (((glpi_computers.FK_users)=(SELECT glpi_users.ID
FROM glpi_users where name like"S9990531")));


Est ce que cela veut dire :

1) création de la requete cherche_user

SELECT glpi_users.ID
FROM glpi_users where name like"S9990531";

puis

2) création de la requête cherche ordinateurs_user

SELECT glpi_computers.name, glpi_computers.FK_users
FROM glpi_computers
WHERE (((glpi_computers.FK_users)= .... la je sais pas quoi mettre

et j'ai pas trouvé sur le net.


PS En effet,ta remarque sur Oracle et et SQL Server sont logique puisque l'on travail (mais pas moi) surtout avec ces SGBD. Donc la
personne qui m'a aidé ....
db
Le #24091471
Le 19/12/2011 13:57, P3859 a écrit :
Le 18/12/2011 15:59, Gloops a écrit :

juste pour infos

SELECT glpi_computers.name, glpi_computers.FK_users

FROM glpi_computers

WHERE (((glpi_computers.FK_users)=(SELECT glpi_users.ID

FROM glpi_users where name like"S9990531")));




Et en transformant la requête imbriquée ne jointure :

SELECT glpi_computers.name, glpi_computers.FK_users
FROM glpi_computers
INNER JOIN glpi_users on glpi_users.ID=glpi_computers.FK_users
WHERE name = "S9990531"
?

db
Gloops
Le #24091801
P3859 a écrit, le 20/12/2011 12:10 :
Le 20/12/2011 05:10, Gloops a écrit :
Gloops a écrit, le 20/12/2011 05:07 :
P3859 a écrit, le 19/12/2011 13:57 :
Le 18/12/2011 15:59, Gloops a écrit :
P3859 a écrit, le 17/12/2011 17:28 :
Le 17/12/2011 15:58, Gloops a écrit :
P3859 a écrit, le 17/12/2011 13:15 :
bonjour

Je rencontre un petit pb dans le cadre de l'utilisation d'une
requête
vers une base Mysql.

J'ai installé le driver ODBC
J'ai créé ma base
j'ai lié ma base Mysql avec ma base Access 2010

jusque la tout va bien

j'ai tenté quelques requêtes mono table/multitable en avec
l'assistant.
je les ai modifiées avec l'interface graphique ...pas de pb.

par contre, si je bascule en mode SQL et que je modifie le conte nu,
Access me redemande de me connecter au lien odbc à chaque fois
!!!!!

Merci de vos réponses et de vos conseils



Bonjour,

En mode édition, avec l'assistant, ça baigne, et c'est en mod e
SQL que
ça coince ?

Quelle est la requête tapée ?
Ou ça coince dès le premier caractère modifié ? A priori, j'imagine
plutôt que c'est à la validation, non ?
C'est pour ça que ça serait intéressant de savoir ce qu'on cherche à
valider.





bsr,

non, ce n'est pas la requête en elle même qui coince. Il n'y a pas de
message d'erreur. Mais Access ouvre la fenêtre d'administration
d'obdec
pour que je resélectionne ma source. Une fois ceci fait, le clic
sur le
bouton [ok] lance la requête est Access me renvoit le résultat
escompté



Ah, ben c'est ça, qu'il fallait dire ...

Et donc les données sont désignées via des tables liées ?

Tiens, ça ne me rappelle rien ...
Access dit quoi, comme source de la table liée ?


Euh, c'est vrai que quand j'ai utilisé MySql, c'était depuis C# , donc
ce n'est pas forcément la meilleure comparaison.

Là je n'ai pas Access à la maison, et en général quand j'ai Access au
bureau il n'y a pas MySql avec.

Cela étant, souvent, ça ne m'empêche pas de poser les bonnes
questions.





juste pour infos

SELECT glpi_computers.name, glpi_computers.FK_users

FROM glpi_computers

WHERE (((glpi_computers.FK_users)=(SELECT glpi_users.ID

FROM glpi_users where name like"S9990531")));


et lorsque je lance la requête : ouverture de la fenetre "Sélect ionner
la source de données"





Mais, euh ... Tu en es satisfait, de tes parenthèses ?





Ah mais je n'avais pas percuté tout de suite ...
Les requêtes imbriquées, sous Oracle ou SQL Server ça marche, si ça
marche sous Access c'est récent.
Essaie en remplaçant la requête imbriquée par une requête enre gistrée,
pour voir ...





SELECT glpi_computers.name, glpi_computers.FK_users
FROM glpi_computers
WHERE (((glpi_computers.FK_users)=(SELECT glpi_users.ID
FROM glpi_users where name like"S9990531")));


Est ce que cela veut dire :

1) création de la requete cherche_user

SELECT glpi_users.ID
FROM glpi_users where name like"S9990531";

puis

2) création de la requête cherche ordinateurs_user

SELECT glpi_computers.name, glpi_computers.FK_users
FROM glpi_computers
WHERE (((glpi_computers.FK_users)= .... la je sais pas quoi mettre

et j'ai pas trouvé sur le net.


PS En effet,ta remarque sur Oracle et et SQL Server sont logique puisqu e
l'on travail (mais pas moi) surtout avec ces SGBD. Donc la personne qui
m'a aidé ....



Ah, je me suis fendu d'une réponse, et voilà que aioe me la censure . ..
Ce qui tombe bien, c'est que celle de db m'a l'air bien plus opérationn elle.
P3859
Le #24092151
Le 20/12/2011 12:54, db a écrit :
Le 19/12/2011 13:57, P3859 a écrit :
Le 18/12/2011 15:59, Gloops a écrit :



juste pour infos

SELECT glpi_computers.name, glpi_computers.FK_users

FROM glpi_computers

WHERE (((glpi_computers.FK_users)=(SELECT glpi_users.ID

FROM glpi_users where name like"S9990531")));




Et en transformant la requête imbriquée ne jointure :

SELECT glpi_computers.name, glpi_computers.FK_users
FROM glpi_computers
INNER JOIN glpi_users on glpi_users.ID=glpi_computers.FK_users
WHERE name = "S9990531"
?

db





merci pour l'idée, mais même chose avec la requête fournie ...j'ai du modifier

WHERE name = "S9990531"


en WHERE glpi_users.name = "S9990531"


sinon il y avait une erreur de syntaxe
Publicité
Poster une réponse
Anonyme