réseau devenu invisible !

Le
docanski
Bonsoir la foule ! (enfin c'est pas vraiment le cas :-) )

Curieux résultat de mes différents essais de paramétrage pour faire
fonctionner mon relais Wifi : mon portable ne reconnaît plus ni le modem
ni le relais mis en place pour répéter son signal !
Il "voit" le signal d'autres modems du voisinage mais ne voit pas le
mien, même lorsque ce portable est placé à 50 cm !
Pourtant, les autres PC de la maison détectent sans problème le réseau
Wifi et s'y connectent.
Le pare-feu du SE est et a toujours été désactivé et il ne pourrait donc
pas bloquer ce signal si tant est qu'il pourrait d'ailleurs le faire.
Dans la configuration du portable, rien de suspect et je suis d'ailleurs
allé jusqu'à la vider entièrement des adresses des réseaux favoris,
qu'ils soient automatiques ou manuels.
Bref, je ne peux plus utiliser mon portable avec mon propre réseau.
C'est dingue !
Une idée ? une piste ?

Cordialement,
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
François
Le #20897011
docanski a écrit :

Une idée ? une piste ?



Changer de canal, peut-être ?

Les canaux 1 à 9 sont interdits pour les liaisons à l'extérieur (source
: doc de la livebox).

Chez moi, les canaux 12,13 et 14 ne sont pas reconnus par ma Debian
Squeeze, j'ignore pourquoi. Le 10 est pourri, probablement par
l'aéroport d'à côté. Il me reste le 11.

--
François
docanski
Le #20897291
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
François ecrit ce qui suit en ce 04/01/2010 23:27 :

Changer de canal, peut-être ?



Le canal 1 me pourrissait la vie : déconnexions fréquentes
Les canaux 4, 6 et 10 sont utilisés par des voisins et un choix trop
proche de ceux-ci serait, d'après ce que j'ai lu ici et là, risque
d'affaiblissement du signal ou de perturbations. J'ai donc choisi le 13.

Chez moi, les canaux 12,13 et 14 ne sont pas reconnus par ma Debian



J'espère que ce n'est pas le cas avec la Lenny car j'ai tenté une
installation ce soir et elle me refuse la configuration automatique.
Elle reconnaît pourtant le chipset Wifi mais ne voit pas l'ESSID. Même
tapée à la main, la config aboutit à un fiasco. :-(

Il serait quand même étrange que mon portable ne soit pas capable de
lire un canal 13, lui non plus : il fonctionne sous XP.

Cordialement,
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
Bruno Tréguier
Le #20898951
Le 05/01/2010 à 0:41, docanski a écrit :

Le canal 1 me pourrissait la vie : déconnexions fréquentes
Les canaux 4, 6 et 10 sont utilisés par des voisins et un choix trop
proche de ceux-ci serait, d'après ce que j'ai lu ici et là, risque
d'affaiblissement du signal ou de perturbations. J'ai donc choisi le 13.

Chez moi, les canaux 12,13 et 14 ne sont pas reconnus par ma Debian



J'espère que ce n'est pas le cas avec la Lenny car j'ai tenté une
installation ce soir et elle me refuse la configuration automatique.
Elle reconnaît pourtant le chipset Wifi mais ne voit pas l'ESSID. Même
tapée à la main, la config aboutit à un fiasco. :-(



Bonjour,

Je ne pense pas que le canal soit bridé par votre version de Linux. A ce
niveau, s'il existe une limitation, c'est plutôt au chipset qu'il faut
l'attribuer...


Il serait quand même étrange que mon portable ne soit pas capable de
lire un canal 13, lui non plus : il fonctionne sous XP.



CQFD. ;-)

Si vos appareils (ou vos adaptateurs WiFi) ont été achetés aux
Etats-Unis ou au Canada (ou plus généralement, hors d'Europe), il y a de
grandes chances qu'ils n'autorisent que les canaux 1 à 11. Certains
appareils peuvent être "débridés" (un peu à la manière du dézonage des
lecteurs de DVD), mais pas tous... Cela pourrait-il être la cause de
votre souci ? Faites le test sur un canal entre 1 et 11 (même si ça
marche mal chez vous), vous serez fixé...

Sous Linux, vous avez la possibilité de voir les canaux reconnus par
votre carte en faisant un:

iwlist wlan0 channel

("wlan0" à adapter au nom réel de votre interface réseau WiFi, que vous
obtiendrez par un simple iwconfig).

Cordialement,

Bruno
Bruno Tréguier
Le #20898941
Le 05/01/2010 à 7:39, Bruno Tréguier a écrit :

Je ne pense pas que le canal soit bridé par votre version de Linux. A ce
niveau, s'il existe une limitation, c'est plutôt au chipset qu'il faut
l'attribuer...



Pardon, lire "firmware" et non "chipset". ;-)

Cordialement,

Bruno
François
Le #20901451
Bruno Tréguier a écrit :


iwlist wlan0 channel



wlan0 11 channels in total; available frequencies :
Channel 01 : 2.412 GHz
Channel 02 : 2.417 GHz
Channel 03 : 2.422 GHz
Channel 04 : 2.427 GHz
Channel 05 : 2.432 GHz
Channel 06 : 2.437 GHz
Channel 07 : 2.442 GHz
Channel 08 : 2.447 GHz
Channel 09 : 2.452 GHz
Channel 10 : 2.457 GHz
Channel 11 : 2.462 GHz
Current Frequency:2.462 GHz (Channel 11)
-----------------------------------------------------

iw list :

Wiphy phy0
Band 1:
Frequencies:
* 2412 MHz [1] (27.0 dBm)
* 2417 MHz [2] (27.0 dBm)
* 2422 MHz [3] (27.0 dBm)
* 2427 MHz [4] (27.0 dBm)
* 2432 MHz [5] (27.0 dBm)
* 2437 MHz [6] (27.0 dBm)
* 2442 MHz [7] (27.0 dBm)
* 2447 MHz [8] (27.0 dBm)
* 2452 MHz [9] (27.0 dBm)
* 2457 MHz [10] (27.0 dBm)
* 2462 MHz [11] (27.0 dBm)
* 2467 MHz [12] (disabled)
* 2472 MHz [13] (disabled)
* 2484 MHz [14] (disabled)
* 2512 MHz [-498] (disabled)
* 2532 MHz [-494] (disabled)
* 2552 MHz [-490] (disabled)
* 2572 MHz [-486] (disabled)
* 2592 MHz [-482] (disabled)
* 2612 MHz [-478] (disabled)
* 2632 MHz [-474] (disabled)
* 2652 MHz [-470] (disabled)
* 2672 MHz [-466] (disabled)
* 2692 MHz [-462] (disabled)
* 2712 MHz [-458] (disabled)
* 2732 MHz [-454] (disabled)
Bitrates:
* 1.0 Mbps
* 2.0 Mbps (short preamble supported)
* 5.5 Mbps (short preamble supported)
* 11.0 Mbps (short preamble supported)
* 6.0 Mbps
* 9.0 Mbps
* 12.0 Mbps
* 18.0 Mbps
* 24.0 Mbps
* 36.0 Mbps
* 48.0 Mbps
* 54.0 Mbps
max # scan SSIDs: 4
Supported interface modes:
* IBSS
* managed
* monitor
* mesh point
---------------------------------------------------

Ça passe sous XP avec le canal 12, avec la même machine et avec un autre
portable, ainsi qu'avec un Palm, que ce soit directement avec la
Livebox ou par l'intermédiaire de la borne.

--
François
Bruno Tréguier
Le #20901881
François wrote:

Ça passe sous XP avec le canal 12, avec la même machine et avec un autre
portable, ainsi qu'avec un Palm, que ce soit directement avec la
Livebox ou par l'intermédiaire de la borne.



Ok, vu, au temps pour moi. Il y a effectivement eu, dans les toutes
dernières versions du noyau Linux (à partir de la 2.6.30) un changement
majeur dans la gestion du "regulatory domain" des cartes WiFi.

Tout est expliqué là: http://wireless.kernel.org/en/developers/Regulatory

L'ancien mécanisme peut encore être employé si
CONFIG_WIRELESS_OLD_REGULATORY est mis à "y" dans la config noyau, mais
par défaut il est à "n" désormais, mais du coup les nouvelles
distributions Linux doivent être mises à jour pour permettre la
sélection du pays. Ce n'est peut-être pas encore le cas de Debian Squeeze.

Du coup, selon les marques et versions des interfaces WiFi, il se peut
que le pays par défaut soit erroné.

On peut a priori le forcer via "iw" ou "wpa_supplicant" (à partir du
noyau 2.6.28):

iw reg set FR

Mais c'est perdu au reboot sauf erreur.

Sur mon portable, un "iw reg get" ramène un "country 00", donc je
suppose qu'il n'est pas forcé à quoi que ce soit par la distrib (Kubuntu
Karmic), mais ça fonctionne.

Vous pouvez tester un "iw reg set FR" pour voir ?

Cordialement,

Bruno
docanski
Le #20902081
Alors que les eleveurs et agriculteurs polluent toujours la Bretagne,
Bruno Tréguier ecrit ce qui suit en ce 05/01/2010 07:39 :

Bonjour,



Bonjour,

Je ne pense pas que le canal soit bridé par votre version de Linux. A ce
niveau, s'il existe une limitation, c'est plutôt au chipset qu'il faut
l'attribuer...



Au niveau du firmware (selon ta rectification), il n'y a aucune raison
pour qu'une Lenny 5.0.3 ne puisse pas "voir" le signal car il est
parfaitement visible sous Ouine installé sur une autre partition de la
même machine.

Il serait quand même étrange que mon portable ne soit pas capable de
lire un canal 13, lui non plus : il fonctionne sous XP.





Il s'agit évidemment de 2 machines différentes : la première est une
station de travail qui a toujours "vu" ce signal, la seconde (le
portable) le voyait ... jusqu'au jour où le modem a été configuré pour
émettre sur le canal 13.
Coïncidence ou pas ? Là est la question. Le portable est un MSI U-Wind100.

Si vos appareils (ou vos adaptateurs WiFi) ont été achetés aux
Etats-Unis ou au Canada (ou plus généralement, hors d'Europe), il y a de
grandes chances qu'ils n'autorisent que les canaux 1 à 11.



Ce n'est pas le cas : tant le relais que le modem et les adaptateurs
Wifi ont été achetés en France.

Cordialement,



Tout autant,
--
docanski

Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
Bruno Tréguier
Le #20902201
Rebonjour,

docanski wrote:

Au niveau du firmware (selon ta rectification), il n'y a aucune raison
pour qu'une Lenny 5.0.3 ne puisse pas "voir" le signal car il est
parfaitement visible sous Ouine installé sur une autre partition de la
même machine.



Ok, dans ce cas, voir mon post suivant, car il y a eu récemment un
changement dans la gestion du WiFi au niveau du noyau Linux, et
contrairement à ce que je disais, il existe effectivement des
limitations (contournables) pouvant être dues à une absence de
configuration du domaine réglementaire de la carte.


Si vos appareils (ou vos adaptateurs WiFi) ont été achetés aux
Etats-Unis ou au Canada (ou plus généralement, hors d'Europe), il y a
de grandes chances qu'ils n'autorisent que les canaux 1 à 11.



Ce n'est pas le cas : tant le relais que le modem et les adaptateurs
Wifi ont été achetés en France.



En revanche, la carte est peut être configurée par défaut pour la zone
US, mais le driver Windows la reconfigure, alors que le driver Linux ne
le fait pas par défaut...

Si vous avez la possibilité, sur votre Lenny, de tester la commande dont
je parlais dans mon précédent post: "iw reg set FR", je serais intéressé
par le résultat...

Cordialement,

Bruno
François
Le #20904291
Bruno Tréguier a écrit :


Vous pouvez tester un "iw reg set FR" pour voir ?




Fait. Ensuite de quoi iw reg get me répond :
country US:

Et les canaux 12 à 14 sont toujours désactivés.

--
François
Bruno Tréguier
Le #20904571
Le 05/01/2010 à 20:59, François a écrit :
Bruno Tréguier a écrit :


Vous pouvez tester un "iw reg set FR" pour voir ?




Fait. Ensuite de quoi iw reg get me répond :
country US:

Et les canaux 12 à 14 sont toujours désactivés.



Grmbl. :-/

Pouvez-vous me dire quelle est votre version de noyau ? Si c'est une
Squeeze, c'est vraisemblablement 2.6.31, mais je voudrais être sûr que
vous n'avez pas un noyau antédiluvien. ;-)

Egalement: quelle est la carte WiFi en question, et le driver utilisé ?

Cordialement,

Bruno
Publicité
Poster une réponse
Anonyme