Réseau mode bridge

Le
testeur
Bonjour,
Pour pouvoir connecter des machines virtuelles sous VirtualBox, je réalise
un bridge entre ma carte réseau réelle et la carte VirtualBox interface 1,
ce qui donne une pseudo carte Pont réseau.
Mon réseau est connecté derrière un modem routeur Adsl Netgear.qui fait
office de DHCP.
Si je laisse les options "Obtenir une adresse IP automatiquement" pour le
pont, aucune adresse n'est atribuée au pont, et celui ci prend l'adresse
automatique 169.254.X.Y, et bien sûr rien ne marche.
Si je force un adresse dans le domaine du routeur (192.168..X;Y) , la
connexion du pont s'établie, et toutes les machines virtuelles, avec
Visrtualbox ou VPC ont bien acces à Internet.
Par contre ma machine réelle, elle n'a plus acces à Internet, ni au réseau
local 192.168.X.Y.

J'ai vérifié toutes les règles du firewall (Internet sécurity 2007) et l'ai
même désactivé, mais sans succes.
Je ne comprend pas pourquoi les machines virtuelles ont acces à Internet, et
plus la machine réelle.

Système Windows XP pro SP3.

Si quelqu'un a une explication ou mieux une solution, je suis preneur.
Merci d'avance.

Olivier.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fabrice [MVP]
Le #16758371
"testeur" news:
Bonjour,
Pour pouvoir connecter des machines virtuelles sous VirtualBox, je réalise
un bridge entre ma carte réseau réelle et la carte VirtualBox interface 1,
ce qui donne une pseudo carte Pont réseau.
Mon réseau est connecté derrière un modem routeur Adsl Netgear.qui fait
office de DHCP.
Si je laisse les options "Obtenir une adresse IP automatiquement" pour le
pont, aucune adresse n'est atribuée au pont, et celui ci prend l'adresse
automatique 169.254.X.Y, et bien sûr rien ne marche.
Si je force un adresse dans le domaine du routeur (192.168..X;Y) , la
connexion du pont s'établie, et toutes les machines virtuelles, avec
Visrtualbox ou VPC ont bien acces à Internet.
Par contre ma machine réelle, elle n'a plus acces à Internet, ni au réseau
local 192.168.X.Y.

J'ai vérifié toutes les règles du firewall (Internet sécurity 2007) et
l'ai même désactivé, mais sans succes.
Je ne comprend pas pourquoi les machines virtuelles ont acces à Internet,
et plus la machine réelle.

Système Windows XP pro SP3.

Si quelqu'un a une explication ou mieux une solution, je suis preneur.
Merci d'avance.

Olivier.





Bonjour,

Avec virtual PC, nul besoin de créer des ponts, il suffit de dire que la VM
à une carte réseau c'est tout, le serveur DHCP fait le reste ou la
configuration manuel des IP dans la VM comme si c'était un vrais PC.

Les ponts c'est pour lier différents réseau, dans votre cas il s'agit d'un
même réseau, donc il ne faut pas créer de pont !

--
Fabrice
Microsoft MVP
http://www.fab3d.fr.st
Faq Windows XP :
http://a.vouillon.online.fr/faq-winxp.htm
testeur
Le #16758871
Bonsoir,
Oui je sais cela pour Virtual PC : aucun problème, le réseau fonctionne
bien.
Mon problème de pont est pour Virtualbox 2.0, qui a une gestion réseau plus
lourde que Virtual PC, et si l'on veut avoir a la fois acces au résau local
et a Internet il faut faire un bridge entre la carte réelle et la carte
générée.
Malheureusement, je ne sais pas si c'est un bug de XP-SP3, mais le mode
bridge chez moi fais que la machine réelle n'a plus acces à Internet (même
en l'absence de machines virtuelles).
Par contre dans ce mode les machines virtuelles ont bien accès à la fois au
réseau local et Internet.
Cest assez paradoxal, et ce qui confirme que les paramètres réseau sont à
priori bon.

Je sèche !

Olivier
Publicité
Poster une réponse
Anonyme