[Resolu] Was: Connexion OpenMoko et perte du resolv.conf

Le
Kevin Hinault
Le 4 décembre 2009 14:59, Kevin Hinault <hinault@gmail.com> a écrit :
> 2009/12/4 François TOURDE <fra-duf-no-spam@tourde.org>:
>> Perso, mon interface était usb0, et il n'y avait pas de

Et bien en fait le problème venait de usb0 ! L'utilisation de eth1
créer ce problème mais pas usb0. Voilà ma conf dans le
/etc/network/interfaces qui fonctionne plutôt bien :
# freerunner SHR
auto usb0
allow-hotplug usb0
iface usb0 inet static
address 192.168.0.200
netmask 255.255.255.0
up iptables -A POSTROUTING -t nat -s 192.168.0.0/24 -j MASQUERADE
up echo 1 > /proc/sys/net/ipv4/ip_forward
down iptables -D POSTROUTING -t nat -s 192.168.0.0/24 -j MASQUERADE
down echo 0 > /proc/sys/net/ipv4/ip_forward

J'aurais bien aimé comprendre comment Debian attribue usb ou eth aux
interfaces. C'est suite à une réinstallation que j'ai réglé ce
problème

--
Kévin

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Yo machine
Le #21019541
Bonjour à tous et tous mes vœux de liberté logicielle à la liste.

Pardonnez mon titre peu standard, je tente de garder le sourire devant
mon noyau qui refuse de démarrer.

Ce matin, sans crier gare mon système ne veut plus partir et m'affiche
ostensiblement ce message

ext2-fs: sda1: couldn't mount because of unsupported opional feature (4)
no filesystem could mount root, tried : ext2 vfat iso9660
Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown
block (8,1)

Et plus rien.

Ça n'est pas la première fois, sauf que précédemment il repartait à la
deuxième.

Le noyau est un 2.6.18 fait main, qui jusqu'à présent ne présentait
aucun problème.

Et voici la ligne du fstab

/dev/sda1 / ext3 defaults,errors=remount-ro 0
1

Les recherches faites sur le net oriente mes recherches vers e2fsck,
j'ai lu aussi qu'il fallait faire un démontage propre, sans que je ne
comprenne comment faire.

Pour info, les problèmes ont commencé lorsque j'ai (vainement) essayer
de mettre à jour le drivers nvidia, comme quoi le mieux est l'ennemi du
bien.

Auriez vous une piste.

Bonne journée à tous.

P'tit Louis

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Yo machine
Le #21022831
Je me réponds parce que je me parle aussi,

Suite à ce mail, nouvelle tentative et ça marche !!

Dois-je m'inquiéter d'un disque dur qui commencerait à rendre l'âme ?!

P'tit Louis


Ce matin, sans crier gare mon système ne veut plus partir et m'affiche
ostensiblement ce message

ext2-fs: sda1: couldn't mount because of unsupported opional feature (4)
no filesystem could mount root, tried : ext2 vfat iso9660
Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown
block (8,1)

Et plus rien.




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Yo machine
Le #21023401
Le jeudi 21 janvier 2010 à 18:50 +0100, patrick a écrit :
Yo!
Bon tout d'abord ça ne se fait pas de "voler le fil de quelqu'un
d'autre" même résolu. Passons...


J'ai fait ça ?! Mince alors, vraiment désolé.

Donc: rouvres un fil avec ta question.

Enfin:
1. démarre avec un live-cd (disons un ubuntu)
2. n'installes rien sur ton disque dur,
3. une fois dans l'interface graphique d'ubuntu ouvres un terminal,
montes si nécessaire ton disque dur et fais un #fsck.ext2 -f /dev/sda1
pour vérifier.

Enfin (2) tiens nous au courant



Merci, je vais.

P.


P'tit Louis

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Sébastien NOBILI
Le #21023591
Salut,

Le jeudi 21 janvier 10 à 20:01, Yo machine a écrit :
| Le jeudi 21 janvier 2010 à 18:50 +0100, patrick a écrit :

[...]

| > 1. démarre avec un live-cd (disons un ubuntu)
| > 2. n'installes rien sur ton disque dur,
| > 3. une fois dans l'interface graphique d'ubuntu ouvres un terminal,
| > montes si nécessaire ton disque dur et fais un #fsck.ext2 -f /dev/sda1
| > pour vérifier.

Tu peux aussi utiliser badblocks. Par défaut il fait un test de lecture,
mais il propose également un test de lecture / écriture non-destructive
(option -n).

Seb

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme