Résultat du Formatage conditionnel

Le
Patrick
Bonjour,

Dans un classeur Excel 2003, toutes les cellules de ma feuille sont dotées
d'un formatage conditionnel du genre :

=SI(ET(NON(ESTVIDE($K60));$P60=Status4);VRAI;FAUX)
alors la couleur de fond est grisée et la police de caractères est barrée.

Je dois copier en VBA, seulement certaines colonnes de cette feuille dans un
autre classeur en préservant le résultat de la mise en forme des cellules
copiées.

La difficulté, c'est que le formatage conditionnel n'est plus en mesure de
restituer le bon résultat dans le mesure où les colonnes sont décalées, voire
inexistantes.

En résumé, comment puis-je en VBA, récupérer le résultat du formatage
conditionnel d'une cellule ?

Merci d'avance

Cordialement,
Patrick
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel.C
Le #18857171
Bonsoir.
Oui, en testant par macro pour chaque cellule le résultat des formules
employées dans la MFC.
Cordialement.
Daniel

Bonjour,

Dans un classeur Excel 2003, toutes les cellules de ma feuille sont dotées
d'un formatage conditionnel du genre :

=SI(ET(NON(ESTVIDE($K60));$P60=Status4);VRAI;FAUX)
alors la couleur de fond est grisée et la police de caractères est barrée.

Je dois copier en VBA, seulement certaines colonnes de cette feuille dans un
autre classeur en préservant le résultat de la mise en forme des cellules
copiées.

La difficulté, c'est que le formatage conditionnel n'est plus en mesure de
restituer le bon résultat dans le mesure où les colonnes sont décalées, voire
inexistantes.

En résumé, comment puis-je en VBA, récupérer le résultat du formatage
conditionnel d'une cellule ?

Merci d'avance

Cordialement,
Patrick


Patrick
Le #18863581
Bonsoir,

Dois-je me résoudre à coder en VBA les formules de MFC ?
N'existe t'il pas une autre façon de faire plus facile à maintenir ?

Cordialement,
Patrick


"Daniel.C" a écrit :

Bonsoir.
Oui, en testant par macro pour chaque cellule le résultat des formules
employées dans la MFC.
Cordialement.
Daniel

> Bonjour,
>
> Dans un classeur Excel 2003, toutes les cellules de ma feuille sont dotées
> d'un formatage conditionnel du genre :
>
> =SI(ET(NON(ESTVIDE($K60));$P60=Status4);VRAI;FAUX)
> alors la couleur de fond est grisée et la police de caractères est barrée.
>
> Je dois copier en VBA, seulement certaines colonnes de cette feuille dans un
> autre classeur en préservant le résultat de la mise en forme des cellules
> copiées.
>
> La difficulté, c'est que le formatage conditionnel n'est plus en mesure de
> restituer le bon résultat dans le mesure où les colonnes sont décalées, voire
> inexistantes.
>
> En résumé, comment puis-je en VBA, récupérer le résultat du formatage
> conditionnel d'une cellule ?
>
> Merci d'avance
>
> Cordialement,
> Patrick





Daniel.C
Le #18865101
Non.
Mais ce n'est pas hyper simple.
Dans une macro, pour chaque colonne à transposer, pour chaque cellule,
il faut récupérer les 3 conditions possibles, donc les 3 formules
potentielles, évaluer la formule, et si la condition est remplie,
récupérer, les paramètres de formatage conditionnels et les appliquer
en tant que simple format.
Daniel

Bonsoir,

Dois-je me résoudre à coder en VBA les formules de MFC ?
N'existe t'il pas une autre façon de faire plus facile à maintenir ?

Cordialement,
Patrick


"Daniel.C" a écrit :

Bonsoir.
Oui, en testant par macro pour chaque cellule le résultat des formules
employées dans la MFC.
Cordialement.
Daniel

Bonjour,

Dans un classeur Excel 2003, toutes les cellules de ma feuille sont dotées
d'un formatage conditionnel du genre :

=SI(ET(NON(ESTVIDE($K60));$P60=Status4);VRAI;FAUX)
alors la couleur de fond est grisée et la police de caractères est barrée.

Je dois copier en VBA, seulement certaines colonnes de cette feuille dans
un autre classeur en préservant le résultat de la mise en forme des
cellules copiées.

La difficulté, c'est que le formatage conditionnel n'est plus en mesure de
restituer le bon résultat dans le mesure où les colonnes sont décalées,
voire inexistantes.

En résumé, comment puis-je en VBA, récupérer le résultat du formatage
conditionnel d'une cellule ?

Merci d'avance

Cordialement,
Patrick









Publicité
Poster une réponse
Anonyme