RIS : Problème intégration drivers à une imaga riprep

Le
David Pujol
Bonjour à tous,

Sur un windows 2003 Server j'ai mis en place le RIS pour déployer mes
postes XP Pro.
J'ai créé une image basé CD d'un XP SP1, puis j'ai déployé cette
image sur un pc DELL, et intégré quelques softs et mises à jour.
A partir de là j'ai générer mon image RIPREP sans soucis.

J'aimerais maintenant utilisé cette image RIPREP pour d'autres postes
en intégrant les drivers manquants (réseau, son,vga, chipset).
Pour cela, en suivant les nombreux sujets sur internet et les KB
microsoft (
http://support.microsoft.com/?scid=...8&y=16) , j'ai
rajouté l'arborescence $oem$$1Driversvga (+son+network) au même
niveau que le dossier i386 de l'image RIPREP. J'ai ensuite modifié le
fichier riprep.sif de la sorte :

OemPreinstall = yes
DriverSigningPolicy = Ignore
OemFilesPath=..$oem$
OemPnpDriversPath =
Driverschipset;Driversmodem;Driversetwork;Driversson;Driversvga;=
Driverswifi

Mon image RIPREP descend bien mais les drivers ne sont ni copiés à la
racine, ni installés.

J'ai alors dupliqué l'arborescence $oem$ et modifié de la même
manière le fichier ristndrd.sif correspondant à l'image basé CD (ou
image Flat).

De même, mon image RIPREP décend bien mais les drivers ne sont ni
copiés à la racine, ni installés.

En revanche, si je lance une descente de l'image basé CD cette fois,
l'arborescence "Drivers" est bien copié à la racine de C: et
presques tous les drivers sont déployés !!

Que me manque t'il pour que mes images RIPREP intègrent des drivers
additionnels au même titre que mon image basé cd ??

Merci de votre précieuse aide, je ne sais plus où chercher et ça
m'embête de me limiter aux images basées cd !!

Cordialement.
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Thierry DEMAN [MVP]
Le #678700
Bonsoir,

après avoir descendu l'image, puis avoir ajouté les drivers supplémentaires,
vous pouvez créer une nouvelle image avec RIPREP qui contiendra tous les
nouveaux drivers!

A bientôt,
--
Thierry DEMAN-BARCELÒ
MVP Exchange, SQL/Server
MCSE2003+M+S,MCSE+I,MCDBA,MCTS,MCITP
http://base.faqexchange.info http://www.faqexchange.info
"David Pujol" news:
Bonjour à tous,

Sur un windows 2003 Server j'ai mis en place le RIS pour déployer mes
postes XP Pro.
J'ai créé une image basé CD d'un XP SP1, puis j'ai déployé cette
image sur un pc DELL, et intégré quelques softs et mises à jour.
A partir de là j'ai générer mon image RIPREP sans soucis.

J'aimerais maintenant utilisé cette image RIPREP pour d'autres postes
en intégrant les drivers manquants (réseau, son,vga, chipset...).
Pour cela, en suivant les nombreux sujets sur internet et les KB
microsoft (
http://support.microsoft.com/?scid=...4078&x&y) , j'ai
rajouté l'arborescence $oem$$1Driversvga (+son+network...) au même
niveau que le dossier i386 de l'image RIPREP. J'ai ensuite modifié le
fichier riprep.sif de la sorte :

OemPreinstall = yes
DriverSigningPolicy = Ignore
OemFilesPath=..$oem$
OemPnpDriversPath Driverschipset;Driversmodem;Driversnetwork;Driversson;Driversvga;Driverswifi

Mon image RIPREP descend bien mais les drivers ne sont ni copiés à la
racine, ni installés.

J'ai alors dupliqué l'arborescence $oem$ et modifié de la même
manière le fichier ristndrd.sif correspondant à l'image basé CD (ou
image Flat).

De même, mon image RIPREP décend bien mais les drivers ne sont ni
copiés à la racine, ni installés.

En revanche, si je lance une descente de l'image basé CD cette fois,
l'arborescence "Drivers" est bien copié à la racine de C: et
presques tous les drivers sont déployés !!

Que me manque t'il pour que mes images RIPREP intègrent des drivers
additionnels au même titre que mon image basé cd ??

Merci de votre précieuse aide, je ne sais plus où chercher... et ça
m'embête de me limiter aux images basées cd !!

Cordialement.
David Pujol
Le #678697
N'est-il pas possible de rajouter des drivers manuellement qui
s'intègreraient à mon image RIPREP ??!

J'ai bien pensé à votre solution mais mon parc de machine étant
plutot hétérogène, cela m'impose de refaire un riprep à chaque
nouvelle machine reçu nécessitant un nouveau driver!
Pas très pratique... Je perds du coup tout l'intérêt d'utiliser
riprep qui est sensé passer outre les différences de matériels.

Ma méthode d'intégration des drivers est-elle correcte?


après avoir descendu l'image, puis avoir ajouté les drivers supplém entaires,
vous pouvez créer une nouvelle image avec RIPREP qui contiendra tous les
nouveaux drivers!


David Pujol
Le #677885
Après quelques nouveaux tests, même problème avec le SP2.
Je peux intégrer les drivers à mon image cd sans souci, mais je ne
peux pas en rajouter dans mon image RIPREP après sa création.

Même en rajoutant de nouveaux drivers dans
RemoteInstallSetupFrenchImagesWINDOWS_XP_RIPREPi386Mirror1UserData Drivers
, ils ne sont pas déployés sur mes nouvelles machines (ils sont
copiés mais pas installés). Pourtant le "DevicePath" du registre est
ok, et si je fais une recherche automatique des pilotes via le
gestionnaire de périphérique, ils sont immédiatement trouvés.

J'en déduis que la descente d'une image RIPREP sur un poste différent
de celui qui a servi à sa création n'entraine pas de recherche et
d'installation de nouveaux drivers.

Au vue de l'hétérogénéité de mon parc, je vais me contenter
d'image CD contenant tous mes drivers et quelques options spécifiques
modifiable dans le ristndrd.sif ... Dommage!

Citation KB Microsoft : "Si l'image est déjà créée et que vous
voulez ajouter des pilotes Plug-and-Play OEM, Microsoft vous recommande
d'utiliser le service RIS pour télécharger l'image sur un ordinateur,
de suivre la procédure décrite à la section "Images Riprep" de cet
article(qui consiste à rajouter les drivers avant de faire un riprep),
puis de réinstaller l'image sur le serveur RIS. "

Merci!
Scorpio92
Le #683827
Bonjour

Moi, j'ai un souci avec Riprep, lorsque je le lance, il me défile des
message d'erreur, comme quoi je ne peux pas copier des fichiers car "access
denied", je comprends pas.
Pour votre souci, j'ai aussi un parc d'environ 15 types de machines
différentes (portables et desktop) et j'utilise Sysprep. J'ai réussi ) faire
2 images. 1 pour les desktop et 1 pour portable .
Je vous conseil cet outils, et vous pourrez ajouter tout les drivers que
vous voudrez apres la 1ere image créé.
bonne journée.
Guy



Après quelques nouveaux tests, même problème avec le SP2.
Je peux intégrer les drivers à mon image cd sans souci, mais je ne
peux pas en rajouter dans mon image RIPREP après sa création.

Même en rajoutant de nouveaux drivers dans
RemoteInstallSetupFrenchImagesWINDOWS_XP_RIPREPi386Mirror1UserDataDrivers
, ils ne sont pas déployés sur mes nouvelles machines (ils sont
copiés mais pas installés). Pourtant le "DevicePath" du registre est
ok, et si je fais une recherche automatique des pilotes via le
gestionnaire de périphérique, ils sont immédiatement trouvés.

J'en déduis que la descente d'une image RIPREP sur un poste différent
de celui qui a servi à sa création n'entraine pas de recherche et
d'installation de nouveaux drivers.

Au vue de l'hétérogénéité de mon parc, je vais me contenter
d'image CD contenant tous mes drivers et quelques options spécifiques
modifiable dans le ristndrd.sif ... Dommage!

Citation KB Microsoft : "Si l'image est déjà créée et que vous
voulez ajouter des pilotes Plug-and-Play OEM, Microsoft vous recommande
d'utiliser le service RIS pour télécharger l'image sur un ordinateur,
de suivre la procédure décrite à la section "Images Riprep" de cet
article(qui consiste à rajouter les drivers avant de faire un riprep),
puis de réinstaller l'image sur le serveur RIS. "

Merci!




Publicité
Poster une réponse
Anonyme