Sac de noeud pour regrouper des dates

Le
Manu
Bonsoir,

J'ai un etrange probleme :

En col A j'ai une liste de nom, en Col B une liste de date, en D1 une date
de debut (cette date sera tjrs le premier jour d'un mois ex : 01/02/2008) et
en E1 une date de fin (cette date sera tjrs le dernier jour d'un mois ex :
30/04/2008)

A B
TOTO 15/05/2008
MOMO 02/07/2008
RIRI 07/05/2008
TOTO 16/09/2008
TOTO 14/05/2008
MOMO 02/03/2008
RIRI 13/05/2008
FIFI 01/04/2008
TOTO 13/05/2008

Et cela sur environ 10000 lignes
alors voilà, je souhaiterais connaitre en fonction des dates de debut et
date de fin (taper en D1 et E1) combien il y a de toto dans le mois de
fevrier, mars et avril puis idem pour chaque personne.

Le but final est de faire un graphique en courbe où en x nous aurons les
mois et en y les noms.

Je sais qu'il est possible de faire cela par un TCD, mais je prefere passer
par un autre biais pour diverses raisons en esperant qu'il soit possible de
passer par un autre moyen.

Merci pour votre aide

Manu
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacquouille
Le #18093991
Bonsoir
Pourquoi "Etrange" ?
En (A2:A10000)= les noms
et (B2:B10000)= les dates
=SOMMEPROD((A2:A10000="Toto")*(Mois(B2:B10000)=1)) ----->devrait donner le
nombre de Toto recensés en janvier.
Si la plage couvre plusieurs années,
=SOMMEPROD((A2:A10000="Toto")*(Mois(B2:B10000)=1)*(Année(B2:B10000) 08))

Perso, je crois que ce sera plus simple que de passer par un >D1 et <E1.

Bonne chance
--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Manu"
Bonsoir,

J'ai un etrange probleme :

En col A j'ai une liste de nom, en Col B une liste de date, en D1 une date
de debut (cette date sera tjrs le premier jour d'un mois ex : 01/02/2008)
et en E1 une date de fin (cette date sera tjrs le dernier jour d'un mois
ex : 30/04/2008)

A B
TOTO 15/05/2008
MOMO 02/07/2008
RIRI 07/05/2008
TOTO 16/09/2008
TOTO 14/05/2008
MOMO 02/03/2008
RIRI 13/05/2008
FIFI 01/04/2008
TOTO 13/05/2008

Et cela sur environ 10000 lignes...
alors voilà, je souhaiterais connaitre en fonction des dates de debut et
date de fin (taper en D1 et E1) combien il y a de toto dans le mois de
fevrier, mars et avril puis idem pour chaque personne.

Le but final est de faire un graphique en courbe où en x nous aurons les
mois et en y les noms.

Je sais qu'il est possible de faire cela par un TCD, mais je prefere
passer par un autre biais pour diverses raisons en esperant qu'il soit
possible de passer par un autre moyen.

Merci pour votre aide

Manu




Manu
Le #18094391
Merci la Fripouille, ca fonctionne impec, mais le soucis c'est que je ne
veux voir les resultats qu'entre 2 dates taper en D1 et E1 oumême pour
simplifier je pourrais taper en D1 : 3 en E1 : 6 ce qui voudrait signifier
que je ne veux les resultats que de Mars, avril, mai et juin.

et alors là...........................

Manu


"Jacquouille" news: %
Bonsoir
Pourquoi "Etrange" ?
En (A2:A10000)= les noms
et (B2:B10000)= les dates
=SOMMEPROD((A2:A10000="Toto")*(Mois(B2:B10000)=1)) ----->devrait donner le
nombre de Toto recensés en janvier.
Si la plage couvre plusieurs années,
=SOMMEPROD((A2:A10000="Toto")*(Mois(B2:B10000)=1)*(Année(B2:B10000) 08))

Perso, je crois que ce sera plus simple que de passer par un >D1 et <E1.

Bonne chance
--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Manu"
Bonsoir,

J'ai un etrange probleme :

En col A j'ai une liste de nom, en Col B une liste de date, en D1 une
date de debut (cette date sera tjrs le premier jour d'un mois ex :
01/02/2008) et en E1 une date de fin (cette date sera tjrs le dernier
jour d'un mois ex : 30/04/2008)

A B
TOTO 15/05/2008
MOMO 02/07/2008
RIRI 07/05/2008
TOTO 16/09/2008
TOTO 14/05/2008
MOMO 02/03/2008
RIRI 13/05/2008
FIFI 01/04/2008
TOTO 13/05/2008

Et cela sur environ 10000 lignes...
alors voilà, je souhaiterais connaitre en fonction des dates de debut et
date de fin (taper en D1 et E1) combien il y a de toto dans le mois de
fevrier, mars et avril puis idem pour chaque personne.

Le but final est de faire un graphique en courbe où en x nous aurons les
mois et en y les noms.

Je sais qu'il est possible de faire cela par un TCD, mais je prefere
passer par un autre biais pour diverses raisons en esperant qu'il soit
possible de passer par un autre moyen.

Merci pour votre aide

Manu








Manu
Le #18094381
Merci la Fripouille, ca fonctionne impec, mais le soucis c'est que je ne
veux voir les resultats qu'entre 2 dates taper en D1 et E1 oumême pour
simplifier je pourrais taper en D1 : 3 en E1 : 6 ce qui voudrait signifier
que je ne veux les resultats que de Mars, avril, mai et juin.

et alors là...........................

Ou encore une autre idée : on demande le resultat pour chaque mois mais
surtout la finalité est que le graphique represente les resultats entre les
dates de fin et de debut, n'y a t'il pas une ouverture par ce biais ?


Manu
"Jacquouille" news: %
Bonsoir
Pourquoi "Etrange" ?
En (A2:A10000)= les noms
et (B2:B10000)= les dates
=SOMMEPROD((A2:A10000="Toto")*(Mois(B2:B10000)=1)) ----->devrait donner le
nombre de Toto recensés en janvier.
Si la plage couvre plusieurs années,
=SOMMEPROD((A2:A10000="Toto")*(Mois(B2:B10000)=1)*(Année(B2:B10000) 08))

Perso, je crois que ce sera plus simple que de passer par un >D1 et <E1.

Bonne chance
--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Manu"
Bonsoir,

J'ai un etrange probleme :

En col A j'ai une liste de nom, en Col B une liste de date, en D1 une
date de debut (cette date sera tjrs le premier jour d'un mois ex :
01/02/2008) et en E1 une date de fin (cette date sera tjrs le dernier
jour d'un mois ex : 30/04/2008)

A B
TOTO 15/05/2008
MOMO 02/07/2008
RIRI 07/05/2008
TOTO 16/09/2008
TOTO 14/05/2008
MOMO 02/03/2008
RIRI 13/05/2008
FIFI 01/04/2008
TOTO 13/05/2008

Et cela sur environ 10000 lignes...
alors voilà, je souhaiterais connaitre en fonction des dates de debut et
date de fin (taper en D1 et E1) combien il y a de toto dans le mois de
fevrier, mars et avril puis idem pour chaque personne.

Le but final est de faire un graphique en courbe où en x nous aurons les
mois et en y les noms.

Je sais qu'il est possible de faire cela par un TCD, mais je prefere
passer par un autre biais pour diverses raisons en esperant qu'il soit
possible de passer par un autre moyen.

Merci pour votre aide

Manu








LSteph
Le #18096691
Bonsoir Manu,

puisque fripouille vadrouille ou dormouille....
(non oublions les petits escargots)

=SOMMEPROD((A2:A10000="Toto")*(Mois(B2:B10000)=>$d$1)*(Mois(B2:B10000)<=$e$1))


--
lSteph




Manu a écrit :
Merci la Fripouille, ca fonctionne impec, mais le soucis c'est que je ne
veux voir les resultats qu'entre 2 dates taper en D1 et E1 oumême pour
simplifier je pourrais taper en D1 : 3 en E1 : 6 ce qui voudrait signifier
que je ne veux les resultats que de Mars, avril, mai et juin.

et alors là...........................

Ou encore une autre idée : on demande le resultat pour chaque mois mais
surtout la finalité est que le graphique represente les resultats entre les
dates de fin et de debut, n'y a t'il pas une ouverture par ce biais ?


Manu
"Jacquouille" news: %
Bonsoir
Pourquoi "Etrange" ?
En (A2:A10000)= les noms
et (B2:B10000)= les dates
=SOMMEPROD((A2:A10000="Toto")*(Mois(B2:B10000)=1)) ----->devrait donner le
nombre de Toto recensés en janvier.
Si la plage couvre plusieurs années,
=SOMMEPROD((A2:A10000="Toto")*(Mois(B2:B10000)=1)*(Année(B2:B10000) 08))

Perso, je crois que ce sera plus simple que de passer par un >D1 et <E1.

Bonne chance
--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Manu"
Bonsoir,

J'ai un etrange probleme :

En col A j'ai une liste de nom, en Col B une liste de date, en D1 une
date de debut (cette date sera tjrs le premier jour d'un mois ex :
01/02/2008) et en E1 une date de fin (cette date sera tjrs le dernier
jour d'un mois ex : 30/04/2008)

A B
TOTO 15/05/2008
MOMO 02/07/2008
RIRI 07/05/2008
TOTO 16/09/2008
TOTO 14/05/2008
MOMO 02/03/2008
RIRI 13/05/2008
FIFI 01/04/2008
TOTO 13/05/2008

Et cela sur environ 10000 lignes...
alors voilà, je souhaiterais connaitre en fonction des dates de debut et
date de fin (taper en D1 et E1) combien il y a de toto dans le mois de
fevrier, mars et avril puis idem pour chaque personne.

Le but final est de faire un graphique en courbe où en x nous aurons les
mois et en y les noms.

Je sais qu'il est possible de faire cela par un TCD, mais je prefere
passer par un autre biais pour diverses raisons en esperant qu'il soit
possible de passer par un autre moyen.

Merci pour votre aide

Manu











Manu
Le #18098191
Merci c'est impec, maintenant il faut qu'avec tous ca je fabrique un graph
pour chaque mois. J'y travaille et vous tiens au courant.

Merci

Manu

"LSteph" %
Bonsoir Manu,

puisque fripouille vadrouille ou dormouille....
(non oublions les petits escargots)

=SOMMEPROD((A2:A10000="Toto")*(Mois(B2:B10000)=>$d$1)*(Mois(B2:B10000)<=$e$1))


--
lSteph




Manu a écrit :
Merci la Fripouille, ca fonctionne impec, mais le soucis c'est que je ne
veux voir les resultats qu'entre 2 dates taper en D1 et E1 oumême pour
simplifier je pourrais taper en D1 : 3 en E1 : 6 ce qui voudrait
signifier
que je ne veux les resultats que de Mars, avril, mai et juin.

et alors là...........................

Ou encore une autre idée : on demande le resultat pour chaque mois mais
surtout la finalité est que le graphique represente les resultats entre
les dates de fin et de debut, n'y a t'il pas une ouverture par ce biais ?


Manu
"Jacquouille" news: %
Bonsoir
Pourquoi "Etrange" ?
En (A2:A10000)= les noms
et (B2:B10000)= les dates
=SOMMEPROD((A2:A10000="Toto")*(Mois(B2:B10000)=1)) ----->devrait donner
le nombre de Toto recensés en janvier.
Si la plage couvre plusieurs années,
=SOMMEPROD((A2:A10000="Toto")*(Mois(B2:B10000)=1)*(Année(B2:B10000) 08))

Perso, je crois que ce sera plus simple que de passer par un >D1 et <E1.

Bonne chance
--
Bien amicalmement,
"Le vin est au repas ce que le parfum est à la femme."

Jacquouille.

"Manu"
Bonsoir,

J'ai un etrange probleme :

En col A j'ai une liste de nom, en Col B une liste de date, en D1 une
date de debut (cette date sera tjrs le premier jour d'un mois ex :
01/02/2008) et en E1 une date de fin (cette date sera tjrs le dernier
jour d'un mois ex : 30/04/2008)

A B
TOTO 15/05/2008
MOMO 02/07/2008
RIRI 07/05/2008
TOTO 16/09/2008
TOTO 14/05/2008
MOMO 02/03/2008
RIRI 13/05/2008
FIFI 01/04/2008
TOTO 13/05/2008

Et cela sur environ 10000 lignes...
alors voilà, je souhaiterais connaitre en fonction des dates de debut
et date de fin (taper en D1 et E1) combien il y a de toto dans le mois
de fevrier, mars et avril puis idem pour chaque personne.

Le but final est de faire un graphique en courbe où en x nous aurons
les mois et en y les noms.

Je sais qu'il est possible de faire cela par un TCD, mais je prefere
passer par un autre biais pour diverses raisons en esperant qu'il soit
possible de passer par un autre moyen.

Merci pour votre aide

Manu












Publicité
Poster une réponse
Anonyme